PDA

View Full Version : Win32s conflict with Win 3.11 apps



nc_mike
November 26th, 2015, 06:31 AM
I am trying to figure out who on one of my PCs on which I've installed Windows 3.11 that some of my apps, such as Word and WP for Windows hangs after I install Win32s. I don't know if maybe it has something to do with the way I am configuring my DOS high memory of something else. Anyone ever run into this issue? When I remove Win32s from the equation all the affected apps run fine.

Regards,
Mike

krebizfan
November 26th, 2015, 07:15 AM
I have seen lots of Windows NT/9x programs become unhappy when run on Win32s. I have not seen Win16 programs that work without Win32s but fail with Win32s installed. The WfW 3.11 system I used way back when had both Win32s and MS Word installed and running fine.

I doubt it has anything to do with high memory; Windows programs should ignore such details. What versions of software are you using? My guess is that you installed both a 32-bit and a 16-bit version of the software and it tries running the 32-bit version with Win32s even though it is incompatible with Win32s. If you have the install disks, check for a README file that might allow you to force the software to run the 16-bit version. I don't remember how to do it and I can't think of a good term to search on.

nc_mike
November 27th, 2015, 08:31 AM
All of my Windows apps are only 16-bit. I've been researching and trying different things. I tried installing Win32 stand-alone first. Then I restored a clean version of Win3.11 and tried installing the Al Unser game that also installs a copy of Win32s- same result. When I try to start the Al Unser game I get a DOS error ("Unexpected DOS Error: 21") message in addition to MS Word and WordPerfect hanging on startup. I tried several other things such as increasing the FILES to 150, setting a higher smart drive cache for windows to 512, then 1024 and 2048 - those had no effect. I also tried 32BitDiskAccess settings in both on and off mode - same symptoms. Here is my list of installed software and my autoexec and config.sys and hardware profile:

HARDWARE PROFILE
________________
Dell Dimension 3000
CPU: 3.4Ghz
RAM: 2GB
Main Drive: 120GB SSD (also tried with an EIDE HDD, same Win32s issues)
ZIP100 Parallel
CD/RW Drive
DVD/ROM Drive
Matrix Millennium II Video Card
Intel EtherExpress PRO/100B Compatible On-Board NIC
Onboard USB
Display: 20" LCD
Aureal Vortext Sound Card




AUTOEXEC.BAT

@ECHO OFF
SET MGA=C:\MGA\SETUP\
LH C:\WINDOWS\SMARTDRV.EXE /L
LH C:\WINDOWS\MSCDEX.EXE /S /D:MSCD001
PATH C:\WINWORD;C:\MSIE50;C:\WINDOWS;C:\DOS;C:\KEDIT;C: \FL;C:\MTCP;C:\TRUMPET;INTEL100;%PATH%
path C:\ALDUS;C:\PM4;%PATH%;
SET TEMP=C:\TEMP
LH C:\DOS\MOUSE.COM
LH C:\DOS\DOSKEY.COM
VER
SET MTCPCFG=C:\packet\tcp.cfg
C:\INTEL100\E100BPKT.COM 0x63 16 FAST FULL
C:\TRUMPET\WINPKT 0x63
C:\MTCP\DHC

CONFIG.SYS

DEVICE=C:\DOS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE NOEMS
DOS=HIGH,UMB
REM [FOR ADDT'L RAM] DOSDATA=UMB (frees up more memory for DOS but disables CTRL-ALT-DEL reboot when used)
SHELL=C:\DOS\COMMAND.COM /E:2048 /P /H
FILES=150
BUFFERS=40
DEVICE=C:\DOS\SETVER.EXE
lastdrive=Z
DEVICEHIGH=C:\OAKCDROM.SYS /D:MSCD001
DEVICEHIGH=C:\DOS\POWER.EXE
STACKS=18,256
DEVICE=C:\WINDOWS\SMARTDRV.EXE /DOUBLE_BUFFER
DEVICEHIGH=C:\WINDOWS\IFSHLP.SYS
INSTALLHIGH=C:\DOS\SHARE.EXE /F:5120 /L:2000 RE


Windows Software Installed
---------------------------
Windows 3.11
Graphical Desktop over Windows 3.1: Calmira II (Win 95 UI clone)
Internet Explorer 5.0
Trumpet Winsock
MS Word 2.0
MS Office 4.3
MS Word 6.0
MS PowerPoint 4.0
MS Excel 5.0
MS Access 2.0
WordPerfect 6.1 Suite
WordPerfect 6
Quatro Pro
Corel Presentations
CorelFlow
SideKick 2.0
Lotus 123 V5
MS Project 4.0
MS Publisher 2.0
Page Layout: Aldus PageMaker 4.0
Microsoft Video for Win 1.1
ACT 2.0
Turbo Pascal for Windows
Adobe Photoshop 2.5
Kedit/Wndows
WS/FTP pro
Video Player: Xing MPEG Player
Symantic ACT! 2.0 Windows
TopDown Flowcharter
Peachtree Accounting for Windows
Contact Manager: Contact Master
Frame FrameMaker 4
MP3 Music Player: WinPlay3
Grollier MM Encylopedia 98
QuickTime 2.1.2
Accounting: One Write Plus
---------------------------------------------------

DOS Software Installed
-------------------------------
OS: IBM PC DOS 7.1
Driver: CD Driver
Driver: Zip Drivers
Driver: Intel 10/100B Packet Driver
Desktop: Quarterdeck DeskView 2.0
Word Processing: Mansfield KEDIT Word Processing: WordPerfect 5.1
Word Processing: IBM Script/PC Composer (diskette)
Word Processing: DWSCRIPT
Publishing: IBM BookManager Read Publishing: Acrobat (DOS)
File Manager: IBM FileList
Utility: IBM Fixed Disk Organizer
Utility: System Utility: SysInfo7
Utility: SysTest
Utility: IBM 4019/4029 Soft Fonts
Database: Ashton-Tate dBase III Plus
Graphics/DOS: Harvard Graphics 2.0
Spreadsheet/DOS: Lotus 123 2.4
Spreadsheet/DOS: VisiCalc
Accounting: QuickBooks Version 1.0
Accounting: One Write Plus
Communications (Dial-up): QMODEM
Communications (Dial-up): ProComm+
Internet: TCP/IP Stack/DOS): mTCP
Internet: TCP/IP Stack/Windows: Trumpet Winsock with a DOS shim
Internet: Browser/DOS: Arachne
Game (DOS): Space Invaders
Game (DOS): Monopoly
Game (DOS): Cyborgirl Pinball
Game (DOS): Jeopardy
Game (DOS): Wheel of Fortune
Programming/DOS: Turbo Pascal 6.0
Multimedia: MIDI Software: Voyetra Sequencer Plus Pro
Multimedia: CDP (CDPlayer)
Productivity/DOS: Cash Register (DOS): Point of Sale Cash Register
Productivity/DOS: Family Tree Maker
Productivity/DOS: Policies Now

Regards,
Mike

krebizfan
November 27th, 2015, 10:10 AM
That was not what I was expecting: a Pentium 4 with 2GB. What I remember is the patch technique to make Win 3.11 run on a system with 2 GB of RAM requires Win 3.11 to run in standard mode which rather effectively precludes use of Win32s. It will crash in enhanced mode; Win32s will push it into enhanced mode. The problem tree is obvious. You may need to contact those responsible for creating the patches to Win 3.11 you are using to verify and correct problems.

It probably can be fixed but I expect all the patches needed would result in having a very buggy Win98SE system showing a Win 3.11 About box and Win 3.11 Window ornaments.

Chuck(G)
November 27th, 2015, 10:57 AM
Another approach might be to run DOSBox for those 16-bit apps, if WIn98SE won't run them.

nc_mike
November 27th, 2015, 03:35 PM
Oddly enough, I DO have Win32s running on the exact same HW configuration on a Dell Dimension 8200 running at 2.8GHz with no mods to Windows 3.11. I am beginning to think it might have something to do with the difference in the motherboard chip sets. The Dimension 3000 and 8200 are very much alike with the 3000 being a mini tower with on-board video/nic and a different chip set than that of the Dimension 8200 series. So far, that is the only difference between the two systems other than the video cards (The 8200 has a Matrix Millennium G400 AGP and the 3000 has a Matrox Millinium II PCI); both machines have 2GB of RAM.

Regards,
Mike

nc_mike
December 4th, 2015, 10:09 AM
OK, now I am truly baffled. To recap, I have two fast Dell Dimension systems - one is a Dimension 3000, the other is a Dimension 8200. I had no problem installing Win32s (any version) and having it work fine with Microsoft Office 4.2 (Word 6 for Windows specifically). On my Dell Dimension 3000, after installing Win32s, before or after installing MS Office 4.2), Word hangs on its splash screen. My 3000 is a heavily loaded and configured system so I first thought maybe the cause was some conflict with other SW, so I took another entirely vanilla Dell Dimension 3000 stock system and did a simple straightforward fresh install of PC DOS 7.1 and Windows 3.11 (DOS 2000/Win3.11 - the same as is working fine with Win 3.11 and Win32s on the 8200), installed Win 32s (works fine after install and before installing Office 4.2/Word 6), then installed Office 4.2 (and also tried Office 4.3 later - same results). Even with this being the basic configuration WinWord 6 hangs on its splash screen after Win32s has been properly installed and verified. Of course I also tried reversing the install sequence - first DOS/Win3.11, then Office 4.2 (works fine), then Win32s (Win32s works fine), but then try to start Word 6 again afterwards and - hang.

I just don't know what to look at next to diagnose the issue. I did check the BIOS settings and made sure Hyperthreading is disabled, Anything else to examine?

Regards,
Mike

krebizfan
December 4th, 2015, 10:37 AM
What version of Win 32s are you using? The webpage linked below suggests Office 4.2 will work with Win 32s 1.25 but not Win 32s 1.1 or Win 32s 1.3. Though really, the fact that any of this can run at all is an impressive feat of compatibility. The hardware is about a decade newer than the software and the application was designed for a different API than the one you are using.

http://virtuallyfun.superglobalmegacorp.com/2011/04/03/office-4-2-for-windows-nt/

nc_mike
December 4th, 2015, 10:50 AM
What version of Win 32s are you using? The webpage linked below suggests Office 4.2 will work with Win 32s 1.25 but not Win 32s 1.1 or Win 32s 1.3. Though really, the fact that any of this can run at all is an impressive feat of compatibility. The hardware is about a decade newer than the software and the application was designed for a different API than the one you are using.

http://virtuallyfun.superglobalmegacorp.com/2011/04/03/office-4-2-for-windows-nt/

I'll go back and try Win32s 1.25 - my recent testing was with 1.1 and 1.3(s), but not 1.25 (though I thought I tried 1.25 at one point I am not entirely certain.

Yam, the fact that its working great on the 2.8GHz Dell Dimension 8200 is itself amazing. I've gotten everything else but Win32s working on the 3000 which I wanted to do because that one has got a 3.4GHz CPU (I've even tried the 3000 with a standard 2.8GHz stock CPU - same results). If Win32s 1.25 doesn't work then I might conclude it as something to do with the 3000's chip set which is different that that on the 8200, but let me run another test using 1.25 first.

Regards,
Mike

Cimonvg
December 4th, 2015, 12:07 PM
hello
did you remember the permanent swapfile ?
win32s also wants that..
/cimonvg

nc_mike
December 4th, 2015, 08:19 PM
hello
did you remember the permanent swapfile ?
win32s also wants that..
/cimonvg

Yes, I've verified that the swap file is permanent and also tried it with and without 32-bit disk access enabled. I did go back and try Win32s 1.25 and when I do, Windows locks up with a message dialog "Unexpected DOS Error 21" after installing it, rebooting, and invoking Free Cell. I don't get that error with 1.30c Win32s installs fine and Free Cell runs fine, but both Word 6 and Wordperfect 6 lock up at their splash screens.

I also went back to a freshly formatted HDD, installed DOS 7.1 and Windows 3.1 (instead of 3.11WFW), and got the same results with Win32s 1.1 and Win32s 1.25 ("Unexpected DOS Error 21") and with 1.30c Win32s installed fine but the word processor apps lock up on launch.

Again, this only happens on the Dimension 3000's I have, not on the 8200 and not on the 500MHz Gateway GP7-500 tower - all of those load DOS7Win3.11 with Win32s and the none of the apps lock up. I've been looking though the BIOS to see if there is anything in there I could change/disable - the only thing I see that might have an impact could be the hard drive ultra DMA mode which I just noticed is enabled; I don't know if disabling UDMA would have an impact or is involved in the Win32s issue, but I have to believe the issues have to have something to do with interaction/conflict with the particular hardware or BIOS of the Dimension 3000 as I've methodically eliminated the potential software impacts (getting as bare bones as possible).

Regards,
Mike

Cimonvg
December 6th, 2015, 12:21 PM
hello again
what about bootlog.txt , any clue in there ?
/cimonvg

nc_mike
December 6th, 2015, 06:06 PM
I'll go take a look...good idea.