PDA

View Full Version : Heathkit H19 + 3P+S...what's wrong?



Nama
December 11th, 2015, 08:45 AM
So I just bought myself a Heathkit H19 terminal to complete my IMSAI 8080 set.
I know it works because I have successfully sent and received data between it an my MacBook, and also did the loopback test by shorting pins 2 and 3 on the DB25 connector.

I know the Processor Tech 3P+S (setup to mimic a 2SIO card) in the IMSAI also works, as I have, up until now, been using it connected to my MacBook.

However I can not get the 3P+S to talk to the H19 terminal, and visa versa. Nothing is received at either end.

These are the serial lines that I have hooked up to the 3P+S:

2 - Serial out
3 - Serial in
4 - RTS

7 - GND
8 - Carrier Detect

One thought is that I'm missing one of the handshaking signals.
I do not have CTS, DSR, or DTR hooked up.

Just wondering if anyone can shed some light on my problem.

Thanks.

Philip

daver2
December 11th, 2015, 09:49 AM
Assuming both ends are 25-way 'D' connectors then it is generally 2 and 3 for TX/RX. 7 for ground. And then I connect 4-5 and 6-8-20 to fake the hardware handshake lines at both ends.

4=RTS and 5=CTS.
6=DSR, 8=DCD and 20=DTR.

If you fake the hardware handshake lines at both ends and connect the pin 7s together then all you generally have to worry about is which way around TX and RX need to be.

If this works successfully - you can then work on the hardware handshake lines themselves (although at slow baud rates you may not need them anyhow).

Dave

kyeakel
December 11th, 2015, 10:24 AM
Maybe you need one end of the cable to have swapped pins 2 and 3. Null modem style? If you could talk to both ends via the same cable to your MacBook, you probably need a null modem adapter to use that cable between the H19 and the IMSAI.

Kipp

JNZ
December 11th, 2015, 01:12 PM
I can't help in this case, but I also have an H-19. Neat! Mine doesn't work though...the terminal logic seems to run, but there's no display or raster at all.

billdeg
December 11th, 2015, 03:03 PM
I love the H19 / Z19 that is my go-to terminal when I need something that works. Did you make sure you were setting the H19 the correct direction, I recall the page that explains how to set the dip switches says to look at the switches as if they were upside down. I am sure you have that right, but that's a thought.

I can set up a mirror system if need be, let me know if that will help.

Nama
December 11th, 2015, 11:40 PM
Solved!!!
Still not sure what the issue was exactly, but the comments on the Tx and Rx lines needing to be reversed got me rifling though my pile of cables until I found one that worked...is it a null modem cable???
28281
Thanks for all your help

Phil

billdeg
December 12th, 2015, 02:28 AM
Good to know, thanks. I set my IMSAI up to play around with it next week.
b

deramp5113
December 12th, 2015, 06:06 AM
I can't help in this case, but I also have an H-19. Neat! Mine doesn't work though...the terminal logic seems to run, but there's no display or raster at all.

If you're interested in selling it, let me know. I built an H-19 in college and have fond memories of it.

Nama
December 12th, 2015, 06:31 PM
Ok...maybe the terminal isn't working 100%.
I can't seem to get any of the 'Escape' codes to work.

For example, pressing ESC p should display inverse characters, or ESC H should 'home' the cursor.
I've never used a Heathkit terminal before, so maybe it's something I'm doing wrong as opposed to a hardware issue? I would expect it to be pretty basic stuff though.

Any advice from H19 or Z19 users would be most welcome.

Cheers

Nama
December 12th, 2015, 08:29 PM
I figured it out...the terminal needs to be switched to ANSI mode for this to work.
Thanks again