View Full Version : IBM RT data retreival with QIC-02 tapes

February 14th, 2016, 08:54 PM
I just need a nudge in the right direction here.

So I've got the RT with AIX 2.1 - it has commands like backup/restore and tar etc which I can use to backup files to tape and I've done so in the past successfully.

But now I've got another 150MB tape drive + QIC02 controller coming which is capable of reading the same 6150 QIC tapes and it has a normal 8 bit ISA adapter with an address select switch which I could easily put in a general IBM clone (in fact it appears it came from a Compaq originally in 1990). What I want to do is read the contents from my AIX tapes, on to a normal PC, so I can get files off the RT - there is a lot of neat stuff on it which isn't published including the source code for a VGA driver for AIX 2.1 (for a specific card unfortunately, but quite neat nonetheless).

Ideally I would use ethernet, but my card gave up long ago.

So if I'm setting up a PC system (and I have almost limitless options here) - what OS / hardware combo would you recommend?
What method would you recommend?
Any advice / ideas?
Anyone got a spare RT ethernet card :P ?? That'd save me a lot of tape work!

February 14th, 2016, 09:46 PM
Are you wondering how to support the old QIC controller? If so, NetBSD still has code for supporting the old ISA QIC controllers; you may have to rebuild the kernel however. You might also try a very old Debian distro, such as Woody to get that support.

February 15th, 2016, 08:40 PM
Are you wondering how to support the old QIC controller? If so, NetBSD still has code for supporting the old ISA QIC controllers; you may have to rebuild the kernel however. You might also try a very old Debian distro, such as Woody to get that support.

Thanks Chuck, that gives me a starting point for a build. I did a bit of google work, and found my specific model was supported in the MTIO module which was pretty neat - have a Duron sitting here doing nothing which should be ideal for a Debian Woody or Potato install.

However seems to be a bit of a bust, not only is there no capstain left, but despite dismantling it and giving it lots of WD40 love - I can't get the eject mechanism to work properly. It works a lot nicer now than it did, but when it goes to eject the "window" ends up hitting the heads. It's a nice setup - push in once to load, push again to unload, but there isn't enough movement/pressure to push the heads that little bit further out of the way. Just frustrated at the moment, cost me over 50US, and if I buy another at the going rate of 80-100 US - probably going to be in the same boat - manually fixing a capstain and crossing my fingers nothing else is broken.

On the upside, I probably have a good controller, (Wangtek 0775) and another 6150 tape cartridge.

If anyone knows of a common eject fault issue that I probably have with a Wangtek 5150EQ, please let me know :)

February 15th, 2016, 09:15 PM
That's a problem that's begun surfacing in spades in the past few years. I've got a QIC-36 Wangtek drive here too and its capstan has gone south. The eject still works okay, though--I don't know if it's the same as yours, however.

In a pinch, you can try one of the older Tandberg SLT drives with a SCSI interface. Some of them will honor the older QIC formats.

February 16th, 2016, 11:10 AM
Yeah I had it with my IBM 6157-002 as well, but by chance somebody was selling brand new full capstan assemblies at the same time on ebay - so I got lucky there.

Thanks for the Tanberg reminder - I've got two pulled from an RS/6000 setup around somewhere. I didn't even think of these because for some reason in my head I thought they weren't compatible. I'll dig them out and look up the model numbers - fingers crossed.

February 16th, 2016, 08:10 PM
Ok well it seems my other drives are in my storage unit, so probably wont poke those until Saturday. But I did find the tapes it came with, and they're QIC525. So I'm guessing here, but probability looks good for them reading and maybe writing QIC150. Tapes are labelled as backups of someone's business documents from 1997 - surprised they got donated to a charity.

In other news, I fixed the eject mechanism on the Wangtek 5150EQ - there is a bar underneath that runs the length of the drive, overtime it loses a bit of strength and requires adjustment - Wangtek was nice enough to actually have a screw down block which is used to make the adjustment, so now I can pop tapes in and out.

Have been looking at guides online of capstan repair, my favourite/looks the easiest might be heatshrink tubing - possibly with a touch of adhesive and multiple layers (the gap is quite large). If it wears too much, I'll do a ring of better material on the outside. Unless I can find the actual measurement, will be a bit of guesswork on size. Any tips welcomed on that, probably wont be until the weekend again.

February 16th, 2016, 08:24 PM
It might be worthwhile to have Terry rebuild one (http://www.terrysrubberrollers.com/). He does good work.

February 16th, 2016, 08:43 PM
I noticed him mentioned in an old thread when I was googling, but didn't think it was still in operation. That's brilliant, thanks for the link.
He has a photo of Wangtek 5525ES drive capstans he's done too which look identical to mine [ except my rubber is 100% gone ].

Of course if I go that route I may be waiting two months (living in NZ etc), but if the Tandberg's get the job done anyway, then that wont matter. If the Tandberg's are faulty for the same reason, I might do one home job, and then see if he can do me a batch. I've also got a 23MB QIC drive in the AT&T 3B2-400 that's no doubt long gone as well.

February 19th, 2016, 08:08 PM
The Tandberg (actually it's a legit IBM 7207 external unit I had) seems to have a capstan in good shape, so tonight I'm building a Duron 800 running Debian Woody, and will try it out.

On the topic of the original QIC drive from Wangtek, I picked up a tip that somebody mentioned 5/16" ID (5/8" OD) fuel hose as a candidate for the Wangtek 5000 series drives, and it looks pretty good!
I'll try it out at some point to confirm, it certainly engages the tape perfectly but whether or not I've created a tape speed issue needs to be checked.


February 19th, 2016, 08:32 PM
The problem with neoprene hose that I found was that it's far from really round. Maybe you'll have better luck. I've considered using some Tygon hose as a possibility.

February 25th, 2016, 11:24 PM
Just wanted to post a quick update.

I'm still working on my host computer, I ran in to all sorts of issues with the Duron and various Debian / RedHat installs, none would detect my AHA1542-CF, I suspect it was an issue with the PCI to IDE bridge.
The Tandberg TDC3800 however when reset, did rewind/fast forward the tape without getting goop on it.
Then some of my cheaper used tapes that I got with the drive (600XTD) actually started failing themselves, but my recently unsealed DC6150 tapes seem fine in it.
I also reassembled the power-steering-hose driven Wangtek 5150EQ - and was able to get Linux to reset / rewind and talk to the controller, but DMA errors ensued and prevented any read/write testing.

Moved to a 486DX2/66 Acer Acros, which turned out to have onboard SCSI, which seems to cause NetBSD 1.6, and 3.0 to crash during boot (neato).

So now I've pulled out a 486DX/40 I have - going to install either NetBSD 1.6.2 or 3.0 tonight (I've created the media for these). I was quite impressed with old NetBSD, rather than slaughtering me with irrelevant messages on startup, it provided logical information in a concise and informative manner so I felt like I actually knew what was going on and what hardware was picked up. I plan to leave this as a dedicated NetBSD machine with multiple floppies + QIC drives, that I can leave headless and SSH or Telnet in to.

The home made capstan on the Wangtek is *not* perfectly round, I did find a small lump, but I wont know how much of an issue that'll be until I write a tape with the 6157-002 and try reading it. Chances are the Tandberg 3800 will read it, but I want to see if it worked well enough to be usable.

March 3rd, 2016, 08:29 PM
I am victorious!

NetBSD 1.6.2 + 486 + Adaptec 1540 + IBM 7207 QIC525 Tandberg
AIX 2.2.1 + IBM RT Model 135 + QIC-150 + IBM 6157-002

Used tar, which is found on the AIX Extended Services disks under "Administrative Utilities" and 6150 tapes.

tar -c -v -f/dev/rmt8 -s10500 -d1250 -C800 *

and then on the other end tar -x.

Nice! I'll post links to the interesting stuff once I get it uploaded. Cobol for AIX appears to be one of interest, as is the Matrox VGA driver, and the previous "IBM Engineer" left lots of stuff on it.
Haven't tested the repaired Wangtek yet, but I'm quite happy at the moment.

March 4th, 2016, 12:37 AM
Fun fact: the same rubber they used on the capstans, is also used in the roller that inside the tape.
Fun fact 2: in a molten state, it's very effective as a glue

Al Kossow
March 4th, 2016, 08:37 AM
Fun fact: the same rubber they used on the capstans, is also used in the roller that inside the tape.

There is no rubber inside of a DC300 cart, the wheel is plastic.

March 5th, 2016, 12:29 AM
There is no rubber inside of a DC300 cart, the wheel is plastic.

I'll open one of the dead tapes up and look, I know the wheel itself is plastic.

What actually happened was during testing many of the old tapes I was given were jamming up, then I used fresh tapes and had no problem at all.
In hindsight, perhaps the other tapes just jammed up for some other weird reason, and this particular 3M had goo in it from my 6157 when I first got it.

None of my tapes that were unsealed in the last 12 months had any issue in either drive, however the old tapes (two brands, around six tapes, mostly with '1998' hand written on them) jammed / goo'd up.
The jam occurs when first inserted in the drive, where it does a very short rewind/forward/rewind/forward operation - don't even have the option to retension, seek, or rewind before the tape is ruined.

March 5th, 2016, 09:11 AM
Al's correct--it's all hard plastic (nylon for wheels?). It's the dead polyurethane tension belt that goes bye-bye.