View Full Version : Problems with the serial lines

April 16th, 2016, 11:21 PM
I have 386dx-25 PC with two 8450 UARTs under DOS and a modern PC with 16550A UART under Linux/DOS. I could find only one way to transfer a file from DOS side--to use mode com1:9600,n,8,1 and then copy con1 FILE or copy FILE con1. It works for files less than 50 KB in size so I have to split the longer ones. :( I tried ppp for DOS (dosppp, lsppp) in an attempt to work with Linux but this failed. :( I tried to use Norton Commander Link, Digital Research Filelink, Zip, and PDZM on both PCs. Nothing is working. :( Thanks in advance for any hint.

April 17th, 2016, 12:40 AM
I wonder if a copy of the KA9Q/NOS software for DOS might work. You may need to use a SLIP link, its been a while since I used it, (I assume Linux still supports SLIP) but it has FTP....


looks like MINIX 3 is of no utility as it needs a Pentium or later. You might also try MINIX 2 but that would be messy as no slip driver is included.

April 17th, 2016, 03:30 AM
Maybe you can use the old DOS version of FastLynx.

April 17th, 2016, 12:04 PM
Filelynx 2.0 is the fantastic tool. It has diagnostic which shows that COM1 is broken. I began to use COM2 and got more than 10 kilobytes per second with old 8450! I was sure that it can't make more than 1 KB/s. Norton commander link begins to work too and it can also give 10 KB/s. Thank you very much for this help.
I hope to find opportunity to play with KA9Q NOS TCP/IP...

April 17th, 2016, 12:34 PM
Glad you have things working, even if you didn't use my suggestion. Pity about COM1