PDA

View Full Version : IBM AT 5170 floppy drive compatibility puzzler



1980s_john
April 25th, 2016, 01:22 PM
Hi,

I am setting up an IBM AT with a 1.2MB floppy drive. I have an IBM DOS 3.3 boot disk (in 1.2MB format), and four 1.2MB drives, all set as drive A: with terminator:
- Panasonic JU-475-3EAF
- Mitsubishi 504B
- Epson SD-680L
- Chinon FZ-506

This evening I connected each drive to a newish PC (Intel D865 motherboard with Intel Pentium 4) and they each booted off the DOS 3.3 floppy disk with no problems. However, only one drive (sorry forgot which - it was about 2 months ago!) booted the floppy on the IBM AT.

Are their any jumpers on the AT floppy controller, or on the drives, that the IBM AT has that I need to check? Or ROM versions? Any way to change the stepper rate for example?

Any other tips / suggestions welcome, my next idea is to try another IBM AT as a comparison.

Regards,
John

per
April 25th, 2016, 01:30 PM
Have all the drives been used in vintage PCs before?

1980s_john
April 25th, 2016, 02:00 PM
No they haven't.

Regards,
John

per
April 25th, 2016, 02:07 PM
Ok! Check the jumpers on the drives regarding the Ready-signal. The PC handles this a bit differently than most other Shughart derivatives. Also check that all of them are set to ID1.

In the PC, the line is also used to detect disk-change. The ready signal is turned off when you change the disk, and the computer have to step the head one track to turn it back on if there is a disk in the drive. If there is no disk, it remains off. This behavour is expected by the PC.

Stone
April 25th, 2016, 02:12 PM
Check the Drive Select jumpers to be sure that they're all on position 2. On some drives this could be named #1 and on others it could be named #2 depending on whether the numbering sequence begins at 0 or 1. For sure, the one that booted correctly has this jumper set right.

pcdata76
April 26th, 2016, 05:07 AM
I had a similar problem with my 5170 (Type-1 board with 1984 BIOS). I prepared a DOS boot disk and 5170 advanced diagnostics disk. Tested both on 5155, booting fine (although advanced diags thows an error as it expects 5170 but boots fine) Drive is a 1.2M Epson SD-680L, which is tested good on many of my computers. I dont have a genuine IBM HD floppy disk controller so i used different ones (an ISA ide/fdd controller, another ISA SCSI controller with FDD interface etc.) but couldn't managed to boot from any of the disks which i've prepared. I suspected from bios and flashed the AMI BIOS on minuszerodegrees and replaced it. Computer is now booting fine. Then, i tried recent IBM 5170 BIOSes, both are working fine too (of course with error 601 due to the non-ibm fdd controller but boots fine from floppy and after booting i didn't saw any problem on read/write) I thought that genuine chips and verified them. Despite they look OK at verification, burned 84 BIOS on new chips but didn't managed to boot again.

Note: Drive select jumper is at 2nd position (DS1 / DS2). Didn't checked ready/disk change jumper (i dont even know Epson SD680L has one or not)

I suspect that first revision BIOS of 5170 (1984) is expecting genuine floppy drives (or some others too, but does not work with all brands).

1980s_john
April 26th, 2016, 02:04 PM
Hi,

[EDIT 23:30]
I have the original IBM AT floppy/hard disk controller. I don't want to swap that out (or the ROMs) as this is meant to be an original IBM AT.

I tried all 4 drives, the Epson and Chinon booted fine on the IBM AT first time.

On first attempt the Panasonic JU475-3EAF just ignored the floppy and went straight to Basic. Jumper for DS2 (starts at 1) set, couldn't see Ready or speed jumpers. However I later plugged it in again and now it is booting fine on the AT. Guess it needed a bit of warming up!

The Mitsubishi 504B did try and boot but gave 'Non-system disk or disk error' messages, pressing a key just made it try again with the same error.

I found Mitsubishi manual here:

http://maben.homeip.net/static/S100/mitsubishi/diskette/Mitsubishi%2050xB%20diskette%20specifications.pdf

All jumpers look fine. DC jumper is set ie 'Disk change (reset by step) on pin 34'. This drive also has jumpers to set 300rpm or 360rpm so I think this is a 'keeper' for my PC set-up, for any future disk copying.

I am thinking about tolerances on the IBM AT card, maybe RPM is off, or signal level is off. It is over 25 years old and I have a working set up with 3 drives out of 4 so am now very happy! Thanks for the tips,

Regards,
John

Stone
April 26th, 2016, 02:26 PM
The solution seems quite obvious (at least to me)... use the Epson and Chinon for the IBM AT and the Panasonic and Mitsubishi for another purpose. :-)

SomeGuy
April 26th, 2016, 02:28 PM
On the Panasonic, when it tried to boot, did the light come on and the motor spin? There is not much beyond a bad connection or missing magic smoke that would prevent that from happening.

The Mitsubishi 504B also seem odd. The non-system disk error means that it read the boot sector OK. So why not the rest? The most likely cause there is perhaps the head got stuck. I'd also double check that the disk was still OK.

1980s_john
April 27th, 2016, 02:25 PM
I plumped for the Chinon in the AT. First time it played up with a 'Non-system disk or disk error' message, then after powering off and reseating both ends of the floppy cable it worked fine.

I'll give the Mitsubishi a try in another IBM AT, and re-try it on the PC (where it worked fine a few days ago). I am thinking the edge connectors used in the AT are not the most reliable connectors, especially as this particular AT has some major case corrosion. This was due to me storing it for years with a BIOS battery made up from 4xAA alkaline cells. When I moved it this brown corrosive liquid poured out - lesson learned to NEVER store anything with alkaline batteries fitted! It is amazing the machine cleaned up quite well and now works at all.

Regards,
John