PDA

View Full Version : 5160 Xebec HDD controller issues



Denniske1976
May 4th, 2016, 07:12 AM
Hi Guys,

I was just wondering about something and thought I'd ask here...

I was going through my IBM pile of stuff (because of that weird floppy drive issue with the 5150) as I wanted to know if everything in storage still works. Well it does except for one thing:

In my 5160 (one of them, older model with a Seagate ST-412) the HDD controller card was shot... again! I think this is really weird, I've had thos powered on about 6 months ago and it was working... this time a 1701 error. At first I thought the ST-412 would be dead because it's the oldest working HDD I have without even one bad cluster on it!! (YAY) :-) But I thought that'd be weird since I had put it away working 6 months ago. So I tried the hard drive in another XT and it was flawless... OK so I guess the controller must be bad... tried another Xebec controller (I have a pile of these things) and again, 1701 error. After trying about 5 controllers (versions with and without jumper block) I had one controller that did the job again and everything worked. Tried the other controllers with another harddisk in another computer and every combination gave ma a 1701.

So uhm, bottom line is: I was actually thinking, is there anything that's known to genrally fail with these things? I now have about 5 IBM Xebec controllers that all give me a 1701 error that have been put away in working condition! It almost looks as if these thing die from looking at them LOL. There's nothing to see on the cards and also I couln'd find any blown tantalums. There's nothing about this on minuszerodegrees so I might just be seing ghosts here, but I thought this was quite typical... take a box of Xebec controllers and find the only one working :oops:

Anyone?

Stone
May 4th, 2016, 07:48 AM
Capacitors (of any type) are always the first component to suspect. They don't always give visual clues as to their actual condition and may need to be checked electronically to verify their condition.

SpidersWeb
May 4th, 2016, 11:43 AM
Failure is certainly possible, but I've found it to be quite rare, but that's just my personal experience.

There is also the possibility of oxidised or damaged cables/connectors that are skewing results - worth checking if you haven't already.

When was the last time you performed a low level format / factory format on the ST412?

I'm wondering if the drive is borderline, and some of the controllers are a bit more sensitive than others.

SomeGuy
May 4th, 2016, 12:16 PM
It is improbable that they all failed in the same way. There is probably some other cause.

Are all of these cards the exact same model? If not then you may need to perform a low level format before it a specific controller will recognize the drive.

If they are of the same model do they have the same ROMs? With some hard drive controller cards of that time period, OEMs would modify the ROMs, mainly to accommodate drives with different parameters. If your drive does not match the expected parameters, it may return an error.

Double check that your cables are OK and connected properly. Then triple and quadruple check them. (frikkin cables :) )

Chuck(G)
May 4th, 2016, 01:25 PM
"1701" is pretty much a catch-all error for "there's something wrong with your hard disk setup".

To see if the controller's responding, do a write of anything to port 322h to enable the controller, then read port 321h. If you get anything back other than FFh, the controller is responding--the problem is most likely in your connection/setup to the hard disk itself.

modem7
May 5th, 2016, 01:18 AM
I now have about 5 IBM Xebec controllers that all give me a 1701 error that have been put away in working condition! It almost looks as if these thing die from looking at them LOL.
I agree with SomeGuy. It is unlikely that five of these failed in storage.

By the way, the "1701" is generated by the BIOS ROM on the IBM-Xebec controller. So, if all five have indeed failed, the failure is not in the BIOS ROM related circuitry.

I know that all three variations of the IBM-Xebec controller use the same low-level format (http://www.minuszerodegrees.net/hdd/low_level_format_1.jpg) on the platters. If I go to my working IBM 5160, one with an IBM-Xebec controller and ST-412 drive, I can swap out the IBM-Xebec controller for any other another variation of the IBM-Xebec controller, then observe that operation is not affected.

If I swap out the ST-412 for a 'foreign' drive, I need to go through the low-level format procedure, etc.

I wonder if your testing situation isn't being complicated by something intermittent (e.g. +12V from power supply, ST-412, cabling).
For each of the suspect controllers, use of a procedure like the following would pretty much be conclusive about the faulty status of the controller.

1. Start with known working configuration.
2. Observe no error at power up.
3. Swap out the known working IBM-Xebec controller for a suspect one (doing nothing else).
4. Observe 1701 error at power up.
5. Swap in the known working IBM-Xebec controller (doing nothing else).
6. Observe no error at power up.
7. Swap out the known working IBM-Xebec controller for the suspect one used in step 2 (doing nothing else).
8. Observe 1701 error at power up.
9. Swap in the known working IBM-Xebec controller (doing nothing else).
10. Observe no error at power up.

If I saw that, I would definitely be putting the suspect IBM-Xebec controller on the faulty-to-be-fixed pile.



Tried the other controllers with another harddisk in another computer and every combination gave ma a 1701.
That experiment is only valid if you know that the existing low-level format (http://www.minuszerodegrees.net/hdd/low_level_format_1.jpg) on the platters of the "another harddisk" is compatible with the IBM-Xebec controller.

Denniske1976
May 5th, 2016, 04:49 AM
So uhm, according to modem7's post I do have 5 of them on the "faulty-to-be-fixed" pile... now to just find out what it could be. I indeed did test the controllers that way and after having them reused with the original harddisk that worked (and remember, I put the 5160 away 100% working about 6 months ago and even that controller now gives me a 1701 with the harddisk and cabling that was attached).

And that's exactly the reason why I was wondering if there's any sort of "Oh yeah, just cut off C56 and C58, that'll be the problem" kind of know fault with these controllers as for me it's also hard to believe that I have 5 Xebec controllers that "just died sitting in a box".

I also tried low level formatting with those controllers but I just end up with either a "no fixed disk found" or "error reading fixed disk" message. I've tried about 3 different cables and two other ST-412 combinations... just nothing would go, until I had the original ST-412 back in and one of the controllers out of my spares box worked (without any format or anything, I agree that the same controller should IMHO be interchangeable with an existing ST-412).

So where could I start with fixing those controllers? I even have one very old Xebec IBM controller (1983 dated) that gives a 1701, but all the (2-legged btw) tantalums are just fine visually... I'll check the tantalums with my AVO meter and see what they do.

Stone
May 5th, 2016, 05:33 AM
Generally, I would be more inclined to believe the drives are the real problem. More often than not they tend to be the unreliable component. If you can, try some other working drives with the *bad* controllers. It's possible that with a reliable drive the controller(s) will work fine.

modem7
May 5th, 2016, 09:04 PM
... as for me it's also hard to believe that I have 5 Xebec controllers that "just died sitting in a box".
Well, I could believe it if the box had been stored outdoors for six months exposed to the rain and other elements.

modem7
May 5th, 2016, 09:32 PM
I'll check the tantalums with my AVO meter and see what they do.
If a tantalum capacitor on the card has gone short circuit, it will overload the power supply, causing the power supply to shut down. You are not seeing that.

If a tantalum capacitor on the card has gone open circuit, you are unlikely to see any effect, since it (working together with other capacitors) is simply helping to filter out electrical noise from a voltage rail. If we hypothesis that your computer/s is, for whatever reason, generating a lot of electrical noise, I would expect that the loss of a filter capacitor (if it was going to have an effect) may result in soft (intermittent) errors rather than a hard (permanent) error.

modem7
May 5th, 2016, 10:05 PM
The "1701" tells us that the 5160's POST detected the BIOS ROM on the card, verified its checksum, then executed the BIOS ROM's initialisation code. The code found a problem (either with the card itself, or in its interaction with the drive) and displayed the "1701".

From the source code for the IBM-Xebec's BIOS ROM:

http://www.minuszerodegrees.net/images4/xebec_1701.jpg



So where could I start with fixing those controllers?
In with a magnifying glass, inspecting everything.

Reseat (multiple times) any chips that are socketed. Each card has two ROMs.

The circuit diagrams are available. Some of us with the required skills and test equipment would possibly, in the same situation as you, use those to work out the faulty component. Pick one card, diagnose it, then see if the other cards have the same faulty component. I am guessing that you are 'not in the same boat'.

mikey99
May 6th, 2016, 04:15 PM
Try cleaning the card edge connectors with a rubber pencil eraser. That has worked for me many times :-)

Stone
May 6th, 2016, 07:05 PM
What's the likelihood that five cards all suffer from dirty connectors?

3pcedev
May 7th, 2016, 02:50 PM
What's the likelihood that five cards all suffer from dirty connectors?

If they were all stored in the same dirty/dusty/humid place then it's not impossible; although it's more likely to be an IC failure. Takes all of 20 seconds to clean them so it's worth a shot.

Denniske1976
May 8th, 2016, 02:05 AM
They're all stored in a plastic storage box in the corner of my bedroom LOL ;-) Cleaning the connectors is worth a shot.

I'll go at it when I the time for that, right now I'm doing a late 5150 again (june 3rd 1986) with copro etc. Picked that up somewhere because it came with a pristine 5153 screen, but it's got an AST SixBoard, Hercules CGA card (didn't even know they existed) and it has a Rodime 20MB harddisk with controller (and no bad clusters) in it too, and of course a 135W PSU. It als has a 102 key AT keyboard, dunno if it's a switchable one (it's still in my car downstairs), but I thought the 5150 didn't work with an AT keyboard? It's a big heavy one, actually looks like the original PC keyboard build-wise (and just as heavy) but it's a larger AT type keyboard.

So with this 5150 opened up I can actually test all the Xebec controllers :-)

Stone
May 8th, 2016, 03:08 AM
...Hercules CGA card (didn't even know they existed)...I've got one. It's a GB200 Rev B.

Denniske1976
May 8th, 2016, 03:46 AM
I've got one. It's a GB200 Rev B.

Guess that'll be the one, there's nothing on the card except "Hercules" and the 3 chips say: "Video 200", "LPT 200" and "GENROM 200". Card is dated 1985. Don't think it's original (although I did have a few IBM 5150/5160 computers that had a Hercules MDA/LPT card in it). I'll change it for an IBM one anyway, either MDA/LPT or CGA.

I see the Rodime disk is RO252, 11MB and a Type 2 harddisk. So I could go about and test those Xebec controllers with this disk? I know that this harddisk is 100% good. Or might it not be compatible with the Xebec controllers? Most 5160 I had came with Seagate ST-412 or ST-225 (if it was the 20MB model).

Stone
May 8th, 2016, 05:13 AM
The GB200 Rev B is on the solder side of the card, just beyond the notch for the 8-bit slot.

Denniske1976
May 8th, 2016, 06:17 AM
The GB200 Rev B is on the solder side of the card, just beyond the notch for the 8-bit slot.

Yep, you're right... almost unreadable (blackened PCB lettering) but it's there all right. Week 15, 1986, GB200 REV B.

Denniske1976
May 12th, 2016, 11:26 PM
Well just a little update... as I'm having this machine open now anyways and it's got a 135W PSU in it I've started to test my stash: CGA cards, MDA cards, controllers etc.

I also had a bunch of IBM CGA cards that wouldn't work. Although these would make the machine not power up at all (just a little turn of the PSU fan and that's it). Problem with these was also tantalums, all the same BTW. C8 near the CGA connector had to be removed and all was well again. These also just have been in stock for about 5 years (maybe longer) in normal conditions (not in some moist cellar or storage unit, just in house).

I also had a bunch of MDA adapters and these were all good except for two: one generates the all to familiar "one long beep, two short beeps" but then gives me a completely normal image on the 5151 connected and I see no operating problems :oops: The other one also generates the "beeeeeeeeeep beepbeep" and then gives me a screen but it's garbled at the top, when in cassette BASIC, the lower F-function part is readable but the top where it would say "IBM BASIC xxx bytes free" etc is completely rubbish, not unreadable but it reads (*^%*$&#&()*&)%^$^%BASIC098707-^(*%$&^$#&^% etc. So ASCII characters but crispy clear LOL.

Well, just wanted to put this here... will test the rest of my adapters too but it's a big pile of cards (memory boards, serial/parallel boards, LPT boards, I have one IBM PC LAN Adapter, one of those PGA adapters but no screen to test it with). Fun way to spend saome free time ;-)

3pcedev
May 13th, 2016, 02:42 PM
For what it's worth the garbled text when in IBM basic indicates the video RAM is probably faulty.

Denniske1976
May 15th, 2016, 02:01 AM
Little update: I've been testing them controllers with a known good harddisk and known good cables. Weird thing is the "known good harddisk" is an old Seagate ST-225 that's marked "Type 1 - 10MB" for IBM PC/XT (and I couldn't get it working as a 20MB drive). This drive seemed to be shot, but with the Advanced Diagnostics disc for PC I got it low level formatted as Type 1 - 10MB again, no bad clusters and working like a charm again (before it was only "error reading disk" and even the Measurement Test and Hard Drive Test would fail from the Adv. Diag. Disk, but after it was spinning for about an hour everything started working without problems LOL).

With the disk and cabling I now have confirmed three controllers actually working (old one without the jumper block and two with the jumper block). I have about three other controllers that give me a 1701 error and I think I had one giving a 1715 error (it was late last night, not sure about that, could be 1705 as well).

Bottom line: I now have at least another working system... A very nice and clean IBM 5150 from june 1986 (so a late one) with 135W PSU, coprocessor installed, one floppy drive, that 10MB ST-225 harddisk (and it's got a "Manufactured for IBM Armonk" sticker on it). I've put in a CGA card with 5153 screen, an IBM async adapter (I like having a serial and LPT port available) and I had a bunch of QuadRAM cards lying around so I've expanded the memory from 256K to 640K with one card (because now all 5 ISA slots are occupied).

PS: Is there any way to get the PSU a bit more quiet? I've tried two of the PSU's I have but both have quite the noise kind of fan in it. Can these be interchanged with just any 12V fan with the same measurements?