PDA

View Full Version : Peaktron PX-3000 Turbo XT Board



pille
June 5th, 2016, 08:49 AM
Hello!

After moving around for some time I found my Peaktron Turbo XT board in one of the boxes. While my DTC scsi card has a bios problem, I wanted to use my MCT-IDE-8 to boot from, but unfortunately the board doesn't see the card. I tried every jumper setting possible, but nothing works. Does anyone what it could be? An MFM controller works fine on the board. Also, the board crashes or doesn't boot when set in turbo mode.

Thanks in advance!

Marco

Chuck(G)
June 5th, 2016, 10:50 AM
Do you get a signon message from the IDE-8 board at boot? If not, you may want to check the jumpers for the BIOS extension ROM address.

Also, have you depopulated your Peaktron board to the extent that there's only a display adapter, floppy controller and the IDE-8 installed? Could be a port or interrupt conflict.

pille
June 6th, 2016, 01:41 AM
There is no signon message at boot. I installed only a display adapter and the ide controller. Right after the bios prompt, something like "Turbo XT 4.77/8.00 MHz", the board prompts to insert a disc. I had no floppy controller installed. I will try again all jumper settings. Maybe, I forgot one. The mystery is, that the same controller works fine in my Commodore PC10-II.

Chuck(G)
June 6th, 2016, 07:43 AM
If you boot from floppy, can you use DEBUG to see the BIOS for the IDE-8 in memory?

pille
June 8th, 2016, 10:39 PM
No BIOS. But I will concentrate on the scsi card for now. I think opening two threads is a little bit confusing. I apologize.