PDA

View Full Version : EGA/Serial combo card problem.



Retrom
July 5th, 2016, 03:37 AM
Hi all, I have the following card installed in my 286:
http://old.vgamuseum.info/component/content/article/637-chipsatechnologies-p82c434p82c431.html
And I'm having trouble with the on-board serial controller, the EGA card itself functions just fine, but the built-in 9 pin serial port on the card has been giving me constant headaches. If I try using a serial mouse with it, the mouse is detected, but the cursor doesn't move in any application I've tried. I've also tried multiple mouse drivers and multiple mice to no avail. I've also tried various different terminal emulator with it and I can't get it to reliably send and receive data faster than 300 baud! Anything higher than that and it will send data just fine, but all data it receives just ends up being garbage. The weird thing is though, the one program that works perfectly with the card is Microsoft's "interlink" serial networking tool, it works absolutely fine at maximum port speed with no issues at all. Any ideas on what the problem could be? I've tried this card in multiple computers and have the same problems. I can find very little information about this card online (I had to figure out which jumpers on it configured the serial port by trial and error basically) so any help would be appreciated.

Retrom
July 5th, 2016, 05:46 AM
Never mind. I managed to fix the problem. Turns out the IRQ was set incorrectly. With a bit more trial and error I figured out which jumpers set the IRQ. I wish I had documentation for this card! :)