PDA

View Full Version : KIM Talking Gibberish



Moonferret
August 15th, 2016, 04:39 PM
Hi Folks!

This one has me stumped. I've just bought a set of KIM I/O + 60k memory boards from Bob at Corsham Technologies which allows me to hook up a Terminal or PC via RS232. On one of my KIM boards, everything works fine. I can enter programs via RS232, run the memory test and even use Microsoft 8K BASIC. Everything works as you would expect.

However, on the second KIM board, I can download & run all the programs from the 'First Book Of KIM' (Which only output to the LED display) and edit memory etc via the RS232 interface just fine but when I try and run BASIC or Bob's memory test program, I just get gibberish on the RS232. For example, I set the RS232 to something like 1200 baud, download BASIC, confirm data has gone into memory ok but when I run it, I just get about 10 or so random characters. Now, if I change to 4800 baud, hit reset on the KIM and try running BASIC again from address 4065, I get the usual 'MEMORY?' prompt but no matter what I press, I just get a syntax error and it takes me back to the memory prompt. Similar thing when I run Bob's memory test. I get his short welcome message but garbled followed by what should be a full stop for every pass. Program is running, just the output is messed up. As its bit banged IO, it's like the timing is messed up.

As the first board works ok, I know the IO & memory expansion boards are ok. I've run memory tests on the 2nd board's 1k RAM and that seems ok. I'm just not sure what to check next. The fact that I can use the monitor program and load and save via RS232 gives me some confidence that the 6530's are OK but it's weird that other programs that use the RS232 don't.

Anybody have any suggestions?

BobApplegate
August 28th, 2016, 05:56 PM
First thing to try is make sure you're set to 8N2. Let me know how that goes.

Bob