View Full Version : VEDIT bug on Kaypro 10

October 30th, 2016, 05:45 PM
I've tried both of the Kaypro screen configurations availabe in the CP/M VEDIT install/configure and
get the same results:
When I paste text, the display contains graphic characters

It is not until I go into command mode and back again to edit mode
that the screen gets redrawn and it looks normal.

Its not catastrophic I guess, but annoying having to go in in out of
command mode to clear up the apparent "display anomaly"
Anyone ever correct this?

October 31st, 2016, 03:14 PM
I just tried the editor Express (v1, demo version) -using a terminal version, not
a memory mapped display version, and surprisingly,
the same triangular graphic artifacts are produced on the display while I was hacking around,
which also vanished when I went in and out of the command mode.

Very suspicious. I think this points to some problem outside the editors - hardware, firmware, or

October 31st, 2016, 03:55 PM
Just tried VDE. It does it too.
The simple way to demonstrate the bug is to simply scroll lines off the top of the screen
then scroll then back on. As they come onto the screen the lines are not right;
they turn into blinking triangles.

The only editor that doesn't do it is the copy of Wordstar that is in the Kaypro 10 installation packages.
I guess MicroPro knew the secret method that avoids this, the others, don't.
I'm constrained to ws.com. That'll do. Just thought something else might be lighter and nicer.
Did some quick edits, block copies, its clean with respect to the triangle artifacts.
Of course, it doesn't have edit/command modes. so its a bit of a different beast.
The only thing I saw that was wrong was that it reports [[[ I/O ERROR ]]] on file saves,
though it looks like the file writes fine.