PDA

View Full Version : decompress AZM file?



Doug_M
November 3rd, 2016, 08:16 AM
How do I decompress a file distributed as .azm? I've got lbrext for LBR files, unzip and unarc. The latter two did not recognize the file as something to uncompress.

fritzeflink
November 3rd, 2016, 08:41 AM
How do I decompress a file distributed as .azm? I've got lbrext for LBR files, unzip and unarc. The latter two did not recognize the file as something to uncompress.



Maybe take a look into http://oldcomputers.dyndns.org/public/pub/manuals/cpm-faq.txt


Q22: What are all these .xQx, .xYx, and .xZx file types?

A: (Don Kirkpatrick)

These are compressed files, a.k.a. squeezed or crunched files. They
must be uncompressed before they can be used. They differ in the
compression algorithm; .?Q? was the first generation and .?Y? the
newest. There are many fine programs that uncompress files, but
most handle only one or two compression types (e.g. SQ111.ARC and
CRUNCH24.LBR). One program that will uncompress all three types can
be found in CRLZH20.LBR.



look at

http://oldcomputers.dyndns.org/public/pub/cdrom/cpm/beehive/compress/

Doug_M
November 4th, 2016, 05:30 AM
Thanks. I tried UCRLZH.COM which recognizes the file and uncompresses it. But it encountered a couple of CRC errors. I re-downloaded the file using a different computer (to ensure binary transfer) and the copied it to my Kaypro. Same CRC errors. However I found a program for Linux (unar) that was able to successfully uncompress the file. Well, at least it gave no errors and the ASM file has far more lines of text than what UCRLZH was able to produce. I can't tell if the file is truncated but I guess I'll find out when I go to assemble it.

fritzeflink
November 4th, 2016, 05:47 AM
So as you got problems with uncrlzh I hope my files are not bad.

Please take a look onto CFX .

CFX is a universal utility written in the C programming
language, whose main purpose in life is to make access to files
stored under the CP/M operating system accessible to users of
other operating systems. CFX may be freely used and distributed
for nonprofit purposes.

http://oldcomputers.dyndns.org/public/pub/program/pc-side/compress/cfx/index.html

or best here at the bottom.

http://www.z80.eu/cpmcomp.html

Chuck(G)
November 4th, 2016, 08:58 AM
..and then there's good old USQ.COM.

fritzeflink
November 4th, 2016, 09:39 AM
..and then there's good old USQ.COM.

Yes...

I run NZCOM oder Z3PLUS on my CP/M computers. Yes it's an easy way installing a ZCPR environment. All compressing is handled with VLU ( Video Library Utility) so I unpack files seldom manually.
One I liked was NULU before I was told about ZCPR (even installed ZCPR3 on my kaypro years ago. http://oldcomputers.dyndns.org/public/pub/rechner/kaypro/kay_ii/zcpr/index.html).
You'll find it in the Walnut Creek CDROM or here. http://oldcomputers.dyndns.org/public/pub/cdrom/cpm/kaypro/index.html
I meet with Jay Sage in the 90th and got a lot of informations from him,. I even loved the The Computer Journal.
About ZCPR see http://oldcomputers.dyndns.org/public/pub/manuals/zcpr/index.html

About TCJ see http://www.kiblerelectronics.com/tcj/archive/ (thanks for archiving, I lost my TCJ during change of residence)

That are just some remembering ...

Doug_M
November 8th, 2016, 01:51 AM
Hmm. cfx32 worked just fine with the file in question. I'll have to try another program on my Kaypro.

Doug_M
November 8th, 2016, 06:04 AM
I tried uncrlzh again and it worked fine. Perhaps my original file transfer of rtty.azm was corrupted (I re-downloaded it first to a Linux box, then from that to my Kaypro). Anyway, I've got nulu and usq (used that one before on the Model 4) on my utility disk for future use. Thanks for all the help everyone!