View Full Version : Osborne 1 booting woes

February 6th, 2017, 09:19 AM
Hi guys!
I just picked up a Osborne 1. White plastic shell version (later model?) ROM 1.43. It has the double density upgrade.
After replacing PSU capacitors, it powers on fine. However, I cant get it to boot from either floppy drive. The drives just spin, and it slowly loops "BOOT ERROR". The heads never click.

I created the floppies in an older DOS machine using imagedisk, and various images found online. I've tried creating them in both a 1.2MB, and a 180k drive (same as 360k, but single sided), both SD, and DD, and a variety of settings in imagedisk. Imagedisk is reporting the disks are OK, but that doesnt really mean much.

I'm really not sure if I'm creating bad disks, or something is up with the osborne.

Any further tips to get this going? Thanks in advance!

February 6th, 2017, 11:52 AM
The Osborne 1 was SD IIRC. Did you try writing them at 250kb/FM?

February 6th, 2017, 12:01 PM
This one has the DD upgrade card installed. But I did try both SD and DD, and various write speeds.

February 6th, 2017, 02:46 PM
I'm assuming you've done the usual things like clean the heads ...cleaned then greased the rails..checked cables etc..

Have you tried swapping the drives over to see if the second drive shows the same behaviour when it's the primary one?


February 6th, 2017, 04:31 PM
I'm assuming you've done the usual things like clean the heads ...cleaned then greased the rails..checked cables etc..

Have you tried swapping the drives over to see if the second drive shows the same behavior when it's the primary one?


Yea, I did clean the heads with iso+qtip, but didn't grease the rails. The grease was still soft, and this machine is super clean internally. I figure I'd hear a loud buzzing if the head carriage was jammed?
I didn't swap drives, as the Osborne 1 has a keyboard shortcut to force the drives to swap. Shift+Quotation, rather than Enter at the boot prompt. Cabling is good.

February 15th, 2017, 09:08 AM
I'm getting closer, but still not quite there. Replacing the 8877 made no difference. But I did manage to get ahold of another Osborne in rough shape to use for parts.
It has ROM 1.44, rather than the 1.43 in mine. It is missing the double density upgrade, but it appears it used to be there, as the glued on standoffs are present.

I swapped the drives from the parts machine into mine. Now at least I can hear the drive heads seeking when it attempts to boot. Before they just spun and did not seek. Still no boot though.

I tried the parts motherboard with my DD card installed, but from what I have read online, it may have a bad display PIA chip I believe. The screen is way off center vertically, and will only scroll partially. But it DOES sort of boot on the B drive! It gives an error "Bdos err On Q: Select" and then gives an "A>" prompt. I can perform a DIR command . However, if I push it any further by loading any programs on disk, it crashes with corrupted random characters on the screen. Bad RAM maybe?

I suppose I could try and move the suspect PIA chip from my board to this parts one, but really it's just a shot in the dark.

Any other suggestions?

February 20th, 2017, 09:36 AM
Progress! I removed and replaced the suspected PIA chip from the parts motherboard. Screen scrolling issue is now fixed. It still only barely boots, and crashes when pretty much anything is run.

Another strange issue I found is that it will only boot from the drive in the middle of the floppy cable. This occurs regardless of termination, drive swapping physically, or via keystroke, or trying another cable. The other drive will sometimes let me read the disk directory, but it wont boot, and often gives "Bad Sector" errors. Again, this is only with the drive on the end of the cable, and it doesnt matter how I swap the drives around.

Still could use help here. Suggestions?

March 22nd, 2017, 04:06 PM
I'm at my wits end with this thing. I have now gone through:

3 motherboards, one of which I replaced a bad PIA IC.
New floppy controller chips.
2 power supplies w/ caps replaced + 1 bench supply.
2 Double density PCB's, one of which I have replaced ALL logic IC's
4 floppy drives that have been cleaned and RPM calibrated, have also swapped logic PCB's around.
2 floppy cables.
Countless boot floppies both single and double density, including a fresh DD one I just purchased on eBay.

No combination of any of the above will boot. In fact, now I dont even get a partial boot! Just scrolling BOOT ERROR on all combinations.

Frustration levels are getting ridiculous. :mad: I have spent WAAAY more time on these than they're worth.
Anybody here have any suggestions before I throw in the towel and part these Osbornes out?

March 30th, 2017, 07:47 AM
Ended up being all 4 floppy drives were not functional. I successfully adapted a Gotek floppy emulator to it, and it boots right up! Here is the thread with further info. (http://www.vcfed.org/forum/showthread.php?56999-Osborne-1-Gotek-Floppy-Emulator-SUCCESS!&p=454229)