PDA

View Full Version : CD-Rom Hardware Issue?



Smack2k
February 13th, 2017, 06:04 PM
I have a 52X Creative CD-ROM Drive I am trying to put into a system I am building...the drive opens fine when the button is pressed, but after about 2-3 seconds, it closes automatically.

Anything I can do or check on the inside of the device to try and fix or is the drive just shot?

This test is being done when the computer first boots to the BIOS...no windows or DOS or anything else involved yet.

I can open it without fail each time the button is pressed, but it will close again after the 2-3 seconds...

Unknown_K
February 13th, 2017, 06:35 PM
Check the eject button switch for dirt or something else obstructing it or triggering it without you hitting the button. Is the tray making it out 100% (plastic teeth could be broken or jammed towards the rear of the tray).

Stone
February 14th, 2017, 02:36 AM
Just be ready with your disk and don't stare at the empty tray.

This is the computer testing your physical and mental dexterity. :-)

Smack2k
February 14th, 2017, 04:08 AM
Check the eject button switch for dirt or something else obstructing it or triggering it without you hitting the button. Is the tray making it out 100% (plastic teeth could be broken or jammed towards the rear of the tray).

I will check out the switch...as for it making it out 100%, I am pretty sure it is making it all the way as the tray comes out past the point of where the disc sits, about another 1/2 inch or more.


Just be ready with your disk and don't stare at the empty tray.

This is the computer testing your physical and mental dexterity. :-)

You know, that is what I figured....I always wanted to know how fast I could load and and unload a Windows 95 OSR2 CD, now's my chance!!!

Also, are the XBOX 360 size Belt replacements a good bet for most CD-Roms? Looking around on ebay and Amazon and seeing various sales of belts, some with varying sizes, some all the same type.

konc
February 18th, 2017, 10:06 AM
hehehe you brought back memories. I was working for a computer store back then and those 52x Creative drives were, apart from super cheap, a disaster (my sample is 2-3 hundred drives). They were failing at a rate way higher than all the other drives and they were notorious for doing what you're describing. In fact the behavior I saw most of the times was even faster, they would pull the tray back in not after 2-3", but immediately after opening. So yeah, you have a pretty normal drive. It works as usual :)

Smack2k
February 20th, 2017, 07:26 AM
I guess I got lucky or my disaster hasnt occurred yet....I took the drive apart, cleaned the lens (nothing to do with this issue, but what the heck), cleaned up the rails / gears, and blew compressed air through it. Plugged it back in and its working great now...Noisy as hell when it has a CD in it that is being accessed, but working. Was able to install Windows 95C with it...

Opening the drive now works good to, it stays open...

I have another Creative Drive (slower 8X version) that I have in there with it that didnt seem to have any issues and worked right out of the box it had been sitting in for years. But it also got the cleaning treatment just in case.