PDA

View Full Version : HP LaserJet 4Si rescue - now need to refurb



Shadow Lord
February 18th, 2017, 02:07 PM
Hello All,

I just got my hands on a very clean LaserJet 4Si which was showing the infamous "Error 50". I managed to get an official HP Printer Maintenance Kit for $39 shipped! So I have replaced the fuser, the pickup rollers and the transfer roller. I made a printout and the quality is less then "stellar". I am guessing this is due to the super old toner cartridge that has been sitting in the printer for years (mid 2000) in unknown conditions. HP no longer produces the 91A toner so I have to go w/ a non-OEM one. Any recommendations? Is anyone still running one of these old work horses?

Also does anyone know how to print out a config page showing total memory, if PS is installed, etc. etc.? Thanks!

Dwight Elvey
February 18th, 2017, 02:09 PM
I hope you wore gloves while installing the transfer roller.
Dwight

Shadow Lord
February 18th, 2017, 02:12 PM
I hope you wore gloves while installing the transfer roller.
Dwight

Glove?

Why gloves?


Just Kidding! ;) I did say it was an official kit - it included the gloves!

Shadow Lord
February 18th, 2017, 02:29 PM
CURSES!


So as I was typing my last message I smelled something burning. Ran over to the printer and turned it off. Tried turning it on again and at first I got "language configuration" error on the screen. I was able to reset language to English but now the printer fails to finish warm up and gives me error 50 again. So either the brand new fuser is dead or there is something else going. Anyone have any experience with these beasties?

Unknown_K
February 18th, 2017, 09:07 PM
I have a 4si in the basement. When I snagged it it was streaky and had issues grabbing paper. The guy I got it from gave me a bunch of NOS rollers and other parts for it and I purchased a new toner (HP's never opened). From then on it worked just fine (after some RAM and interface upgrades). I haven't used it in a few years so I don't know if it still works, but never had that error you mentioned. It did need some cleaning. Have you take the main board out and looked it over, could be some dead critters shorting something out. Unless you seen smoke the burning could just be dust on the heater getting burnt (how was the unit stored?).

Shadow Lord
February 19th, 2017, 08:50 AM
Unknown_K,

I took the new fuser out and the pressure roller on it had melted. This could be because the pressure roller was bad (the foam had broken down) or it could be because there is an issue with the thermoresistor/thermal regulation. The PSU looks good (supplying appropriate voltages - no idea if there is a sudden spike somewhere) so I am hoping it was just a bad fuser. I am trying to get my hands on another fuser at this point. Once I do, I will try again. Interestingly the old (original fuser) did not exhibit this issue and the lamp looked fine (I took it apart for giggles). If a third fuser fails then the problem is more serious and may be well beyond my capability to fix....

Shadow Lord
February 19th, 2017, 10:23 PM
Ok. I found a very old post on a site that describes measuring resistances. The fuser has 5 pin connections setup as such:
a D
b E
c

a,b,c are small connectors and measuring the resistance across a and c gives ~245K ohms (which based on the old post seems to be accurate).

I can not measure any resistance across the two larger/beefier connectors D and E.

However, checking continuity across the lamp proves positive (i.e. there is a short and the lamp is intact per the visual inspection).

So what seems to be burnt out is the cylindrical object that is sitting right against the fuser roller. In fact this reads open on both fusers which explains why the fuser will not warm up (it sits inline with the power circuit to the lamp). So I am guessing this is the thermo-protector switch (looks like pictures of bimetallic disc switches I found online).

Per the service manual:


The main components of the fusing system are the fusing lamp and its associated Fusing and Pressure Rollers, a Thermistor, Thermo-protector, and the AC Controller/safety circuitry in the AC Power Module. The Thermo-protector is a switch designed for over-temperature protection and opens when the temperature reaches 210 C. The Thermo-protector may not reset when the fuser cools."

I am guessing the thermoresistor is fine given the 245K ohm reading, and I know the lamp is fine given visual inspection and continuity testing so that leaves the thermo-protector switch being tripped and given that it is the issue on both fusers the problem is probably higher up in the DC controller or PSU.

I found this site (http://repairfaq.cis.upenn.edu/sam/printfaq.htm#pcfljiiiec50) which gives quite a bit of technical info on the issue for LJ III. While most solutions seem to point to a triac failure I don't think that is my problem. Please feel free to correct me if I am wrong but a triac failure would prevent power to get to the fuser so neither fuser should have powered up, correct? But my fuser powered up then burnt out tripping the thermo-protector switch. So either the thermo-protector switch did not work, or it worked but the circuit did not respond to it. I am going with a failure in the DC pcb in the temperature protection circuit which is described a few line further down on that site.

Now I am sure to an EE the description is clear as glass but to me - well lets just say I am seeing alphabet soup. Any help is appreciated! TIA!