PDA

View Full Version : Phillips LTP3230 POST issue.



Retrom
February 28th, 2017, 06:18 AM
So today I picked up an old Phillips LTP3230 286 laptop from the thrift store, it's in pretty rough shape, but it does power on. However, when I turn it on, it gives a beep code (1 long and 3 short, as far as I can tell) the display does come on though, and it goes through the memory test, and complains about the CMOS battery and so on, as one would expect, but then right when it should be attempting to boot from the Floppy or HDD, it just reboots and starts the whole process over again.

I did open the system up, and found it has 640KB of RAM onboard, and four 1 MB SIMMs, and I tried swapping the SIMMs around and I also tried booting the system without them installed (It has that 640KB onboard, so it will boot without the SIMMs) but I get the same results every time.

The beepcode indicates a bad video card on some BIOSes, but the video does seem to be working fine on this computer, so I'm not sure if that's the problem. Anyway, here's a video of the system booting, to show you what I mean:
https://www.youtube.com/watch?v=qkYgA3760_Y

Retrom
February 28th, 2017, 07:20 AM
Well as usual, I post here, and then find the solution shortly afterwards - I completely disassembled the laptop, only to discover that the reset button was stuck in :rolleyes: At least the fix was simple I guess. No idea why it caused a beep code though.

*Edit - I've since discovered that the beep code was most likely caused by faulty video ram, as the display becomes really garbled when you put it into VGA graphics mode, it seems to work fine in text mode though.