View Full Version : Kaypro 4/84 freezes after cold boot

March 21st, 2017, 10:50 PM
So, recently I acquired a Co-Power 88 board for my Kaypro. It seemed to be in a bit flaky condition, so I was careful to check that nothing was shorted before I tried connecting it to my machine. I disconnected the daughterboard from the main board, just to check that Kaypro could still boot with just the Z80 connected through it. Well, it could not.

After meddling with it a while, disconnecting and reconnecting, I popped the Z80 back to Kaypro board and started to sweat a bit.. The machine could do the cold boot, and do the directory listing etc, but now it freezes after maybe 10s after you switch on the power. Pushing reset for warm boot simply does nothing. I have tried reseating the Z80, testing with different ROM BIOS chip, and tried replacing the RAM chips, but none of these had any effect. I don't currently have a spare Z80 to try, but have ordered one just in case.

Any idea what could cause this kind of behavior?

March 22nd, 2017, 02:32 PM
Always verify that the Power Supply Voltages are withing specifications first. Next, check for a good CLOCK Pulse to the CPU. Then
check the Reset Signal. After that I'd check all the Control Signals for the CPU. If that all appears good, I'd insert a Z80 NOP Generator
and look at the Address Lines, making sure they are all toggling correctly. That only leaves the Data lines, and possible buffer IC's or
bad Memory IC's. It might even just be a bad CPU.



March 22nd, 2017, 02:54 PM
Well, that fixed up quickly. As I was going through the control signals, I noticed a bad connection on WAIT line at pin 24. Just a minor bending, and this problem is now solved. Thanks!

March 24th, 2017, 12:41 AM
Problem solved. As I was checking the control signals on Z80, I noticed a bad connection on WAIT line at pin 24. Just a minor bending, and the machine works nicely again. Thanks for the help!