PDA

View Full Version : T1000 battery pinout



hjalfi
March 25th, 2017, 10:28 AM
I made the mistake of telling some work colleagues that I was interested in old computers, and one of them bought me a 1987 Toshiba T1000 that they saw in a junk shop (the one with the ROM hard drive, 512kB of RAM and 720kB floppy drive).

It doesn't work, of course. I received it with all the screws missing from the case, and someone had half-inched the battery pack, so I suspect it may have been stripped for parts.

Without the battery pack, it won't start up, at all. The power LED doesn't even come on. The battery's supposed to be a quartet of 1.2V nicads, producing 4.8V. I actually *have* some (pulled from my T3100SX), so I might try to bodge something up; the problem is that the battery connector has four pins, and there's no indication of what they do.

The maintenance manual says that the voltage between pins 1&2 and pins 3&4 should be about 5V. This implies that pins 1 & 2 and pins 3 & 4 should be shorted together. Right now, with the 9V power supply connected, I'm seeing voltages ranging from about 4V to 9V across various pins, so that makes me kinda uncomfortable. Is shorting them together reasonable?

Additionally, I'd rather like to run the thing without batteries entirely, purely off the mains; any ideas?

hjalfi
March 25th, 2017, 01:31 PM
Hey, look what I found. Not specs, but a decently high-res photo of somebody bodging up a new battery pack... with the red and black leads shorted together:

http://core0.staticworld.net/images/article/2015/11/this_old_tech_toshiba_t1000_insides_workbench-100625976-orig.jpg

(From here: http://www.pcworld.com/article/3001853/computers/this-old-tech-the-toshiba-t1000-was-my-first-step-into-the-world-of-ms-dos.html)

Chuck(G)
March 25th, 2017, 01:42 PM
Hey, look what I found. Not specs, but a decently high-res photo of somebody bodging up a new battery pack... with the red and black leads shorted together:

From here: http://www.pcworld.com/article/3001853/computers/this-old-tech-the-toshiba-t1000-was-my-first-step-into-the-world-of-ms-dos.html)

Take another (good)look, the two red leads are connected to the white clip (+) on the battery pack and the black leads are connected to the black clip (-) on the battery pack. No shorting at all.

hjalfi
March 25th, 2017, 02:41 PM
Sorry, that should have been phrased as 'both red leads and both black leads are shorted together'...

Anyway, applying 5.1V (it wasn't happy with less) to the battery connector made it go beep and lights lit up and stuff. Eventually the drive pulsed. Typing 'DIR A:' and pressing return made the drive pulse again.

But nothing came on the screen. Adjusting the contrast did nothing. It may be that it's set to the external display. I don't think I have anything which will display composite, and I haven't figured out how to change the display setting (I tried Fn plus every key on the keyboard, to no effect).

Leaving the leads shorted together and then applying 9V to the external power socket caused the screen to flicker, the light lit briefly, then fade. Power cycling repeats this. The voltage across the battery terminals at this point is 9V. I'm going to put this as a very confused battery charger doing odd things.

I now notice that the article I linked to stated that the battery voltage was 7.2V. I also found a forum thread saying the same thing. This is incorrect; the maintenance manual states firmly that the nominal voltage is 5V, min 4.8V, max 5.5V. Adjusting the battery voltage very slightly from 4.9V to 5.2V causes the power LED to change from red to green as it no longer thinks the battery is flat, so the hardware agrees.

I don't think that it's worth experimenting more until I can rig up a battery, because I suspect that the power circuitry relies on having one present. Embarrassingly, though, I can't figure out how to get any of my existing nicad battery packs open --- they're all astonishingly well glued shut...

Chuck(G)
March 25th, 2017, 03:28 PM
I have pretty good luck either tapping vigorously with a rawhide mallet or just throwing them on the (concrete) floor a few times. It usually succeeds in breaking the seams open. Same technique for "wall wart" power supplies.

modem7
March 25th, 2017, 05:04 PM
The T1000 may be similar to the T1100 regarding the battery. See [here (http://minuszerodegrees.net/temp/2/temp_87238956125.png)]. So, for a battery-less T1100, I can power it per [here (http://minuszerodegrees.net/toshiba_t1100/toshiba_t1100_pvabps.htm)].

hjalfi
March 26th, 2017, 04:05 AM
Brute force worked to open the battery packs.

I wired up a battery pack and let it charge for a while. Unfortunately, something bad seems to have happened and now the T1000 won't do anything on poweron --- the power light changes colour to indicate the battery status, and it does seem to be charging the battery, but now the computer itself is completely unresponsive. Where previously I'd get a beep and about 30s later see the FDD pulse, now I get nothing. Removing the battery again and applying 5V across the battery connector doesn't work either.

I suspect that I've either broken it somehow or an elderly cap has given up the ghost.

The caps all look good --- no goop, no bulging. There's a mild hot-electrical smell which may be due to a white ceramic resistor which gets warm during charge. One oddity is that the power LED stays green all the time the battery is connected, even if the mains is disconnected. That doesn't seem right.

I'm not really sure how to proceed at this point.

Chuck(G)
March 26th, 2017, 09:13 AM
I'd start by checking the larger capacitors first--it's not necessary for them to be bulging to be bad--and check that resistor's value. Its not unusual for a power resistor to change value drastically when it fails.

Formulator
March 27th, 2017, 08:59 PM
Please let me know how this turns out for you. I also have a T1000 with a similar issue. The power light comes on green for a second or two and turns off. Fortunately, I had the battery rebuilt using the original wires and pin header. I used (4) SubC NiCd NUN2100-CSF cells.

37354

hjalfi
March 28th, 2017, 08:27 AM
I think I'm going the shelve this one for a bit. I have a mini composite monitor (for a car reversing camera!) on order. Before doing anything irreversible, I want to check for video signal on the composite output. It's possible that my fiddling has somehow got it into a state where it's powering on successfully but not going through the usual boot sequence of a beep and a disk pulse. But it'll be a few weeks before it gets here.

Re the power light going on and then going off again: if it fades, then that's exactly the behaviour I saw when I shorted pins 1&2 and pins 3&4 on the battery connector, but didn't actually connect a battery. I think the battery's an integral part of the power supply and with it not present it simply won't run. So maybe your battery pack is toast.

If I knew more about electronics I'd be tempted to try connecting a 5V zener diode in place of the battery to see if that'll simulate the right voltage drop.

hjalfi
May 6th, 2017, 01:42 PM
Update: the composite monitor arrived. I plugged it in, powered up... nothing happened.

So either the signal being produced by the laptop isn't what the LCD composite monitor thinks of as being a signal, or else something in the computer is fried. Either I broke it while fiddling with it, or a capacitor has faded. I'm afraid I don't think I'm up to diagnosing that. I am on the lookout for an oscilloscope with a component tester, as that'll provide a really simple way to check for dead components, but removing them from the board for testing is beyond me and I doubt I'd get a clean signal testing them on the board.

The one remaining unknown is that the monitor is a modern LCD job which automatically switches on when it detects a signal, and it's not. Can anyone confirm (or, preferably, deny) that a 1990-ish mono composite signal is likely to work with this? Are there any NTSC/PAL-like gotchas here?

zombienerd
May 6th, 2017, 02:09 PM
Leaving the leads shorted together and then applying 9V to the external power socket caused the screen to flicker, the light lit briefly, then fade. Power cycling repeats this. The voltage across the battery terminals at this point is 9V. I'm going to put this as a very confused battery charger doing odd things.


Is the original AC adapter 9V? IF you see 9V at the battery, something important was broken at or before that point, I'd reckon.

modem7
May 6th, 2017, 05:35 PM
Update: the composite monitor arrived. I plugged it in, powered up... nothing happened.
According to the T1000 summary document at [here (http://minuszerodegrees.net/manuals/Toshiba/Toshiba.htm#1000)], a keyboard sequence is required to switch screen output to the 'External display'. 'External' may include both RGB and composite ports.

hjalfi
May 20th, 2017, 11:31 AM
So I found an oscilloscope and had another go.

The PSU sort-of works, and is feeding sort-of 5V onto the board. I'm increasingly unhappy about it PSU, because the board voltage appears to be exactly what's coming out of the batteries, which can vary from 3V to 5.1V depending how tired they're feeling. So I've given up on the batteries and the 9V external power supply and am instead just feeding 5V directly into the battery terminals.

So now that it's got clean power, I can find 5V power lines at various points on the board, which means that power propagation is working. The composite port and the RGB port remain completely dead. There is some activity on the LCD connector. I found a 500khZ signal on one pin and a 2MHz signal on another pin, but the screen doesn't show anything. I tried to look for a clock on the processor but it's an exotic M80C88A QFP package and I couldn't find the pinout...

The first time I powered it up, it beeped. Then about 30 seconds later it beeped again, and the drive chugged, which indicates it was working through the bootup sequence. But it was disassembled on my bench and the screen was disconnected, so I didn't see anything, and it didn't do it again.

This feels like a marginally borked component. I can see power everywhere, so that suggests it's not the PSU, but the maintenance manual states that the LCD takes +5V and -22V, and I certainly didn't see -22V on any of the LCD connector pins. If the PSU has failed in some way where it's mostly failing to generate the right voltages, and the reset logic is waiting for all the exotic voltages to stabilise, that would explain the symptoms I'm getting...

Oh, and just to make life more fun, the manual on minuszerodegrees is for a different issue of the board than I actually have, so some of the jumpers are different.

There aren't very many PSU capacitors, and none of them are bulgy. I suppose I could just remove them all and test them, but given my soldering skills that risks irreparably damaging the board.

https://photos.google.com/photo/AF1QipPjPtRcS2dudTD3PRqEIvCDdQy8T-fsnAYdFUES

GiGaBiTe
May 20th, 2017, 11:44 AM
More than just capacitors can die in power circuitry, I've had all sorts of grief with dead transistors, mosfets and diodes. Another annoyance is if an optocoupler goes away or starts misbehaving, it can cause the output power rails to go crazy or just fail to work.

Formulator
August 25th, 2017, 09:34 AM
Finally got one of these working, but two other that have PSU issues.

http://i.imgur.com/ErWh7qv.jpg

With another unit, I'm having the same issues as user hjalfi in which the LED illuminates when the battery is connected, even before switching the power on.

hjalfi
August 18th, 2018, 02:07 PM
Okay, so I've picked this up again. I now have a proper soldering workbench with all the stuff so I tried recapping the power supply. Hey, it's not like it isn't already broken.

The good news: I made it boot!

The bad news: it doesn't boot any more.

The internal LCD doesn't work, and I can't find any +/- 15V lines on the LCD connector. This suggests that something's still wrong in the power supply. I made it boot via composite a few times, and it worked, but it got increasingly flaky and then stopped working completely. Just before it died for the last time, it behaved really oddly (video attached). I'm connecting 5V directly to the battery connector because I don't have a NiCad battery pack and the AC feed won't work without one.

Other odd behaviours:

- the power switch on the back does nothing. The ROM on the south of the board (which has a handy power feed on pin 1) remains at 5V regardless of the position of the switch (and the power light is on).
- the PSU circuitry is unhappy about starting --- a few times when I've connected the power the light will flash red, then green, then slowly fade out, and then (usually) suddenly brighten to solid green.

Googling shows that all the symptoms I'm seeing are really common. I think these machines are just flaky.

So there are two possible lines of attack: I can try to figure out why the power switch doesn't work, and I can try to figure out why the LCD power supply isn't supplying. I found a really useful writeup from someone with a failing LCD power supply (https://www.vintage-radio.net/forum/showthread.php?t=129196) who tracked it down to a single failing SMD resistor, so that's worth working through. But the switch is a weird one.

So, any suggestions? I'd love to find someone who's reverse engineered the PSU circuitry...

Here's a video clip of the really, really weird behaviour. The machine starts stuttering, running in bursts, before locking up completely. I've never seen that behaviour before.


https://www.youtube.com/watch?v=MHcmjSt9w4E

brassicGamer
September 27th, 2018, 02:57 PM
It's been a while now since this was last updated so I don't know if you've got any further. I found this thread while restoring my own T1000 so I thought I would offer my own process of restoration from my blog (http://brassicgamer.blogspot.com/2018/09/toshiba-t1000-part-2-restoration.html). The schematics seem to have been lost to time, which is a real shame. I guess in order to obtain them or do a proper reverse-engineering job it would be necessary to send the board off to one of those companies that can duplicate circuitry. I don't know how much that process costs but it's not something I would want to undertake as a solo effort!

hjalfi
September 29th, 2018, 03:49 PM
Thanks for that --- I hadn't thought of replacing the capacitors actually on the LCD board. Worth a try if I ever get the main board working again.

Speaking of which, it's shelved for now. I want to get hold of another working one, and then I will laboriously go over the power supply circuitry measuring reference voltages everywhere. This should then let me compare with the broken one and help isolate whatever's actually gone wrong, or at least let me identify the power rails so I can disconnect the power circuitry completely and replace it with a handful of modern regulators.

Sadly, Switzerland's a terrible place to scrounge for electronics. People recycle here.

sslivitzky
March 5th, 2019, 05:16 AM
Hi,

I'm trying, also, to boot a Toshiba T1000. At start, the computer would not boot, the power light would go red then go off. We found out that 4 capacitors needed to be replaced so we did it. The battery pack seems ok but we still build a new one using 4 nimh (eneloop) battery and we still have the same behavior. The power light goes green, stay green but then nothing happens, I tried without plugging the ac adaptor, same behavior. When it start, i can see some black lines on the LCD but that's it. I also tried an external monitor using the composite, nothing. Any ideas what I should check now?

hjalfi
March 8th, 2019, 07:51 AM
My gut feeling, based on lots of very very similar reports, is that the PSU circuitry in these things is trash.

At this point I'd be very much inclined, if I could find enough schematics to identify where the PSU circuitry is connected to the power bus, to just cut the lines and replace the whole module with a modern, very small power conditioning board. But the whole thing is such a maze that I haven't found where to do that. Finding the +5V line is fairly simple as it's routed to all the ICs but there are some other, odder voltages used by the LCD.

blackepyon
March 8th, 2019, 08:40 AM
Lol. T1000, as in Toshiba T1000, not Tandy 1000. I'm not in Kansas any more :P

WimWalther
March 8th, 2019, 09:03 AM
I can confirm your suspicions concerning the on-board power supply circuitry in the Tosh T1000. I was into these machines almost 25 years ago (oh my God) and they would break like a Chinese motorcycle, even way back then when they were relatively new.

The typical mode was fading screen contrast which very soon led to a blank and useless screen. I have three of them and at least two died this way - don't recall the fate of the third. It's really a shame they're such crap, as they're otherwise a very neat little machine..

hjalfi
March 8th, 2019, 01:19 PM
Mine's in really nice condition, too. No browning at all. Nice keyboard as well, even if it is ANSI; obviously not as nice as my 5140 Convertible, but still.

I have two Toshibas, both non booting. The other one's a T3100SX. That one actually worked until I somehow fried it. I still haven't figured out what went wrong or why; I'd replaced the PSU board with a custom one, and everything was fine until I tried splicing in a negative voltage generator to try and get the serial port working. At which point there were various strange noises and over a period of about five minutes it died completely. I have a T1100LE on the way; hopefully this one will survive longer...

(The T3100SX has the gorgeous VGA orange gas plasma screen. I think it's a fairly standard pinout, too. Hmm...)