PDA

View Full Version : Getting EIDE working on IBM 5170 (Future Domain IDE-16032)



DaveJustDave
April 9th, 2017, 02:36 PM
So, as stated in a prior post i have a late run 5170 (final BIOS i believe).

Picked up a future domain EIDE 16 bit ISA controller with its own BIOS.

it has got me thoroughly confused.

1. Unless i have a PnP ISA NIC in the system, it wouldn't see the EIDE card AT ALL.

2. Once i get the card recognized and have a HD plugged in, it will detect Channel 0, but not any devices on those channels. It just hangs.

3. I've tried it with the IBM gen 2 MFM controller in place driving the floppies, I've tried it with a generic IDE/IO controller (with the IDE portion disabled since i'm using the future domain card) and doesn't work

4. i've tried every combination of IRQ/IO/Base address configurations the EIDE card supports, nothing.

5. I've gone into the IBM setup and disabled all hard drives, still no luck.

I appear to have hit a wall here. Perhaps i need to replace the onboard IBM BIOS with something newer and friendlier?

Krille
April 15th, 2017, 03:39 AM
1. Unless i have a PnP ISA NIC in the system, it wouldn't see the EIDE card AT ALL.

2. Once i get the card recognized and have a HD plugged in, it will detect Channel 0, but not any devices on those channels. It just hangs.

I'm thinking there must be some kind of electrical problem with the ISA slot or the bus. Have you tried any other cards in that slot? Have you tried other slots?


3. I've tried it with the IBM gen 2 MFM controller in place driving the floppies, I've tried it with a generic IDE/IO controller (with the IDE portion disabled since i'm using the future domain card) and doesn't work
Does the IDE portion on the IDE/IO controller work without the Future Domain controller?

Perhaps i need to replace the onboard IBM BIOS with something newer and friendlier?

I'm a bit skeptical but I guess it's worth trying. All three versions of the IBM 5170 BIOS is incompatible with XTIDE Universal BIOS, perhaps this is a similar problem.