View Full Version : Tandy 1000SX Floppy drive issues

April 26th, 2017, 02:07 PM
Just as the title says. I am having various issues with my drives. the main issue I seem to have is that I cannot write a floppy disk and I cannot read some disks. I've ruled out some things as I've pulled both drives and attempted to boot without them and it seems I must have at least one floppy drive enabled to even boot the system even though I have a hard drive. I will try my best explaining about the issue as this is problem that had generated over time. I have also did a lot of reading on this before and tried to realign the heads. I am beginning to suspect that the drives in question are perfectly fine.

The tandy had came under my care over 15 years ago with two floppy drives and a hardcard. The floppy drives read pretty reliably if I had formatted the disks at 320KB instead of 360kb. never thought anything was wrong with it at the time since I was using laplink III to get stuff off and on the computer as I pleased. as the years dragged on more and more disks would simply not work and soon the only disks that would read would be the original manufactured disks to some extent. the disks I have made with copyiipc for those old pc booter games no longer worked and the original disks for some booter games even stopped. This has been an issue since I received the tandy and did not possess the knowledge I do now.

What had kick started this into life again was that I replaced the original harddrive that was already a 130MB drive with a solid state 256mb drive from Leidisk. I managed to boot into ms-dos 5 with the original disk and install with no problems, but road blocks started to crop up left and right when I went into installing games from their original disks after the backups that I had failed to work. At this time all the floppy disks in question installed just fine on the other computers I have using high density drives.

I've been following the facebook page tandy1000sx for a little over a year now and had also read up on the nerdlypleasures blogspot that great hierophant runs. I had messaged him and he had given advice that I should come here with this issue. He also said a head alignment is most likely in order and the person who runs the facebook page said that she doesn't have her floppy drives working yet and that I can probably get the chip i'd need from ebay.

As it turns out I've taken out both drives and hooked them up to another computer to help troubleshoot. Both drives can read and write now and have been adjusted using IMG2DSK to verify alignment with a regular disk that was a store bought disk. The exact disk used to test head alignment was called PC paint.
after the adjustments I tried to format a few disks at 360kb with a few of the disks that kept giving me "track 0 error media unusable" that had worked once before till I tried to write to them on the tandy. They formatted perfectly multiple times and even wrote to the disk without skipping a beat. I installed both drives back onto the tandy and tried to read a disk and it was a successful read, took out the disk and put the freshly formatted disk with data on it and it also read. Looked pretty promising so far and began to write data by copying a small file over and it failed with a seek error? then a general failure reading drive A, tried drive B with the same results, and finally attempted to format unconditionally and it gave me Track 0 Error Media unusable. This leads me to believe that my floppy controller is probably bad but still functions to an extent. I have reseated both chips that should control the floppy drives.

I'll leave with a few burning questions in hopes that I am on the right path the restore this beast.

I haven't ruled out the power supply starting to fail but if it is failing what can I replace it with?
I have ordered replacement chips to replace the WD9216 and Zilog FDC chip, while the 9216 is identical the zilog chip that is on its way to me is the same model but has slightly different numbers on the final line of the chip, will this be compatible?

June 2nd, 2017, 06:09 AM
Real sorry for a double post but its been several weeks and maybe it was missed or maybe it was a lot to read?

long story short since I can't edit my post I have received my replacement chips and installed them promptly and i'm still getting the same error.
both drives read and write just fine in another computer. the tandy 1000sx simply refuses to write a disk but reads just fine.