PDA

View Full Version : Compaq Portable +12V rail on motherboard is shorted.



alank2
April 27th, 2017, 11:17 AM
Hi,

Is this a two layer board?

What is 12V used for on it out of curiosity?

The PS shuts down very quickly after startup, presumably because of the short.

Can I feed some voltage to it from a bench power supply without feeding the other rails? Just GND and +12V (or possibly lower). I have a thermal camera and could see where any heat is occurring.

Thanks,

Alan

Stone
April 27th, 2017, 11:45 AM
It's likely a tantalum.

alank2
April 27th, 2017, 12:55 PM
You are right - I found short on a tantalum on the mainboard (C77) and replaced it with an electrolytic. Thought I was doing better until I put the video board in and another 12V rail ground failure. Replaced C16 on the video board and it will now startup. I have a blinking cursor, then some text, video looks nice. It displays an error (601) and finally displays the insert disk message. The guy who sent it forgot to include the 2.11 DOS disk, so I have no bootable media for it which is too bad. My bigger concern right now is that it doesn't respond to any keyboard input...

alank2
April 27th, 2017, 12:57 PM
It also came with a hardcard that gives some errors when trying to boot as well. I can't hear the disk spin up at all, but it doesn't take the system down like the other board with a short did.

Any thoughts on what to look at with the floppy disk controller / keyboard?

Stone
April 27th, 2017, 01:13 PM
The guy who sent it forgot to include the 2.11 DOS disk, so I have no bootable media for it which is too bad...Any DOS disk should work.

alank2
April 27th, 2017, 01:37 PM
Any DOS disk should work.

It would if I had one! All I have is a 10 pack of unformatted disks...

Stone
April 27th, 2017, 02:03 PM
USA is a biiiiiiiiiiiiiiiiiiiiig place. :-)

Maybe if you narrow it down some one of your neighbors can help you out.

alank2
April 27th, 2017, 02:07 PM
Good point, I'm near Tulsa, OK.

I got the floppy adapter fixed. It had a dead 16 MHz oscillator on it. Replaced it and it finally appears to work, no more 601.

Any ideas on the keyboard?

alank2
April 27th, 2017, 02:41 PM
Keyboard is apart, touching the pcb does result in characters. What is odd is that the foams don't look too bad, although the one I pulled off the scroll lock key came off super easy. I don't see any metal foil though. where should that be? I see what looks like the key, then perhaps tape, then foam, then a plastic cover for the foam. Isn't there supposed to be a metal disc?

alank2
April 27th, 2017, 02:46 PM
Here is a picture:

38002

alank2
April 27th, 2017, 02:51 PM
Could it be that over time the pcb has built up a film/corrosion on it? I could try to hit it with some rubbing alcohol...

alank2
April 27th, 2017, 06:37 PM
Well...I hope you guys have some ideas about the keyboard. I saw a site:

https://hackaday.io/project/7640/logs

Where he talks about using a anti-static bag. I did try some of this on a pencil and got mixed results. Sometimes it works well, other times not.

My finger always works directly on the pcb, which I am not sure is normal or not.

The pads on the keyboard honestly don't look that bad, I wonder if the sensitivity of the keyboard circuit is more the problem than the keys themselves.

I hit all the solder joints on the components with some flux and resoldered all the parts to see if a weak joint was the problem, no change.

I replaced the one tantalum with an electrolytic, it tested good when I pulled it off, no change.

Looking for ideas!!!!

Thanks,

Alan

alank2
May 2nd, 2017, 04:55 PM
Keyboard is perfect now, but it took some work. The capacitive pads I got from eBay worked well on about half the keys, but their "capacitive" strength didn't seem enough for consistent, reliable firing. I ended up cutting a ESD bag apart and double stick taping that on the foil side and they work perfectly now. My technique made it easier. Put the outside of the ESD bag down, apply double stick tape, peel liner off, stick the foam discs foil side down on the tape, cut them out, and trim them back into circles.

GiGaBiTe
May 2nd, 2017, 10:31 PM
It also came with a hardcard that gives some errors when trying to boot as well. I can't hear the disk spin up at all, but it doesn't take the system down like the other board with a short did.

If the disk isn't spinning, I'd guess either the bearing is seized or the last person that used it didn't park the head before shutting it off and the head fused to the platter. I know my hard card didn't have an auto head parking routine during power off, it had a file called PARK.COM which moved the armature off the platter.

I had the latter happen on a Compaq Portable that I had about 20 years ago. I removed the lid on the drive to find the R/W arm stuck in the middle of the platter travel and the head more or less welded to the platter. I managed to pry it loose with a screwdriver and the drive started spinning again, but obviously never worked again due to the head being destroyed.

alank2
May 3rd, 2017, 01:26 AM
I took it apart last night for fun. It didn't look bad. I applied 12V to the 12V pin on the ISA card and it wanted to spin just a little bit, like a very small movement and then stops.

KC9UDX
May 3rd, 2017, 07:48 AM
Is it a Plus Hardcard? If so, it's a shame you took it apart (maybe it could still work anyway).

When those do what you describe, you can cycle the power enough times and it will start to oscillate. Leave it oscillating until it gets nice and warm and cycle the power one more time and it will spin up. After that it will work indefinitely so long as you don't remove power. Once you remove power it's a crapshoot if it will restart or if you have to do that procedure again. If you do, you can do this at least dozens of times and it will still work. I've done this with at least eight Plus 10 and Plus 20s. For whatever reason they don't exhibit any signs of permanent damage (other than the fact that you need to do this in the first place).

I should make a Youtube video. I still have one of these that's been sitting idle for at least a decade. I'm sure it would do the same thing again.

alank2
May 3rd, 2017, 08:20 AM
I don't think it has come to any damage unless just opening it has brought some. It barely wants to move, but I'll try warming it with some power and the process you mention to see if it can get going!