PDA

View Full Version : Weird knocking sound on starting ST-225



romanon
May 22nd, 2017, 09:53 PM
Hello, I just bought ST-225 hard drive to my IBM PC 5162, it work fine, no errors, no bad blocks, but on disk starting there is weird knocking sound for few seconds. I have more ST-225s but no one do it.
Check video on cca 0:20

https://youtu.be/Z6mBX0G8Mmc

What could it be? Thanks

Roman

paul
May 22nd, 2017, 09:59 PM
sounds like it's failing to set home using a sensor and using the end stop instead

bobba84
May 22nd, 2017, 10:17 PM
While I'm not sure of the reason for this sound in my experience it's had no bearing on the longevity of the drive. So if it were me, and it worked, I'd use it.

Bobby.

SomeGuy
May 23rd, 2017, 05:18 AM
sounds like it's failing to set home using a sensor and using the end stop instead
Thing is, if it were doing exactly that it wouldn't operate, as the drive must return a track zero signal to the controller once the drive enters the ready state.

I've heard some other Seagate drives that make a similar sound during the startup tests/calibration. It very well may be ignoring the track zero sensor during the tests. What I have wondered is if most Seagate drives actually do that but have something in place to cushion the heads/stepper motor.

Either way, the long lived ST-225 product went through a large number of revisions, so not all operate exactly the same. And it seems a small number of these normally made that kind of thunking noise during startup.

romanon
May 23rd, 2017, 06:39 AM
This disk has same symptome as i see

https://www.youtube.com/watch?v=jUYo6F1Xt3I

David_M
May 23rd, 2017, 08:17 AM
It is probably the most common problem ST225 and ST238 had. I used to see it all the time some drives would develop the fault when only a month old.

They continued to work but some tended to get read errors periodically. I believe it is a problem with the track 0 sensor, my understanding is that the drive firmware does a work around similar to the way the old apple drives were designed. The apple floppy drives have no track zero sensor so on boot up the just step back a full 35 tracks then look for track 0.

The head banging is the drive looking for the track 0 servo information. It seeks back and forth where the firmware thinks it might be until it finds it.

Its not good, but I once had a drive that worked with that problem for a year or so before I upgraded to a larger drive. It was an ST225 MFM drive that I was using as an ST238 on an RLL controller. They were the same drive, the ST238's were the ones that met higher standards during factory testing and were rated for RLL encoding,

romanon
May 23rd, 2017, 08:51 AM
its some way to fix it? Can help PCB change? Or its somewhere inside disk?