View Full Version : KVM Issue with Serial Mouse

May 27th, 2017, 06:22 PM
Have an 8-Port Belkin KVM. 2 of the ports I have hooked up to PC's that use serial mice. I have the same belkin db-9 female to male cable going from the PC to the KVM Switch in both ports. The KVM then electronically switches to allow the PS/2 mouse hooked up in the console port to work.

For the Pentium 1 machine running Windows 95, the system boots up, starts to load Windows, you hear the KVM switch its modes and the PS/2 mouse works fine once in Windows

For the 486 DOS / Win 3.11 machine, the system boots up, loads DOS, loads CuteMouse software, you hear the KVM Switch its modes but when you go into Edit mode in DOS and move the mouse, the cursor just shoots to the bottom left of the screen and doesnt move from there... or if you go into WIn 3.11, there is no mouse to use at all...

Trying to figure out why the mouse isnt working for the 486 machine. Plugging a serial mouse directly into the machine works fine.

May 27th, 2017, 07:34 PM
I have a similar problem with my Starview KVM. I think it has something to do with the serial port on the machine. Using the on-board serial port on my 486, I get no mouse when connected through the KVM but it works fine with mouse directly connected. However, if I disable the on-board com port and use a com port on an expansion card instead, the mouse works fine through the KVM. What type of serial port are you using in your 486? Can you disable it and try to use a serial port on an expansion board or a different type of expansion board if that is what you're already using?

May 28th, 2017, 05:34 AM
I am using the Serial port on my controller card for the serial mouse.

CuteMouse says it's mapping the mouse to COM1 which is that port

I can try a different serial connection and see what happens. There is a serial port on the case I don't have hooked up. Can try that one.

May 28th, 2017, 11:54 AM
Took a look at the CuteMouse info and added an /S1 switch to the startup for COM1 and it worked in DOS. Said it loaded as MICROSOFT mouse

Loaded Win 3.11 and it worked in there.

Rebooted and it loaded this time as Mouse Systems Mouse and didn't work in DOS but still works in Win 3.11. Didn't make any changes to it so not sure why it loaded different after reboot and now only works in Windows.