PDA

View Full Version : Getting serial Magic Mouse to work



Rubix
May 29th, 2017, 05:02 AM
Hi everyone,

I've got a problem with a wide serial Magic Mouse. I tried to use it under MS-DOS 3 with MS drivers, but it acts weirdly.

The drivers detect the mouse but when I move it, it sends completely random signals. I think it's a driver issue. I have another Magic Mouse that has a slider button with "1" and "2" on it. Setting the slider button one way makes it act weird like this one, setting it the other way makes it act normally.

Problem is that this mouse doesn't have that slider and I can't find drivers for it anywhere. It also doesn't help with Googling that Apple has brought out a Magic Mouse many years after.

Do you guys have an idea on how do get this mouse working properly?

38842

38843

Plasma
May 29th, 2017, 05:24 AM
The switch on the bottom of serial mice usually switches between "Microsoft" protocol and "Mouse Systems" protocol. So possibly you need a driver that supports "Mouse Systems" mode. I think CuteMouse will do it.

Stone
May 29th, 2017, 05:33 AM
I have a CuteMouse 2.xx driver that supports Mouse Systems.

T-R-A
May 29th, 2017, 08:19 AM
Yep, CuteMouse is my "go-to" driver for any DOS-based machine. Small footprint, universal and works with about every mouse throw at it.

Rubix
May 29th, 2017, 10:49 AM
Thanks for your answers guys! But ctmouse seems to only work with vga or ega... this Olivetti M21 has CGA.

Stone
May 29th, 2017, 11:10 AM
I read this in the support file:

CTMOUSE displays the cursor only in standard video modes of CGA, EGA and
VGA; Hercules Graphics/InColor Card or SVGA/VESA extended video modes
are not supported but an application can display the cursor by itself in
a user interrupt routine (may be installed by INT 33/000C function) or
when idle. Remember to remove calls to INT 33/0001 (Show cursor) and
define cursor movement limits (INT 33/0007 and INT 33/0008).

Rubix
May 29th, 2017, 11:56 AM
I tried an older version which does work in this aspect. But it automatically runs in Microsoft mode...

38856

Plasma
May 29th, 2017, 12:13 PM
/M forces Mouse Systems but it might only work in versions 2.x+

Alternatively you can try the actual Mouse Systems driver:

38857

Stone
May 29th, 2017, 01:33 PM
I tried an older version which does work in this aspect. But it automatically runs in Microsoft mode...


/M forces Mouse Systems but it might only work in versions 2.x+http://www.vcfed.org/forum/showthread.php?58036-Getting-serial-Magic-Mouse-to-work&p=462595#post462595

Rubix
May 29th, 2017, 01:53 PM
Thank you Plasma! That one works!


http://www.vcfed.org/forum/showthread.php?58036-Getting-serial-Magic-Mouse-to-work&p=462595#post462595

I can't get it to work, it says it doesn't work without vga. Tried /M and /Y, didn't work either. I tried another driver which should support Mouse Systems as well (now that I know what to look for) but it also automatically runs in Microsoft mode.