View Full Version : Flashwriter II and 8212 technical question

June 17th, 2017, 07:57 PM
Hi all,
Yesterday my SBC-200 with Flashwriter II was working well. Today I powered it up and now it's not accepting anything from the keyboard. I probed the outputs from the keyboards and as I press keys they are changing states, but not pulsing.

Looking at the Flashwriter II schematic, I followed the keyboards parallel outputs to a 8212 (8 BIT input/output port) I probed it and found that all the outputs are dead (not high, not low, and no pulse...nothing)

All the pins look like this:
1 - L
2 - L
3 - Change
4 - Dead
5 - Change
6 - Dead
7 - Change
8 - Dead
9 - Change
10 - Dead
11 - L
12 - L

13 - L
14 - H
15 - Dead
16 - Change
17 - Dead
18 - Change
19 - Dead
20 - Change
21 - Dead
22 - Change
23 - H
24 - H

(N.B. that 'change' means changing state when keys are pressed (no pulsing), and 'Dead' means I get no reading at all on my logic probe)

You can see the data sheet for the 8212 here: http://www.datasheetspdf.com/PDF/P8212/500532/1

So my first instinct is that this 8212 IC is dead, but looking at the device selects, the CLR line, and the STB line, now I'm not so sure. I was wondering if anyone could confirm my suspicions or give me some insights?

Pin 1 is a device select and I believe is active low, but it is tied to ground...so all good there.
Pin 11 is STB, but I don't see any strobing as it seems to be stuck low.
Pin 13 is also a device select and I believe is active high, and is driven by a 74ls04 inverter (which seems to be working/inverting), and also reads low...probably this isn't a good sign
Pin 14 is CLR active low...and unfortunately I don't know what this pin does. It's presently reading high.

Again, any help or insights would be greatly appreciated.

Much thanks and Cheers


June 18th, 2017, 05:34 AM
The 8212 is probably fine. The outputs from the chip are floating until the device is selected. This, in turn, only occurs when the keyboard data port I/O address is read by the CPU.

From your description, it sounds like the keyboard is "alive" in that the data input lines to the 8212 change state when keys are pressed. However, the fact that the strobe line doesn't pulse is a red flag. I'd follow the strobe path from the 8212 back through the U36 inverter, the ribbon cable, and back to the strobe output at the keyboard and see where the strobe output from the keyboard is getting lost.

The CLR input on the 8212 is tied to POC (power on clear) and should be high as you measured.


June 18th, 2017, 02:47 PM
Hi Mike,
Much thanks for the reply. That gives me a great place to start looking. last night I did trace the chip select line to the 8212 back to a 47LS00 at U11 on the Flashwriter II. There are two inputs at pin 1 and 2 which are both seemingly pulsing high/low, but the output on pin 3 is stuck high. The same inputs also go to pins 11 and 12 (pin 12 having first gone through a 47LS04 (U24) inverter) of the same 47LS00, and the output on pin 11 is a strong pulse!
I have tried piggybacking another 74LS00 on U11, and lifting the leg at pin 3 so itís not touching the underlying IC, however probing this lifted leg on the piggybacked IC still shows it to be high :-/

...Not sure if any of this means anything.

I'll check out the strobe line this evening.

Much thanks again for your continued support.


June 18th, 2017, 11:04 PM
Hi again,
I traced the lack of strobe back to the 555 timer pin 3.
So I took some reading from the 555:

1 - Low: GND
2 - Low: 0.5v
3 - High: 3.3v
4 - High: 4.8v
5 - High: 3.2v
6 - Low: 0.5v
7 - Low: 0.5v
8 - High: VCC 4.8v

Reseting or powering up the machine has no effect on any of the pins, no pulses detected whatsoever.
Does the 555 look to be an issue?

Cheers and thanks again


June 20th, 2017, 06:47 AM

The select output on U11 you're looking at will only be asserted when the PROM monitor reads the keyboard data register. The data register, in turn, will only be read if the preceding read of the status register indicates a new keystroke is available. My guess is the data register is never getting read (since a new key strobe is not received from the keyboard), so it's correct you're not seeing a pulse on the data register select line.

If your logic probe can detect and beep for a single short pulse (e.g., 500ns), then you could use the IN command in the monitor to perform an input from the keyboard data register and verify you get a quick select pulse on U11 p3 each time you execute the IN command.

However, I really doubt 8212 select logic is the issue. If you're not seeing a strobe pulse from the keyboard at the 8212, then that IS a problem. How short of a pulse can your logic probe detect and beep or flash for? I want to be sure we're not fighting a test-equipment issue as well. In your most recent post, you're checking out a 555 timer. I assume this is on the keyboard itself and not the FlashWriter II? We need to know what type of keyboard you have or see a schematic for it to help further.


June 20th, 2017, 04:11 PM
Hi again Mike,
Again, much thanks for your confirmation. Makes sense that the 8212 is probably not the issue.

Truthfully, I'm not sure how short a pulse my logic probe can detect. It's basically just a cheap probe. I have a USB logic analyser that may do a better job of detecting a short pulse, so I'll drag that out and give it a shot.

Presently I have the machine working with the modified VGmon ROM installed (that talks to the FWII and the Mindless terminal keyboard). I will remove this ROM and reinstall the SD systems ROM and try the IN command as you suggest via a serial terminal.

Yes, the 555 timer is on the keyboard, This keyboard is from a Vector Graphic mindless terminal...the schematic can be found on Page 45 of the Mindless terminal PDF here:


The 555 timer section can be seen in the lower right corner of the schematic.

Thanks again Mike.


June 21st, 2017, 05:43 PM
The 555 is part of the auto-repeat circuit. Instead, look at AKD from Z7 and verify it is firing for each keystroke and then see if it fails through through the the pins 9, 2, 5 half of Z13 or the Z11 NAND.


June 21st, 2017, 06:26 PM
Hello again,
Thanks for the advice...
So I followed your suggestions. The two inputs (pins 1 & 2) if the 74LS132 @ Z11 are pulsing on key presses, but the output (pin 3) seems to be stuck low. I don't have a spare 74LS132, but by my reckoning it seems you found the problem. Not sure why I didn't notice this before, as I originally traced these lines ending back at the 555.

I'll find a 74132, piggy-back it first, and see how that goes. If it looks promising I'll remove the IC and drop a socket in.

Will let you know how I get on.

Much thanks!!!


June 21st, 2017, 07:23 PM
You may want to verify the strobe line is not shorted to ground somewhere before you pull Z11.


June 21st, 2017, 11:31 PM
Hi again,
It did turn out to be the 74LS132 at Z11 as you suggested. First I tested it for shorts to GND as you recommended.
Pulled a spare 74LS132 from an old Apple II Disk controller card. First piggy backed it, but still no pulse from pin 3. Still piggybacking it I lifted pin 3 so it wasn't touching the pin underneath and it pulsed. Pulled the faulty chip, socketed it, and now it works great!

Thanks again for all your help. Marvellous!


June 22nd, 2017, 04:30 PM
Great! That kind of success feels so good :)

June 22nd, 2017, 07:20 PM
Yes, such a good feeling when you can fix something....so thank you for all your help and insights.

Strangely enough I always think older tech feels more personal, more human, and more alive than modern tech. Is it because you can actually get your hands dirty and fix it...it's human sized. Or is it that old stuff can be deeply understood by a single individual. Whereas it would be almost impossible to work on (at a base level) or understand completely, anything modern.

I like to think this old stuff 'feels' happy to still be used, and repaired...however illogical that may sound.

Thanks again


June 25th, 2017, 05:33 AM
Your comments are dead-on! New technology is depressing for this old engineer that used to think he knew and understood everything ;)