PDA

View Full Version : Toshiba t5200/100 problem



frassil
July 13th, 2017, 01:38 AM
Hello everyone!
I did yesterday buy a t5200/100 from a secong hand shop. It seems to be almost ok, it starts up, screen is working, ram check goes without error.

But, after ram check, it gives me the error:
Invalid configuration information - please run SETUP program

It doesn't tell me about any keys to press to get into setup, it feels like i have tried about every bios key sequence there is.
The system seems to not be freezed, capslock light respsonds to caps key, it starts to beep when i have pressed alot of random keys..

Any here know what keys to press? I tried to read the maintance manual, but not sure where to find about Setup. (or maybe im stupid).
Or maybe it's broken?

I have tried to remove HHD, floppy and all extra ram. This makes no difference (except from faster ram check :) )

modem7
July 14th, 2017, 03:40 PM
Welcome to these forums.

The symptoms suggest that you simply need to go through the SETUP procedure.

According to page 3-2 of the T5200 maintenance manual, you need to boot from a DOS boot disk that has TESTCE52.EXE on it.
You then execute TESTCE52.EXE, then of the options presented, use the '0 - SETUP' option.

TESTCE52.EXE can be found at:
1. Goto http://minuszerodegrees.net/manuals/Toshiba/Diagnostics/Toshiba_diagnostics.htm
2. Download the 1995 dated diagnostic programs
3. In that, TESTCE52.EXE is in the \DIAGS\HIGH folder


Alternatively, according to the web page at [here (http://minuszerodegrees.net/manuals/Toshiba/Setup/Toshiba_setup.htm)], TEST3.EXE should work as well.

You should also investigate whether or not the CMOS battery needs replacing.

modem7
July 14th, 2017, 04:11 PM
On some old Toshiba laptops, one can also get into the SETUP by holding down the ESC key whilst powering on the laptop. You could try that.

On some old Toshiba laptops, it is the FN key instead. Again, the key needs to be held down whilst the laptop is being powered on.

Caleb Hansberry
July 14th, 2017, 07:19 PM
Saw this thread an was like "ooh, I can help with those!" but then modem7 responded - he can get you sorted out, I believe he is the one who helped me with mine.

What he said is true, you need to run a setup program, I forget if I used TESTCE or TEST3, on a bootable floppy, and you'll be good to go. I successfully replaced the battery with a pack of three AAs rewired to it's battery wires from the mobo.

frassil
July 14th, 2017, 08:51 PM
Hi and thanks for the replies. I had the cmos battery problem, but did replace the battery with a 18650 3.7v battery, and that seems fine (no more battery error).

But, the system halt after the current error message, ive tried to boot from a floppy that was included, but it wont get that far. Seems responsive though, it starts to beep after x random keystrokes (tried about all keys combinations there is for BIOS setup)

frassil
July 14th, 2017, 08:53 PM
Will try with the hold esc on power up later today!

modem7
July 15th, 2017, 02:16 PM
Will try with the hold esc on power up later today!
Per post #3, some Toshiba notebooks use the the FN key.

SpidersWeb
July 15th, 2017, 02:42 PM
I have a couple of T5200/100's. When I generate an error on boot, I usually get a prompt to either enter setup or continue. To trigger it, holding ESC or just mashing characters to generate a keyboard error usually triggers it for me.

If you can't trigger it, I'd make sure you're waiting long enough for it to generate a hard-drive error (if CMOS is bad, it could be trying to talk to Mr Conner for a while before giving up), and some other quick things I'd try are using it with no CMOS battery (blank vs invalid) and also seeing if anything changes when the keyboard header is disconnected. They're just small things I like to eliminate. Just my two cents.