PDA

View Full Version : 4MB 30 pin simm RAM configuration headache



ScanDisk
August 11th, 2017, 08:10 AM
so that 4mb of RAM I bought from Russia finally came in, I installed it, and it works sort of. The system boots, starts dos, and Windows 286/2.11 now starts fine without the memory parity interrupt issue.

However, the bios still only counts to 640k base and 00384k exentded.

I go into the setup and try to change it, but it doesn't let me.

What do I need to do?

Thanks.

EDIT:

According to the user manual, when J16 is off, it can only do 1MB.

I put the jumper ON J16, but now it says that there is 00000kb extended memory.

When I go into set-up and change it to 3456KB (like the user manual says to do for 4MB of ram), and I click space in order to write the change to the CMOS battery, it just resets to "Not Installed"...

EDIT 32:

Checkit, comes back with the memory including the base memory being OK. However it doesn't even test the extended or expended memory. Probably because the BIOS doesn't know there's over 3MB of extended memory to be used.

So I think the RAM is fine, considering this, and the fact that Windows starts without the memory error I was getting with the previous RAM.

ScanDisk
August 11th, 2017, 12:44 PM
SOLVED!


Turns out:

J14 has to be on
J15 and J16 have to be off.

The Usermanual only spoke about J16 as on none of the pages related to upgrading the memory were J14 and J15 mentioned.

However, I found this far more detail description of the motherboard, which helped a lot:

http://www.uktsupport.co.uk/pb/mb/286x.htm