PDA

View Full Version : Trantor 128 (CD-XT002) SCSI 8-bit isa bios



VERAULT
September 7th, 2017, 06:54 AM
So I have been trying to get my ibm XT to boot to my 2gb scsi hard disk for quite some time. I came across a CD-XT002 scsi card which I guess is the same card as a trantor 128, I found a bios40634
TSROM bios ver 1.12 and had a friend burn it to the correct eeprom. When I boot I get the attached bios displaying, but it never finds a drive.

Any ideas? Am I using the wrong bios?

g4ugm
September 8th, 2017, 01:14 AM
I wonder if its the 2GB drive that's causing the issue. Do you have a drive that's <1GB to try? Does the drive spin up and become ready? It may need jumpers setting so it starts without being probed.

alecv
September 8th, 2017, 02:49 AM
Old SCSI BIOSes suppor CDB-6 SCSI command set only. Maximum CDB-6 LBA address is 2^21 . It gives 1Gb disk capatity maximum.

fatwizard
September 8th, 2017, 06:54 AM
The display shows error 601. That's a floppy drive system error.

VERAULT
September 8th, 2017, 07:33 AM
yes, for testing purposes I removed the floppy card. Still boots to basic with floppy drive in or out. G4ugm, the drive works fine otherwise, If I connect it to my TMC-850 I can write to it,read from it, scandisk it. DOS sees the whole partition. I have the wrong bios for the tmc-850 (ver 8.5) I need to get the eprom burned with 8.2 But thats a whole different issue.) The 2gb scsi drive works fine its an HP C3010 from 1990 Dual height 5.25" drive. For arguments sake I also tried a 500MB scsi drive that I know works I pulled out of an old late 90's powerMac. That drive also works fine on my other scsi card.
I have the correct documents showing me jumper settings for the card and drives. I do have the enable immediate spin up option enabled. Tried with and without it.

I think I have the wrong bios written to this trantor card, anyone have experience with it?

VERAULT
September 8th, 2017, 07:39 AM
It would probably make more sense if I share the info I am looking at
here is a manual for the hard disk (its a big file):
https://www.mirrorservice.org/sites/www.bitsavers.org/pdf/hp/disc/scsi/5960-8345_C3007_C3009_C3010_Technical_Reference_Apr92.p df

here is the settings for the scsi card:
http://stason.org/TULARC/pc/hard-disk-floppy-controllers/M-O/NEC-TECHNOLOGIES-INC-Up-to-7-SCSI-devices-T-128-CD.html

Stone
September 8th, 2017, 07:40 AM
When I boot I get the attached bios displaying, but it never finds a drive.If your floppy drive isn't working how are you getting it to boot?

VERAULT
September 8th, 2017, 07:44 AM
floppy works fine stone, I just had it out to snap a picture of bios screen.

VERAULT
September 8th, 2017, 01:09 PM
I have no idea why my posts arent coming through, I sent them this morning.
Anyway I took out the floppy just to quickly test, error 601 is not an issue thats why I didnt mention it, the floppy is out but works fine.
The 2gb scsi drive is an HP C3010 from 1990, dual height 5.25" scsi hard disk. The jumpers are correct. here is the documention for the drive:
https://www.mirrorservice.org/sites/www.bitsavers.org/pdf/hp/disc/scsi/5960-8345_C3007_C3009_C3010_Technical_Reference_Apr92.p df
The trantor card settings I found here:
https://groups.google.com/forum/#!topic/comp.periphs.scsi/4xZuC6mUcVg

I do have it set to spin up, tried it each way makes no difference. The drive and other 500gb scsi drive I took out of a late 90's powermac work fine when I connect them to my TMC-850mer scsi card, so I know the drives work and the jumpers on the drives are correct, with the tmc 850mer I can format them, scandisk them and read and write to them, cant boot with the tmc-850mer since I have bios ver8.5 not ver8.2 acording to all the posts on this forum, but thats a completely separate issue, I just want to state that the drives work with another card, my issue is with the trantor 128. I really think the issue is the bios version perhaps. Anyone familiar with this card?

VERAULT
September 11th, 2017, 07:58 AM
Anyone familiar with this card or bios versions on it?

VERAULT
September 13th, 2017, 08:03 AM
Geez, I guess not. Well I would really love to get this card working. At this point I can mail it to someone if they want to test on it and mail it back to me, anything to resolve this issue. I need a working SCSI Card in my XT.

VERAULT
September 16th, 2017, 11:52 AM
Well this is disappointing, I was hoping someone could shed some light on this.

Cloudschatze
September 18th, 2017, 01:48 PM
While you're not going to get the Trantor card to boot from the 2GB drive, you might try partitioning and formatting the 500MB drive using Trantor's "TFormat" utility, additionally supplying the "/s60" parameter to specify the non-default sector-size seemingly required by the card. Two T-128 cards that I currently use (also having ROM v1.12) boot from 1GB CompactFlash cards that had to be formatted similarly.

gslick
September 18th, 2017, 02:28 PM
Is that a SCSI READ(6) / WRITE(6) 21-bit LBA restriction in the Trantor BIOS that only supports capacities up to 1GB?

In the past I have used the sg3_utils (http://sg.danny.cz/sg/sg3_utils.html) sg_format utility to soft resize the capacity of SCSI drives > 1GB in size down to 1GB to allow the drives to be used with systems with the 21-bit LBA restriction.

I have no knowledge of whether or not that is relevant to the situation with the Trantor SCSI adapter being discussed here, nor anything about the non-default sector size issue.

David_M
September 18th, 2017, 05:06 PM
Its been a long time now but I used to have an external single spin nec cdrom that came with a trantor card. The card had no rom or pal chip to enable a rom so I ended up using it in linux machine to run a tape drive.
I do recall trying to get the cdrom to run on other scsi cards and it never would work, it always came up with parity errors when running on another card.

Is it possible the problem is the parity setting, I think the undocumented sw6 sw7 and sw8 were to do with parity.

edit:
Forget the above, I just dug my card out of my parts box, it's a T-130b not a T-128

Have you tried booting from floppy with the bios disabled and using the trantor device driver to access the drive? That will at least prove the fault is either the rom or something else.

David_M
September 18th, 2017, 05:47 PM
This thread might provide some insights
http://www.vcfed.org/forum/showthread.php?13217-Trantor-T-128-BIOS-1-12