View Full Version : Altair 8800 boot issues

April 29th, 2003, 07:06 PM
As part of my collection I have an Altair 8800 (actually 2, but one is being rebuilt) and an Altair 8800BT.

The 8800BT came with a pair of MITS 8" drives (Pertec drive, MITS controller in the drives and machine) and it works perfectly. Turn the key and the machine boots to a prompt.

The 8800 came with the same setup but never booted. I recently tried a few things to figure out where the problem was.

First of all, I tested the 8800 set of disk controller boards in the working 8800bt system and I have and determined that the cards are not the problem. (The drives that came with the 8800 aren't quite functional, but they are close)

I then returned my attention to the original 8800 with its controller cards hooked up to the pair of known-good drives. For the life of me I canít get this machine to function properly. I have no idea why it wonít boot, but it wonít. It goes through the motions; it enables the boot drive and loads the heads but it wonít output anything to the terminal.

I suspected the serial card until I ran a test on that and was able to get it to spit data out from the proper output port. Iíve tested every other aspect of the system, within reason, and the machine appears to be fine. It just wonít cooperate with me about booting. Iím at my wits end trying to boot this machine.

Does anyone have any suggestions about what I can try next? I'd really like to have the 8800 boot from the drives someday. . .


May 14th, 2003, 08:47 PM
I figured out this problem earlier tonight, at least in part.

Someone suggested that I try the RAM from my 8800BT in the 8800 to see if I had memory issues. I hadn't tried that before since I was convinced that the RAM I had in my 8800 was good (it runs Kill the Bit fine, after all! :))

I ended up doing the memory swap and now the machine boots like a champ! I feel silly not having tried this before.

Now I have to figure out what was wrong with the RAM originally in the 8800. . .


August 13th, 2003, 05:09 PM
Eric, the problem may be the memory chips themselves. Some chip and/or memory card mfgrs. realized that the specs for the chips did not have to be as specified in the data sheets, went to the chip makers and asked them for the rejects that failed due to the slow speed of the particular parameter of interest ( can't remember what it was, but I do remember that many cards that would work fine with an 8080, or Z80 at twice the speed or the clock cycle would not work with the Alpha Micro systems which accessed memory at the maximum rate of the standard specs.. The boards that gave us trouble were some boards that were sold so cheaaply that they drove us dealers nuts.
You may be fighting omethng like this.

August 17th, 2003, 02:51 PM
I know nothing about the Altair unfortunately, but I can suggest something based on my experience with how finicky the Mac is about new memory chips. Make sure the memory chips are all the same brand; some manufacturers have miniscule timing differences which really piss off whatever's checking the memory. X86 hardware seems to be less particular about this kind of thing (stupid).

If the problem is what ODM said, you may be stuck with having to swap RAM in and out of your Altairs every time you want to boot them, which would suck.