PDA

View Full Version : Need disk formatting program for Gazelle



RichCini
October 8th, 2017, 07:00 AM
All --

Not sure where this fits, since it's a cross-platform issue between a Seattle Gazelle I'm restoring and an IBM PC/AT. Short story is that the AT is being used to create 8" disk images and make new copies using a Shugart SA-851 plus Adaptec AHA-1522 controller on the AT.

The issue I need to solve for is that the three DSDD disks (all based on the MS-DOS 2.0 format) that came with the system have soft errors. I'd like to create clean disks and image those. Unfortunately the disk format is one that uses 1024-byte sectors which no DOS-based formatting program I have can seem to deal with. I even used a driver from a system similar to the NEC 9801, but it still doesn't work. The FORMAT program that comes with the disks will not format with 1024-byte sectors and there is no switch -- document or undocumented -- that I can find.

Does anyone have a floppy disk formatting program that can do this that they can point me to? The full format would be 8x1024x2x77 or about 1.23MB.

Thanks!

Chuck(G)
October 8th, 2017, 08:18 AM
That wasn't a driver "hack"--it was a commercial driver for Mitsubishi CNC gear that uses 1.23 MB floppies in PC98 format.

I've got another one, but you were never clear on what exactly that you wanted or had. The boot sector for the Gazelle is almost certainly sui generis--and I don't know where to find one. I'd be willing to throw a program together to handle it, but I'll need some cooperation.

RichCini
October 8th, 2017, 08:45 AM
Chuck, I admit that "hack" was probably a poor way to describe it not knowing exactly what the driver was originally used for, and I didn't mean it in a negative way at all (but I did edit the OP). It does work for reading/writing but for some odd reason, it barfs on formatting the disk. I wonder if it has to do with the physical disk density -- the Gazelle disks are double-density not high-density and maybe the MS-DOS 6.22 FORMAT program doesn't know how to deal with the mix of densities and geometries through the NEC driver. The "Track 0 Unusable" error I remember seeing in the old days when the wrong disk density was used.

The disks are MS-DOS 2.0 based and AFAIK, the only difference is that they use 1024-byte sectors. I haven't tried it yet, but I'm sure I can read the boot sector using DEBUG, so I could post the DPB data from the disk.

I did look through the Simtel MS-DOS archive for a DOS-based formatting program that could handle the sector size, but one didn't immediately jump out at me. Obviously SCP had a program to do this. The FORMAT program on the DOS2 disks only format SSSD and there doesn't appear to be a switch of any kind to make it do anything else. I did look at the source code and didn't see an undocumented switch.

When I get back this afternoon I'll try to dump the boot sector and post it.

Thanks again!

Chuck(G)
October 8th, 2017, 08:54 AM
If the gazelle's disks are 8", they're high-density. They differ only in the modulation method (FM vs. MFM).

The driver I gave you uses the native BIOS support to do its work; I assume that you declared it as 1.2MB in your BIOS setup. I've got another driver that can be modified that does its own direct hardware access.

Formatting (at least high-level) involves more than laying down an appropriate physical format. The formatter also has to lay down a boot sector, empty FATs, and a blank directory.

SomeGuy
October 8th, 2017, 09:02 AM
I don't know for sure if this would work, but what I would try is using the Altair emulator: http://schorn.ch/altair.html to format and set up an Imagedisk file whatever way is desired, and then write the resulting file to a disk. As I recall, it can use Imagedisk files directly.

There are some example MS-DOS / 86-DOS SCP configurations here: http://schorn.ch/altair_5.php and if you need, there are some other SCP DOS images on bitsavers: http://www.bitsavers.org/bits/SeattleComputerProducts/

Chuck(G)
October 8th, 2017, 09:09 AM
I've been to bitsavers. The images there all seem to be 26x128 SSSD. There is one image that it's hard to tell as IMD says it's corrupted.

Chuck(G)
October 8th, 2017, 09:12 AM
Rich, if you want to see if your hardware's okay, try running 22Disk using, say, the Advanced Digital 4 (ADV4) definition on your drive. That's 8x1024 DSHD.

RichCini
October 8th, 2017, 12:18 PM
Chuck -- I made a Teledisk image if you'd like to take a look at it. Just let me know.

I noticed the following as I was testing before. Sector 0, Head 1 shows data errors in several sectors (4-7). The original SCP disk boots fine but any image that I produce does not boot.

I also tried to grab the boot sector using DEBUG and the first 512 bytes compare perfectly. So, not sure why one will boot and the other won't.

Regarding the 2007-version of the IMD disks on BitSavers. I made three disks -- DOS_2.0.IMD, DOS20_1_MS-422.IMD and DOS20_2_MS-422.IMD. They are indeed SSSD disks. All three boot on the Gazelle with no problems. The first one seems to be a "working" disk which has the system files and utilities EXCEPT development tools. The other two (MS-422) look like a 2-disk version of my single disk. The first one is similar to the working disk. The second has the development tools, source files and object files. I manually compared the file attributes and two BATch files are larger and earlier than mine (by about a week), and eight of the 12 OBJ files are the same date but about 30 minutes later.

Chuck(G)
October 8th, 2017, 02:09 PM
So you can boot the SSSD disks? That's a start.

Have you tried IMD on the bootable disk instead of TeleDisk? Just curious.

RichCini
October 8th, 2017, 02:25 PM
The system came with about a dozen disks -- 3 DSDD and the rest SSSD. All disks -- both DSDD and SSSD boot properly. All disks were imaged with IMD and new copies made on new disks. All of the SSSD copies work fine but the DSDD won't boot (see next paragraph). I made a second copy of the MSDOS 2.0 disk using Teledisk and made a new copy from the image -- as a test -- and that one won't boot either.

So, in sum, all of the SSSD disks, their images, and copies are fine. Focusing on MS-DOS 2.0, the DSDD original boots but the copy -- regardless of imaging tool or disk -- does not. IMD reports problems with Track 0, side 1, sectors 4-7. I tried several disks from different packs of disks and the results are the same so it's not the new media.

Considering that a 2-disk "master" exists (Bitsavers, SN# MS-422), not sure why SCP did this, other than it reduces the required number of disks by 50%. Also, I wonder if the bad sectors are part of a copy protection scheme.

Chuck(G)
October 8th, 2017, 02:38 PM
What does Anadisk say about the first track?

RichCini
October 8th, 2017, 05:04 PM
I dug out my copy of Anadisk 2.07 and ran it on the original SCP Master (no errors) and on the disk created from the IMD image of the master. The IMD disk reported errors on Track 0, Sector 1:

Gap in sectors 2-5
Data, no ID. Adding sector 104
Sector 1, ID but no data
Sector 2, data error
Sector 6, data error

I then used Anadisk to make a direct disk-to-disk copy of the SCP master. No errors were reported while making the copy. I used IMD to make an image of the direct copy. No errors on READ. I wrote that new image to a blank...no errors on WRITE.

So I tried to boot both disks (the direct copy and the IMD copy of the direct). The direct copy booted but the IMD copy did not (actually it started but then bombed before the MS-DOS sign-on message).

Kinda weird that the disk-to-disk copy works but the IMD recreation will not. I've been using 3M disks. Tomorrow I may try some IBM disks I have.

RichCini
October 9th, 2017, 05:59 AM
Here's this morning's update...

Starting with the SCP Master, I made another direct copy using AnaDisk to an IBM 2D disk. From this copy I made a Teledisk image, and then created a new disk from that image using a "generic" disk. Both the original direct copy and the image copy worked. I also created an IMD image of the direct copy, and made a disk from that image using a 3M disk. No joy.

I then converted the Teledisk image to IMD using the td02imd program. The conversion complained about a duplicate sector number on Track 29, but the image worked. It also seems to have mangled the sector count. Not sure why.

I've been using NEW/SEALED 3M disks for all of the previous tests. It seems that the two boxes of 3M DSDD disks I have, although new, mostly exhibit issues with Track 0, Side 1. I have maybe 3-4 boxes but at least I have 20 disks of other brands.

Chuck(G)
October 9th, 2017, 08:19 AM
Hmmm, are you sure they're double-sided? Also, what color are the write enable tabs? If they're the red ones, don't use them. A lot of drives don't see them as opaque.

RichCini
October 9th, 2017, 08:58 AM
Yes, pretty sure. The box and OEM labels on the disks say DSDD. The index hole is in the correct spot for DS disks. The write-enable tabs are silver. On writing disks using IMD, it only complains about Track 0, Side 1. The other tracks write properly.

Chuck(G)
October 9th, 2017, 09:05 AM
That's very strange--and possibly explains why my driver didn't like your disks.

RichCini
October 9th, 2017, 09:17 AM
Yes, maybe. I'm going to try to format one of the other disks using the NECSYS driver and see what happens.


{later}

I took two disks -- one IBM and one generic -- and tried to format them through the drive letter provided by the NEC driver. No dice. Complained about Track 0 unusable. So, I tried it through the physical drive letter and both disks formatted and are bootable with MS-DOS 6.22.