PDA

View Full Version : Commodore PC10-III wont boot :(



Apidya
October 11th, 2017, 08:22 AM
Hallo..

I have just bought a almost brand new commodore pc10-III, but it wont boot up. It wont even read the disks when I put ms dos disk in. not spinning at all.
I have just opening the pc, and It is clearly it has never been open before. What is wrong with it. Has it something to do with the bios.

Hope something in here can help understand this old machine..

BloodyCactus
October 11th, 2017, 11:20 AM
you using high or low density disks? checked if the battery leaked all over everything? psu blew up with old caps?

your not giving much to go on...

Apidya
October 12th, 2017, 09:51 AM
you using high or low density disks? checked if the battery leaked all over everything? psu blew up with old caps?

your not giving much to go on...

I know .. sorry for that.. I was just out of my selfe.
I have Open it and found out today that the battery had leaked. The asid damage was not so bad, so I can fix that, and I have order a new one.
But can the machine run without the battery.?
And the PSU is runnning great.

Apidya
October 13th, 2017, 01:18 AM
you using high or low density disks? checked if the battery leaked all over everything? psu blew up with old caps?

your not giving much to go on...

The battery has leaked. Can that be it? I have manage to clean it fine, and desolder some of the joins. But Can it run without a battery?

Trixter
October 13th, 2017, 12:52 PM
It can run without a battery, but if the leakage damaged traces you will need to repair all of them.