View Full Version : Northstar Horizon MDC-A4 problem

June 2nd, 2018, 02:00 AM

My Northstar MDC-A4 floppy disk controller no longer works - Any ideas what to look for beyond the list below ?
Both drives spin up on start but no attempt to boot from drive 1 - multiple resets occasionally initiate the drive 1 light on but sometimes the drives will not stop spinning after the timeout period.

I have tried a few obvious things including:

1. Substituting with My MDS-AD3 controller from another machine which works just fine so I'm sure its nothing else on the Northstar backplane or the floppy drives.
2. Removing and reseating all the 74 series IC's in their sockets and the three 74S287 PROM's
3. Voltage regulator and tantalum cap seem ok too.

Worth noting I don't have a monitor PROM on the system CPU card so have no way to probe memory content or run controller tests.

Thanks in advance.

June 2nd, 2018, 03:07 AM
Sorry - should have tried a few more combinations with my other working unit before posting.

I put the MDC-A4 in the other machine and it seems fine so it might be a problem with the combination of cards in the problem machine.

June 2nd, 2018, 04:05 AM
Did you use the same drives when you moved it to the other unit?

I this will sound strange, but it still could be the tantalum caps. I had a setup where the caps seemed fine with a continuity tester and meter but under load had intermittent issues. Another reason I usually recap tantalum caps, besides the potential for magic smoke.

June 2nd, 2018, 04:49 AM
No I didn't move the drives over too.
Rationale being I know the drives in both machines are ok as I can read/write when moving the cards between chassis.

The MDC-A4 6.8uF tantalum cap does look pretty discoloured so I'll take your advice and replace it anyway.

I'm going around in circles somewhat - if I insert memory cards from my working machine with this FDC and drive combo the machine is fine.

June 2nd, 2018, 05:17 AM
I’ve seen this happen when a memory board is responding in the same address range as the memory mapped North Star controller. What is the RAM configuration in this machine?


June 2nd, 2018, 05:32 AM
Yes, I'm thinking the same.....

The machine has two memory cards
1. TinkerToys SuperRAM 32K - single 8 way DIP for map selection
2. TinkerToys SuperRam 16 - three 8 way DIP for map selection.

Settings shown in photo - below. Hard to find the manuals for these cards and check the mapping.

With the switches at the top its possible they may have moved when pulling the cards.


I 'think' this means the 16K is mapped from 8000-BFFF and the 32K is mapped between 0000-7FFF.
If Im reading the limited info I have for the MDC-A4 it's prom is mapped from E800 so shouldn't be clashing.

June 2nd, 2018, 10:44 AM
Yes, it looks like the address switches are correct.

What type of computer is this? Unless you have a front panel, I assume it’s configured to auto-jump to E900 on the North Star single density controller upon reset or power on? Most auto-jump circuits require the RAM board at 0000 to support the Phantom signal, and I see the Phantom dip switch is turned off on the 32K board - that could be an issue.

Also, DIP switches are notorious for failing as they age. The failure mode is high impedance when the switch is closed. This typically makes what should look like a zero look like a one instead. In your case, one or more of the banks on the 16K board could then be overlapping the FDC. You can easily check for this by measuring across each switch with a meter. Flipping the problem switch(es) numerous times and optionally flushing with contact cleaner can make the switch work well enough to temporarily solve the problem.


June 2nd, 2018, 11:01 AM
Thanks Mike - I'll check those switch banks.

Its a Northstar Horizon by the way.

June 2nd, 2018, 12:47 PM
The ZPB-A CPU Board used in the Horizon does auto-jump locally on board, so Phantom support on the memory board is not a requirement. This eliminates the Phantom dip switch as an issue.

You don’t typically see the single density controller like you have in the Horizon. I temporarily put a single density controller in my Horizon to bring up some old software and port CP/M 2.2 to the Horizon on the SDC. One of my older SD controllers had a boot PROM that wouldn’t work with a 4mhz processor because the read timeout passed too quickly.


Dwight Elvey
July 8th, 2018, 09:24 PM
I've made a simple monitor for N* that allows one to access memory through the serial port. It could be used to do a dump of the controllers ROMs. It runs on the processors EPROM socket. The code is small and can easily fit on a 2708 but if you were setup like me, the regulators for the 2708 were not installed so I wired the two offending wires to except a 2716 instead. I'm told other have made an adapter socket. I'd plan to do this myself until I saw that the regulators were unpopulated. One could also use the monitor code to load test programs that would allow you to use an oscilloscope to analyze the various functions of the controller. It has a number of simple commands:
Mxx sets the address pointer first x is low byte and second is high byte.
R returns a byte at the address set by M and increments it to the next location
Wx allows one to write a byte to M and also increments
G jumps tot he address of M

M is stored in the HL of the processor.
This runs on the left serial at 9600 baud.
You'd need to write your own program on the other end of the serial. x is not a HEX value, it is just a byte.