View Full Version : Damn Direct Access Menu Software

April 9th, 2007, 08:53 PM
Ok, here's the problem; I have 3 MS-DOS machines with Fifth Generation Software's Direct Access menu software.
They, obviously, came from a school environment where the idea was to run ceratin applications and not let whomever was using it get out of the menuing software.
The software disables the break key, disables booting from floppy and needs a password to quit the menuing system.
Anyone know of a "universal password" that will let you get out of this software?
We used to use it on our clients systems, in some cases, but, we logged the passwords in case we needed to work on the machine.
I'd appreciate some help here :)

April 9th, 2007, 10:06 PM
How can it keep you from booting from a floppy (had the bios locked to boot C then A)?

I would just move the drive to a secondary channel on the IDE cable (slave) and put a fresh C drive with DOS on the primary so the system boots to a clean DOS, then delete the offending menu software from the drive as needed.

April 10th, 2007, 08:02 AM
Booting from the floppy would have to be disabled in BIOS, as the menu can't control anything until after the machine is booted. Check BIOS Settings to enable floppy disk boot...

April 10th, 2007, 10:50 AM
You could remove the drive and format it in another machine. If the BIOS has a password, simply use the CLR_CMOS jumper (or short the BIOS battery) to unlock that.

That is assuming you don't want to keep the software... :)

April 10th, 2007, 04:06 PM
Well, the machines are a PC10-III and 2 PC20-IIIs and the same software is on all of them.

The way it disables the floppy is through a /n switch in the config.sys file according to what I've been able to find on the 'net

Directly Accessing Direct Access.

Direct access 5.1 is a popular DOS shell program, which is often
used to control access to the dos prompt in a stand alone, and a
networking environment. Usually the program is run from autoexec.bat,
and if the person doing security has done his/her job right, then
switches=/n is in config.sys, and floppy booting is disabled in CMOS.
This locks up the computer pretty tight, and Direct Access is usually
passworded on exit to dos, dos commands, maint, etc. The weakness in
direct access is that when you press F10 and the enter password box pops
up, DA reads the password into memory, in ascii. So the trick is to get
your handy dandy TSR memory explorer into RAM. If you ever get a dos
prompt on the computer, even a shell, you can load your memory TSR, and
then load DA. Then it is a matter of hitting F10 to exit, and when the
dialog box is on the screen, hit the hotkey of your mem explorer, and do
a search for Enter Password. Once it finds that in ram, the password is
usually not more than 50 bytes or so in either direction, you need to
look a little for a string that looks like a password. You can repeat
and get all the password on the system this way. This info is from the
mem explorer I use. It is freeware I think.

I had thought of putting a bootable dos drive as C:, but, I can't find any info on the SL02 controller in the XT and I couldn't find any information on any dip switches on the PC10 and I did kind want to save the software on it.

I thought that someone might have some knowledge on some "universal password" that I could have used to exit the menu system.

If not, then I'll have to start ripping them apart to solve this annoying problem.

P.S. DongFeng, I asked you some questions concerning a quadram board in the thread someone started about weither it was repairable or not, but, I suppose you haven't been back there yet,

April 10th, 2007, 04:11 PM
Doesn't F5 on boot skip Autoexec.bat and Config.sys?

Terry Yager
April 10th, 2007, 05:58 PM
Doesn't F5 on boot skip Autoexec.bat and Config.sys?

Depends on the DOS version, IIRC.


April 10th, 2007, 06:09 PM
I can see several ways around the problem, but what I would try first is this:

Enable boot from drive a: in CMOS. If the CMOS is password protected, clear it by using the CLEAR CMOS jumper to reset it to the defaults (this will probably enable the boot from a: )

Boot from a floppy, then edit the config.sys and autoexec.bat to REM offending lines.

Another way would be to press CTL C as soon as DOS starts to abort the autoexec.bat. Then you should be able to edit config.sys and autoexec.bat or at least rename them so that they're not invoked at boot.


April 10th, 2007, 07:08 PM
Yeah, I figure popping up the CMOS settings on the PC20s would be a way around the problem (at least, after I replace the Dallas RTC chips in them, since, after you set the CMOS up, it wants you to reboot, after which, of course, you've lost the setting because the RTC is dead LOL).
It's more the PC10 I'm concerned about because, although you can find a few things about it on the 'net, settings ain't one of them.
Maybe some kind soul (not mentioning any names, Micom) could open their PC10-III up and list the standard jumper settings. I figure Floppy Drive Enabled would probably be a fairly useful default setting :)

April 11th, 2007, 12:52 PM
Doesn't F5 on boot skip Autoexec.bat and Config.sys?

Unfortunately, not on this system.

I have the PC10-III apart and can access the MB, but, of course, the jumpers are just numbered with no indication of what they are for. *SIGH*

They never make it easy, do they?

April 12th, 2007, 07:51 AM
I remember your pain. I had a similar problem with a Tandy SX 1000 that used to be in a Hallmark store. It was used to generate computer greeting cards, and they obviously wanted to prevent in-store hacking (by kids like me wandering the mall in the 80's)....

Eventually I broke through their code, but I forget how I did it.

anyway, try checking the motherboard jumpers, maybe they are set to bypass the A drive and it's not a CMOS issue at all.

have you tried coldbooting the system and repeatedly clicking the DEL key, F10, F7 etc. while the system boots?

Another possible hack..using the TAB key (TAB+esc, etc.) Sometimes the tab key is assigned special privs when the break key is disabled.

does it bypass the A drive in the boot sequence or appear to open it and then ignore a normal boot disk? There may be a special hidden / system file for diagnostic entrance into this system. If the A drive is at least acknowledged during boot, I would probably remove the hard drive and just replace with another formatted drive and see how that goes.

there has to be some way to get in!

April 12th, 2007, 07:52 PM
It checks the A drive and, even with a bootable disk in it, continues on to the hard drive.
I know the drive is good, I just aligned it before putting it in.
I don't have the jumper settings for the motherboard and haven't been able to find them, but, the idea behind situation was to disable the floppy boot so that you HAD to go to the menuing software.
I'll try your other suggestions though and report back.

April 14th, 2007, 08:33 PM
It's been pointed out to me that I should clarify some things about these units.
First, these 3 computers are Commodore PC compatibles. The PC10-III is an XT and the PC20-IIIs are ATs, som the PC20s I'll be able to fix when I replace the Dallas RTCs, but, on the XT (PC10), the A drive would have to be boot-disabled by jumper on the motherboard.
It's running a later version of DR DOS, so, if anyone is familiar with the autoexec abort sequence and/or the motherboard jumper setting, I'd appreciate knowing it. When I get the PC10 back up on the workbench, I'll rty the ones already suggested and see if they work.

Micom 2000
April 16th, 2007, 08:38 AM
Ok here's what I got. Putting it here rather than PM for any collaborative help forthcoming.
CBM certainly didn't make it easy. You have to virtually dissemble it, removing the PSU/ Drive assembly. A bonus was I found the battery was showing acid powder. In both the PC-10 and PC-20(haven't disassembled it yet but it's shape appears to be also a Varta) it had a Varta rather than the Dallas RTC.
If you have the Dallas you should be able to just short the reset lead to the ground lead to bypass the Dallas System password.

My PC-10 doesn't have the expected set-up switches, but CBM BIOS's as does the PC-20. Not all the PC-20s were ATs I believe. This does create a problem. Who provided the BIOS for CBM ? Possibly Phoenix and there are some programs available to hack the various BIOSs so you can get in. Snooper was also able to set some CMOS settings, but of course you need a funtioning OS to use it.

The jumper setting in my PC-10 which used a WD driver ISA card were:

Near the Drive sockets:
jmp 614 on
jmp 206 on
jmp 207 on
jmp 208 open
jmp 101 on
jmp 205 on

The BIOS chip near the Drive sockets was labled:
CBM 1987
PC10c 164A

The one near the ISA sockets was
CBM 1987
PC10c 2C2A

On the PC-20 this was
1989 CBM
4.36 522A

Couldn't see the other without disassembly.

Incidently what appears to be the CPU is a Farraday chip. (huh ?)

Don't know what help this will be to you, but in my case it explains why just plugging in a HDD wouldn't work. IIRC they both worked except for the HD, so I'll have to reassemble a bit and see if I can explore the systems and find out how to get into the BIOS's. Hmm. XTs with BIOS's, a new quandary.


April 20th, 2007, 01:00 PM
Thank you for the information, Micom, I appreciate it.
Due to personal matters, I haven't been on for almost a week, but, I will try out the jumpers and get back to you on the progress.

May 9th, 2007, 04:45 PM

Ok, seems, upon digging things up out of the pile, I DON'T have a PC10-III and 2 PC20-IIIs, what I have is a PC20-III and 2 PC40-IIIs. That's what happens when you rely on a 54 year old memory.

The 20 has jumpers similar to the 10, in fact, the board is silkscreened PC10-III, although it's in a 20 case and has a sticker on one side saying PC10/20. The ROMs, however, are several years newer than the list Micomm gave. The jumpers are pretty much set up as in this list too, although some seem to be hardwired in the artwork and no longer have staking pins.

I tried all the suggestions put forth in the thread to no avail, I'm afraid, so, it's nuke time for the HD and I'll just put some version of DOS on it.

The PC40-IIIs are must easier and the first one is completed and tested with DRDOS gone (it wouldn't take a date past 1999) and MSDOS 6.2 in it's place. It also has a DS12887 in a socket replacing the unsocketted DS1287 and the RTC works fine under MSDOs.

I haven't opened up the other 40 yet, but, I have another "whaddaya think" situation.
The Standard PC40-III came with a 40 MB HD (2 20MB partitions) and a 1.2MB 5.25" floppy. The one I just worked on has a 720KB 3.5" and a 270MB HD. The drive table has been modified for the larger drive and is sen as a single drive and the setup will take all 4 common drives in both sizes.

Question is, should I make it functional or authentic? I can put a 1.2MB floppy and probably dig up a 40MB HD, or, I can leave the 270 HD in and install a 1.44MB floppy.

You people collect, I don't. What would the average collector rather have? Functionality or Authenticity?

Thanks for any and all opinions.

May 9th, 2007, 07:30 PM
Well, I am not an avid collector but I would guess Authenticity! I was looking at a IBM 5170 on ebay yesterday with some foreign motherboard in it. I thought "Big deal! Who wants a 5170 case with a Asus mb in it?" I sure don't. I already have a 1991 Gateway2000 full sized tower with it's 5th motherboard upgrade in it. Putting foreign stuff inside the original just turns them into everyday crud.

May 9th, 2007, 07:35 PM
I was looking at a IBM 5170 on ebay yesterday with some foreign motherboard in it. I thought "Big deal! Who wants a 5170 case with a Asus mb in it?" I sure don't.

Speaking of ATs i've got a couple I need to be rid of. I just need to pull them, test them and wipe the HDs.

It's almost purge time again at the ranch. I've got too much extra stuff, too many new machines and no space to speak of. :D

Terry Yager
May 10th, 2007, 07:26 PM
I vote for both, since you have two. Keep one all-original and max-out the other.


May 11th, 2007, 06:20 AM
I can't seem to get it to run under XP command mode. I need something equivalent or to get Direct Access to run legacy batch commands. Ideas?

August 4th, 2007, 12:15 PM
Well, seems I got another PC20-III in the latest delivery of stuff and, besides working, it has the original 8-bit drive in it.

It also seems that Commodore stuck with a specific line of drives from the PC10 series to the PC40 series (those containing hard drives, of course) and that was WD930xx-Xxx for the 8088 systems and the WD930xx-Axx for the 80286 systems.

The drive in this particular PC20 is a WD93020-XE2-10 and the motherboard is not a re-ROMmed PC10-III, but an actual PC20-III motherboard.