PDA

View Full Version : Irix 64



Vlad
August 3rd, 2007, 04:12 PM
Am I missing something or is IRIX the only OS where backspace doesn't?
Is there a way to just erase one character if you mistype a command or do I really just get a new line to try again? Seems kinda counter productive after a while. All I've gotten back space to do is give me a new line at the command prompt. Sorry if its obvious, I never really encountered IRIX before now.

-Vlad

Sharkonwheels
August 3rd, 2007, 08:50 PM
You on the console?
Or serial'd in? Backspace should work fine.
Try the DEL key, as well.

O2000 - Nice box. I'd love one of them, but to account for the space, it;d have to be a jacked up unit.

I'm still hoping to run into an Onyx2 one of these days....


Tony

Vlad
August 3rd, 2007, 09:44 PM
Its not mine, oh how I'd love to have it though. Its actually in Europe, I'm connecting via SSH. At my SSH console, I hit backspace and it just kicks down to a new line. Delete just makes a ~ show up.


[Vlad@o2000 ~]$ uname -a
IRIX64 o2000 6.5 10070055 IP27
There's the uname if it helps at all.

The only other machine I connected to was a Cray (its down due to a busted Ethernet board) and its running UNICOS. It let me backspace and do all that good stuff just fine, IRIX64 is the only one that has an issue. I just figured either I was doing something wrong or it was just goofy.

-VK

Starshadow
August 3rd, 2007, 11:17 PM
Is this that Cray Cyber site you're logging into?

Vlad
August 3rd, 2007, 11:21 PM
Yup, it is. Thats about the only way the average person could get time on big iron. Why, know something about whats going on?

Sharkonwheels
August 4th, 2007, 12:41 AM
What SSH client you using?
I can't remember ever having a problem using putty, going into my O2 (R10k I think), or my Octane (I think it was 2 x R12k). I don't do much *nix any more. Isn't there a command to alter your current terminal settings? Term, or stty, or something?

EDIT: Oh, did you by chance try a Ctrl-H ?


Tony

carlsson
August 4th, 2007, 03:20 AM
Also what does $TERM default to?

Jorg
August 4th, 2007, 03:36 AM
Try control-H (^H)

Vlad
August 4th, 2007, 08:37 AM
I'm using OpenSSH in GNU/Linux. And Thanks Jorg! CTRL-H does work.
I see ^H in Slashdot jokes enough, but for some reason it never occored to me to try it. :rolleyes:

Thanks for the help guys!

Brendan
August 5th, 2007, 06:03 AM
Don't forget that in alot of Unices, you can:

stty erase ^H

or

stty erase ^?

which can help map your backspace key to the backspace character. It can be a good thing to add to your dotfile (which one varies based on the shell you use).

Vlad
August 5th, 2007, 03:53 PM
I didn't know that, thanks for the tip!

barythrin
August 6th, 2007, 10:09 AM
Yeah, I think that's actually a shell feature not an Irix specific issue. Solaris (and other SYS5 variants?) loves to do that also with some terminal emulation programs (like Putty) but like the previous poster said

stty erase ^h (contrl+H) should set your terminal shortcuts for the backspace key.. Sometimes you can use del to go back a space also or ctrl+h itself.

If you do botch up your terminal (typing a binary file or something like I always used to do) you can also type "stty sane" to reset it back to the configured defaults.

... I can't remember without googling where to change the erase code when it loads shell but it may be sysctl.conf or something in /etc/ .. I dunno I haven't used those systems in such a long time. In linix some of it's in /etc/inittab (which I'm pretty sure doesn't exist in most unix distros). Also could possibly be defined in your .rc files in your home dir.

- John