PDA

View Full Version : Intel DX4 100MHz System Woes



Super-Slasher
May 1st, 2004, 06:10 PM
I finally got around to actually getting a 486 system working, but the joy was short lived as I found I couldn't do any work at all concerning the hard disk in any way.

The motherboard is an Asus PVI-486SP3 and booting up with a Windows 95 boot disk is no problem. I can float around in DOS okay, but as soon as I try to access the hard drive in anyway, the system freezes solid. This has led me to bileve that the IDE controller drivers need to be loaded. Except I have never done anything like that before. I have the latest drivers released by Asus for this perticular board and chipset, but I can't seem to do anything with it.

The drivers came with a "support disk" for my perticular motherboard which I downloaded - and promptly doesn't seem to work. One time I tried accessing the SETUP.EXE file for the installation of the drivers after booting into DOS with the boot disk, and it asked me to reboot the system as if the disk was supposed to be bootable on its own. Now when I try to access the EXE file, it freezes.

So, I thought of just adding the .386/driver files to the config.sys file on the boot disk, but that freezes the system, too.

One file I got with the support disk is one called ADDDRV.EXE, yet I can't seem to use it at all because all it tells me is "Useage: ADDDRV.EXE driver directory", wether being executed right from the disk or added into autoexec.bat.

Can anyone help me with this, please? I spent 5 hours trying to fix it up but failed miserably. I want to install Windows 98 on this perticular machine.

One thing I noticed is that the BIOS is a rather old version as compared to the last one released for my motherboard. I tried flashing the BIOS but it failed; didn't damage the existing BIOS either. Would an older BIOS be the source of some of my troubles; would a newer BIOS have drivers for the IDE controller?

This also leads me to another question: the computer would obviously need access to the driver files before booting up to Windows 98 off of the hard drive, yet how would it do this is the drivers are installed on the hard drive? Would I have to use a boot disk with this motherboard everytime I wanted to get into Windows?

PLEASE help me! Hehe. I really want to get this thing working.

barryp
May 1st, 2004, 06:34 PM
I finally got around to actually getting a 486 system working, but the joy was short lived as I found I couldn't do any work at all concerning the hard disk in any way.

Try FDISK

Super-Slasher
May 1st, 2004, 06:55 PM
EDIT - Just tried FDISK. I can access the drive now, and format it, but during the format when it comes to "Writing out file allocation table" it freezes at 0 percent.

The hard drive was a working pull I had used earlier with Windows 95 on it.

lither
May 1st, 2004, 10:46 PM
i have a SP3 before. it didnt need any driver to access the hardisk.
How big is your hardisk? To my memoy, the SP3 could only use a smaller hardisk . I use a 820M conner HD without any problem.

Super-Slasher
May 2nd, 2004, 07:09 AM
The problem with my hard drive seems to be solved. I have three of the same mobo and I switched with another one, but now a new problem has surfaced.

The CD-ROM is a Mitsumi 2x model that runs off of an ISA adapter card. Now the computer freezes on boot up with my boot disk when the drivers for this CD-ROM are loaded.

Perhaps the problem with it now is there's an IRQ/DMA conflict with the ISA card and another device on the motherboard? The computer freezes just as it loads the driver and the screen reads out the IRQ and DMA settings, 5 and 10, respectively.

Super-Slasher
May 2nd, 2004, 07:40 AM
Bah. Now the system freezes whenever -any- program is loaded from the floppy drive.

I've had it with these motherboards. I'm not going to waste any more time on them. I'm going to keep my eyes around for other DX4-capable mobos, though, as I really want a nice, tripped out 486 system to keep around, hehe.

Atleast I know the DX4 chip I have works...

Thanks to all who tried to help.

dongfeng
May 2nd, 2004, 08:13 AM
Are you using the correct IDE cables? It may sounds silly, but I got caught out once... apparently there are two different types. :?

Super-Slasher
May 2nd, 2004, 08:36 AM
There's only really one kind of IDE cables I have and use on all my other computers without incident.

I personally think the mobos are just flaky, that's all. there were from trashed school computers on their way to the dump.

Peet42
June 3rd, 2004, 02:28 AM
:idea: Just a thought, but is the HDD sharing a cable with a CD or similar? The symptoms sound similar to what I would expect to happen if that was the case and either both were set to "Master" or both set to "Slave"...?

The "Driver" idea is a red herring, since if the system was booting from HDD it would have to access the HDD to load such a driver, thus locking up the system. Also, if the system really locks up when you access the HDD *in any way* then FDISK won't work either, as the first thing it does is read the boot sectors of all attached HDDs.

As for the two different types of IDE cable, they are 40-wire and 80-wire, the latter being required for systems with UDMA-66 or above drive access speeds. On a 486 system you should only be using 40-wire cabling.