Image Map Image Map
Page 95 of 102 FirstFirst ... 4585919293949596979899 ... LastLast
Results 941 to 950 of 1014

Thread: XTIDE tech support thread

  1. #941

    Default

    Hi,

    I understand that Transcend CF card might be a problem... Time to get another one ! I flashed the EPROM with he latest version, but that's not better.

    For your problem with putting the OS you want on your card, you can try this : http://theinstructionlimit.com/insta...to-ide-adapter

    It worked very well on my side.

  2. #942
    Join Date
    Aug 2006
    Location
    Chicagoland, Illinois, USA
    Posts
    5,569
    Blog Entries
    1

    Default

    Quote Originally Posted by modernclassic View Post
    Thanks - I did get the Cisco card to work under DOS 3.2 (just a single 32MB partition, but enough to tell me everything's kosher) after a lot of trial and error on the PC itself. It detected something like 963 cylinders on the card but saw only 0-127 as usable (expected given the DOS version), but the thing I didn't realize is that it would only work if I selected the partition to start from cylinder 1, not 0 or anything else. I had tried a partition from cylinders 100-127 earlier, but that didn't work any better than 0-127 did. But 1-127 works fine.
    You shouldn't be specifying exact cylinders with DOS FDISK; it's supposed to "just work". If you weren't partitioning it with DOS FDISK, I'd scrap what you did and try to do it again with pure DOS.

    I still need to get DOS 5.0 on this machine somehow (only physical versions that'll work are expensive on Ebay right now)
    Do you lack the ability to download disk images and write them to 360K disks reliably? These days, there's no need to purchase DOS just to get a system up and running... If you lack the ability, send me a PM.

    The Transcend card seems to not work at all. The XT-IDE doesn't detect it.
    Just curious, you may want to check the card to see if it's actually dead.
    Offering a bounty for:
    - The software "Overhead Express" (doesn't have to be original, can be a copy)
    - A working Sanyo MBC-775, Olivetti M24, or Logabax 1600
    - Documentation and original disks for: Panasonic Sr. Partner, Zenith Z-160 series
    - Music Construction Set, IBM Music Feature edition (has red sticker on front stating IBM Music Feature)

  3. #943

    Default

    Quote Originally Posted by Trixter View Post
    You shouldn't be specifying exact cylinders with DOS FDISK; it's supposed to "just work". If you weren't partitioning it with DOS FDISK, I'd scrap what you did and try to do it again with pure DOS.
    DOS 3.2 makes you specify cylinders. This was changed in 3.3 from what I can tell. I've only got up to 3.2 on physical media that I can use with my PC; I've tried 3.3 and up in a VM and fdisk is different in the later versions.

    Do you lack the ability to download disk images and write them to 360K disks reliably? These days, there's no need to purchase DOS just to get a system up and running... If you lack the ability, send me a PM.
    I think I can write 360k disks now that I have the card partitioned and working with a single 32MB partition. That's more than the actual 20MB hard drive that was in there before...

    I just need to find some working blank disks. I have a bunch of old disks for my Apple II that I can probably repurpose, it's just that about 50% of them are faulty. So I need to go through them and make sure I pick out 5 good ones.

    Just curious, you may want to check the card to see if it's actually dead.
    The Transcend card isn't dead, just not recognized by the XT-IDE. I guess it may be something to do with the old BIOS that the XT-IDE's are shipping with right now. I'll try updating that and see if the Transcend card works then. I'm not 100% clear on how to do that yet either, which is why I haven't already done it. I understand there's supposed to be a configuration/update file that comes with the card, but mine didn't seem to come with it. I guess I just need to download it from somewhere and run it? I can't find any built-in function in the 1.1.5 BIOS that lets me update it, unless I'm just missing it.

    The Cisco card is working fine now, though, if I didn't make that clear before. It's just only working with 32MB out of its 256MB, because of DOS 3.2. But for now that's ok. As long as I know the card works, I can get everything else updated and working properly eventually.

  4. #944

    Default

    I updated with the latest BIOS, and there is no change.

    I bought "whatever CF Card I could find" yesterday for a test... and I ended up with a 32Gb Sandisk. The results of my tests are even worse thant with the 256 Mb Transcend.

    Anyway I've bought a small Sandisk CF to make further tests. I fear that clones BIOS do accept more or less those expansion cards !



    BTW, it's very hard to have a conversation, as every post I write has to be moderated during half a day before it appears on line !

  5. #945
    Join Date
    Jan 2010
    Location
    Central VA
    Posts
    4,136

    Default

    The XT-IDE not detecting the CF card is more likely to be the CF adapter. Given the other issues you're having, you may have a defective CF adapter. Of the handful of XT-IDEs that have come back to me, a significant portion of issues have been due to dud CF adapters. If you have another adapter, or some other IDE device, give that a try.

    Second, you need to make sure that any existing partitioning is destroyed before trying to FDISK + FORMAT, especially with older versions of DOS. You can do this under Linux using the `dd` command, or use WIPEDISK under DOS:

    https://www.lo-tech.co.uk/wiki/WipeDisk

    You can destroy the old partitioning on any machine you like, but you really need to run FDISK and FORMAT with the drive/CF card plugged into the XT-IDE. The XT-IDE can be installed in another system with ISA slots for that part.

    You update the BIOS by putting the new BIOS ROM image and the XUB configuration utilities on a floppy (or on a non-XT-IDE hard disk) and running the configuration utility.

  6. #946

    Default

    Just got DOS 5.0 installed on my 256MB Cisco card and it's booting fine in the PC. Still nothing with the Transcend (in either of two CF adapters), but that's ok - 256MB is enough.

    I ended up successfully doing what I'd hoped to do, which was get DOS 3.2 installed (since I had it), download DOS 5.0 disk images and copy them to the DOS 3.2 partition, make real floppy disks from the images, boot DOS 5.0 from floppy, wipe the DOS 3.2 partition using DOS 5.0 fdisk, then re-partition and re-format the CF card from DOS 5.0 setup. The hardest part was making real floppy disks, both since my floppy drives weren't being 100% reliable (I needed to clean and lubricate both of them before either would even format a disk without errors) and because most DOS image utilities won't work with modern disk images. Took me quite a while and a lot of trial and error to get those disks made. (I found some threads here about it and they ended up helping, but I still had to try a bunch of different utilities and conversions to get it to work.)

    Now to just update the XT-IDE BIOS - thanks for the info on how to do that. I'll try the Transcend card again after that, but if it still isn't recognized, no big deal.

  7. #947

    Default

    I have a similar XT-IDE CF card issue and I was hoping someone knowledgeable would have an answer.
    I bought a blank PCB of Sergey's XT-IDE Lite card from someone on vcfed and assembled it without any difficulty.
    My problem is when I boot the XT with the CF card plugged in, the XT refuses to boot up, it is just like it is off, nothing on screen. With the CF card not plugged in the BIOS message shows and it boots from A: just fine. I have tried with several CF cards from 32MB to 1GB and also cleaned off the card using Diskpart with the clean command but the XT still won't boot with the CF card plugged in. I've attached a few pics of my assembled card.
    Any ideas how to solve this problem?
    Attached Images Attached Images

  8. #948

    Default

    Quote Originally Posted by BinaryAssasin View Post
    I've got a Leading Edge Model D and I bought an XT-IDE to add a hard drive and eventually a CF card. I was able to play around with the settings and get the hard drive to be recognized by the XT-IDE card as Master. The I/O address i used was 320h. I'm having an issue getting the harddrive to boot to DOS. I FDISK and formatted the harddrive with DOS 6.22 on a 486 rig i have and make sure it boots to DOS. When it's hooked up to the XT-IDE card as MASTER it shows up but the boot sequence reads:

    Booting C>>A
    Error 40h
    Booting A>>A
    Error 40h

    I'm not sure if the C>>A means boot C drive as A drive or boot C drive from A drive. The 40h error leads me to believe its trying to boot the floppy because the hard drive should have an error of 80h. Just wondering if anyone has successfully used an XT-IDE board on a leading edge and if I need to reflash the EEPROM with different settings.
    I have a similar problem on a clone XT. I get error 40h on the C drive, and then it successfully boots from A.
    If I put the XT-IDE card along with the CF card into an old 486 it boots just fine to C. So the XT-IDE and CF card are working fine as-is.
    I also did the FDISK and FORMAT on the XT just to be sure, but I get the same result, only booting from A.
    Also tried FDISK /MBR, it did not help.
    What exactly is error 40h and how can the C non-booting problem be fixed?

  9. #949

    Default

    Hello, you recently bought a book from me on eBay and recommended I post here. I got the XT IDE as a kit from you. I thought I could just flash the epromvin my burner but you mentioned I need to place the firmware EXE on a doe disk and boot, then flash. I'm in need of a did disk with the EXE on it. Can you assist?

    Carlos

  10. #950

    Default

    Hi everyone. I can't seem to get my XT-IDE v4, CF adaptor, and CF to work on my 5150. The XUB BIOS (stock from glitchworks v1.1.5?) sees the cards. I can use fdisk to partition, but after it reboots, reading the cards works intermittently. What I mean by this is that if I run fdisk, it might say no partition data, but if I exit fdisk and immediately re-run it, the partitions show up. Repeating this gives one of these results randomly. I managed to format a partition one time (it usually errors out with an invalid drive error), and copy DOS over to it, but the copied files were corrupted (or maybe just the read was corrupted? Hard to tell). It wouldn't boot, in any case. I also noticed that, with one of the cards, its label was corrupted in different ways in different boots. The XUB would identify it variously as "CF Card", "CFard", or just "Card", on different boots. I can't recall ATM if the other card had this issue. Floppy boot selection works fine.

    I suspect the CF-IDE adapter, as I got it from a sketchy ebay seller for $1.99. I've got an actual 2.5" IDE drive, cable and cable adapter on order to test the bare XT-IDE, but have to wait for that stuff to arrive.

    Thoughts? Also, maybe suggestions for a specific CF-IDE adaptor that is known to work, and where to pick one up, in case that turns out to be the problem? (I'm in Japan ATM).

    DOS 3.30
    IBM 5150 256k board
    63W PSU
    2x360K floppies
    CGA
    Sixpack Plus w/576k
    floppy controller.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •