Image Map Image Map
Page 102 of 102 FirstFirst ... 252929899100101102
Results 1,011 to 1,015 of 1015

Thread: XTIDE tech support thread

  1. #1011


    They probably don't support 8-bit transfer mode.

  2. #1012


    I can't find much info on this chip, I've googled and googled but did find this:
    T he FC1307A is a highly integrated solution for multi-channel SDHC interface to
    Compact-Flash/IDE interface application. It can handle data process between one slave
    Compact-Flash/IDE and up to four host SDHC interface. FC1307A built-in function which can
    speed/size up 4-channel SDHC host interface to Compact-Flash/IDE interface. FC1307A is
    fully compatible with the Compact-Flash standard 4.1 as well as the SDHC 2.0.
    2. Features
    2.1 Compliant with PC Card Standard 8.0
    2.2 Compliant with PCMCIA 2.1/JIEDA 4.2
    2.3 Compliant with ATA/ATAPI-6
    2.4 Compliant with Compact Flash (CF+) 4.1
    2.5 Compact Flash storage card mode using PC card memory , PC card IO and True-IDE
    Support the following modes on the Compact Flash/CF+ interface
    2.6.1 PC card memory mode and PC card IO mode of operation using either an
    8-bits or 16-bits wide data
    2.6.2 Attribute memory , common memory and IO access in PC card/PCMCIA
    2.7 Support advanced timing modes for memory/IO access (CF+ rev4.1)
    2.8 Support PIO mode-0 thru mode-6.
    2.9 Support Multi-word DMA mode-0 thru mode-4.
    2.10 Support Ultra DMA mode-0 thru mode-6.
    2.11 General SPI interface signal control
    2.12 General purpose IOs
    2.13 Expandable 4-channel SD HOST module

  3. #1013


    Firstly, thanks to everyone for their help.

    I've managed to get the XTIDE r4 working perfectly with the original Sintechi SD card adapter now. It turns out it was electrical interference!

    I bought a CF adapter and card, and while it was initially better than the SD - it still had words missing on read periodically. I mucked around with timing and it got a bit better - enough for me to run 70% of 8088MPH but still not stable.

    While I was testing this I had moved ISA slots further from PSU primarily to make more space to work. When I plugged the SD card back in it now worked exactly the same as the CF card even with the original 1.1.5 firmware and none of my tweaks.

    So I reasoned it must be noise related issues. I shortened my IDE cable by cutting off the slave part and I think the crucial step was to power the SD adapter from the XTIDE instead of a floppy power connector (it has no pin 20 connected, so I ran 5v from the pin 20 enable jumper on the XTIDE to the molex connector on the SD adapter. I figured since the XTIDE has a decent bypass cap it would clear up PSU noise.

    Since then it has worked perfectly.

    I am very surprised how PSU noise manifested itself in such a specific issue, but really happy to have it fixed.

    So for anyone reading this, don't discount electrical noise especially when using CF or SD adapters designed for newer machines which I would imagine have much cleaner PSU output than a vintage PC and less noise inside the case. The symptoms of this were random words missing from data reads every 8kb or so, which manifested itself as 2 characters missing from device name in BIOS randomly and sometimes disk not reading the portion table.

    Good news is it shows the XTIDE r4 works great with the common SD card adapters found - both the Sintechi and KTC chipsets (which I believe are actually the same). I've tested in normal and high-speed mode with no further issues.

    Thanks to Glitch for the kit and his help, Malc for testing the same setup and pearce_jj for the IORDY suggestion (it is connected on the SD card adapter) though I never jumped it back to the XTIDE in the end.

  4. #1014


    Quote Originally Posted by do_retro View Post
    ...Good news is it shows the XTIDE r4 works great with the common SD card adapters found - both the Sintechi and KTC chipsets (which I believe are actually the same). I've tested in normal and high-speed mode with no further issues....
    Well done on getting it fixed, It's good to know what works with what, I've had no issues with mine, My 44 pin SD card adapter is now living and working well in an old HP thin client i have running Dos 6.22 / WFW 3.11 on a 4Gb Transcend micro SD card, I might try one of those CF card type adapters which take the SD cards with the XTIDE R4 later.

  5. #1015


    Hi there! New to these forums, not to vintage computers, hell, I've been using 'em since they were state-of-the-art; my first computing experience was playing "Bowling" on a DEC VAX 11/785 at age 4...
    Anywho, a couple months ago I ordered myself an XT-IDE kit for my IBM 5155 Portable Personal Computer, then I ended up ordering a bunch of IC sockets when I discovered that the things that I had that I had thought were IC sockets were not IC sockets but little things for prototyping... just before Christmas, the last sockets came (for the ones not 10-pin-to-a-side I managed to secure "vintage" sockets in-country, but the 10-a-side I had to order from China & they took their sweet time). Today I finished up the card and installed it. Using one of those "DiskOnModule" jobbies, DJ series, spec sheet claims it can take power from pin 20, so I set the jumper on those pins. Booting the machine runs through the RAM check, then throws an error "601" (disk drive, IIRC) with an option to strike F1 to continue. Doing so carries on to the XT-IDE card's BIOS which fails to find a master or slave, and then tries to boot from the floppy. It fails to do this, and just keeps trying again. I haven't tried anything else yet, was going to go for the basics, pulling out all the other cards but the display adapter, XT-IDE and Floppy controller, trying the card in different slots, although there are only a couple it can even fit in given the size restrictions in the 5155's layout (diskette drives impinge significantly into the card area, only the first two can hold full-length cards, the third can take a long, but not full-length card, and the last 5 can only take the shortest of cards, with exact length depending on if the various plugs and wiring for the drives impinge on them and how). I think I've got the jumpers on the card set rightly, what I've read leads me to believe I should be using it in High-speed, yes? Compatibility is only for machines that use non-standard byte ordering, yes? Do I have to do something other for this? Adjust something on the floppy controller? Set the card for slot 8 and try it there (currently have a Bus Mouse card in there just because it supports slot 8 and I do own a Bus Mouse)?

    Machine has an NEC V20, an Intel 8087, and 256K RAM. CGA card in slot 1, FDD controller in slot 3, serial & parallel cards in 5 & 7, I think, XT-IDE in 6. Not 100% sure on those card locations, if it matters, I can check, and get precise part numbers from each, if needed.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts