Image Map Image Map
Results 1 to 6 of 6

Thread: I need some help with RSTS/E

  1. #1
    Join Date
    Oct 2009
    Location
    Waterloo, Canada
    Posts
    27

    Question I need some help with RSTS/E

    Hello again everyone. I've not been very talkative of late, but I have been lurking for a while. (Though, that too has been a bit interrupted by my coursework.)

    I've recently, come across a nice RSTS/E v9.6 distribution. This page to be specific. And I've been having quite some fun with it.

    Now, the major questions I have are:

    1. How would one add one (or more) "permanent" disks to the system? My current distribution is mimicking a system I once had the pleasure of using (that is, the system is an 11/70 (4M only because I don't remember the actual memory size of the original), with two RM80s as the "permanent" system disks, and an RL01 as a "removable" storage disk, there was also a TE16 magtape), and I'm trying to figure out how to "spread" RSTS from being constrained to DR0: to spanning DR0: and DR1: at the once. (DL0: is more or less for use by individual users, so there's no reason to need to automount it at system start up).
    2. I was only an RSTS/E user, not an administrator, but how does one add (non-privileged) users to the system? I know you need to use
      Code:
      create/account [disk]:[ppn]
      though doing so doesn't work as I thought it would. I'm thinking that one need do
      Code:
      create/accound [disk]:[ppn]/PRIVILEGES=NONE
      though, I have yet to try it.
    3. Another question of the noob RSTS/E administrator, whom, what or where do I have to modify to change the banner from "RSTS is on the air..." to something more customized? Furthermore - although I know it was an undocumented feature - from v9.0 upwards there was the feature (read: easter egg) to display the date as a stardate (you know, from Star Trek), how did one enable that again? (I cannot for the life of me remember how.)
    4. Also finally, does any one know where I can find earlier versions of RSTS/E? (Other then the V7 that's floating around.) And conversely, does any one know where to find the later versions of RSTS/E? I know for a fact that Mentec seems to have dropped off the face of the Earth, so I can't ask them anything.


    If you're wondering I don't actually have a real 11/70, as I don't have the room for one, nor have I found any with easy acquisition distance, so I'm running everything off of SIMH for now.


    And speaking of SIMH, I'm trying to figure out how I can turn the tapefiles from here into a functional/bootable UNIX V7M install tape (both as an image for SIMH, and for the purposes of giving to a good friend of mine who also can't figure out how to get it working (with his real PDP-11/83... lucky sob).


    Also, yeah, sorry for the extremely long post. And I'm not to sure this is in the correct forum, but this is DEC related.

  2. #2

    Default

    Sorry, I can't help. But I am interested in what you find out as some day I'd like to try running RSTS too. For now I could
    run it on my 11/84. But I do plan to get a real 11/70 someday and run something there, whether BSD, Ultrix, or RSTS. I think RSTS would be the most fun and I'd try to have it connected to the net from time to time. Good luck.

    I too would like to find out how to get the last versions of this too.
    Tim Radde

  3. #3
    Join Date
    Oct 2009
    Location
    Waterloo, Canada
    Posts
    27

    Default

    Right, so a bit of an update.

    Firstly, the way I was trying to add user accounts didn't work - even though it does now - is due wholly to the fact that somehow my installation of RSTS had a problem, and some critical parts of the system were corrupted. A quick re-installation (I love emulators...) fixed that right quick, so now adding accounts works.

    In other regards though, I've figured out how to get boot-time mounting of the disks. Only problem now, is that the disks - which are formatted as PUBLIC disks, are mounted as PRIVATE.

    The first part of Q3 was also solved in the same manner as Q1, so now I've changed the opening banner.

    Though, I still need help with the latter half of question 3, and help with getting the disks mounted "properly." Question 4 is still up for grabs though, so any help would be obliged.

    And I'm still needing help with getting a bootable UNIX V7M install tape.



    tradde:
    What is your 11/84's current configuration? The v9.6 RSTS/E out there is actually rather "nice" in terms of what it can and cannot support. So far, my only major quibbles with it have been "Why don't you support the RP07?" and "Why don't you support the RK07?" whereas, it'll run fine with any of the MSCP disks (in SIMH at least). For a quick laugh I decided to see what the biggest system I could possibly make RSTS reside on. The end result is the following:

    • PDP-11/94 w/4MB RAM + FPP + CIS
    • 2 DELQA Ethernet controllers (mapped to my Gigabit ethernet port... so yes, the system really "Feels the Powah!")
    • 4 DZ11's (32 lines)
    • 4 DHQ11's (32 lines)
    • 16 DL11/DL11 terminals
    • PTR and PTP
    • LPT
    • CD11 card reader
    • 2 RL02 disks
    • 8 RP06 disks
    • 16 RA92 disks
    • 2 TU81 tape drive
    • 8 TU77 tape drives
    • 8 TU10 tape drives
    • 8 KG11A Communication Arithmetic Options

    So basically, almost everything in SIMH, except those which cause controller conflicts (the RF and RC disks, the TS tape system, and the KE11), and which I don't need/want (read: floppy disk drives, DECtapes, RK05s, and RK06s). Though, as one very important aside, the system is not using the UNIBUS DELUA or DEUNA Ethernet adaptors by way of RSTS/E becoming non-functional at install when using a DELUA or DEUNA; however the DELQA adaptor works perfectly (so just pretend there's a UNIBUS to QBUS converter or something in the system).

    My main thought at seeing the system configuration afterwards was: "Okay, who called IBM and asked for a cheap mainframe?" Also, it runs, and quite nicely too - minus the issues mentioned in the above section. (And I'm pretty sure the system is the size of the room I'm in right now.)

    Now, all I have to figure out, is how to get my ISP to make my routermodem function, so I can remotely connect to the DZ11, VH11 or KL11 terminals.


    Very long rambling is now complete. Please return to your normal activities.

  4. #4

    Default

    My 11/84 has a full complement of 4Mw of memory. It also has a UDA50. I was lucky to find a Unibus SCSI adapter many
    years ago so that makes it easy to create a bootable system using Simh and then move said drive to the 11/84. It also
    has a DEUNA network card, a printer card, and a serial port card for a few more terminals. I haven't done much with it
    since I moved here to New Mexico.
    Tim

  5. #5
    Join Date
    Oct 2009
    Location
    Waterloo, Canada
    Posts
    27

    Default

    Sounds like quite the nice system you have there. I wish I could get my hands on a real '11 system. Though I'm currently happy with emulating (I would though, dearly love to own either a 70 or one of the 83/84 or 93/94 systems).

    In regards to my problems with RSTS/E, I've solved some of my question, though I'm still having issues with disks not mounting correctly. Apparently the system autospans disk volumes when adding users (and a disk fills up), but that issue is not fixed until I can get my system mounting the disks correctly.

    I'm still looking for an answer to question 4 from any RSTS/E users, as I'd love to try running something more historic (or something that doesn't promptly implode on seeing the year 2000).

  6. #6

    Default

    Quote Originally Posted by Creideiki View Post
    Sounds like quite the nice system you have there. I wish I could get my hands on a real '11 system. Though I'm currently happy with emulating (I would though, dearly love to own either a 70 or one of the 83/84 or 93/94 systems).

    In regards to my problems with RSTS/E, I've solved some of my question, though I'm still having issues with disks not mounting correctly. Apparently the system autospans disk volumes when adding users (and a disk fills up), but that issue is not fixed until I can get my system mounting the disks correctly.

    I'm still looking for an answer to question 4 from any RSTS/E users, as I'd love to try running something more historic (or something that doesn't promptly implode on seeing the year 2000).
    It's nice, but I miss the blinkenlights. If you are patient you will find an 11 for yourself. Just keep looking and letting
    others in this hobby know you are looking.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •