Image Map Image Map
Results 1 to 9 of 9

Thread: INFINITE UC2000 S100 bus voltages

  1. #1

    Default INFINITE UC2000 S100 bus voltages

    My wife snagged an INFINITE UC2000 from eBay for me. Got it in and the +16 and -16 voltage lines were DOA. After pulling the system apart I discovered 2 burned lines (the very thin lines that pass through the pins played fuse). After adding jumper wires I am getting +20 and -20 on those lines (without load). I don't see an immediate way to adjust that down.

    I remember seeing something (here?) where this isn't critical but I wanted to check with more experienced S100 bus users.

    Its a very clean system. I'll get pics and specs up when I get a chance.

    -Matt

  2. #2
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,076

    Default

    Sounds a *little* high even without load. See what it is if you put a 2-3 A load on the 8V line; a 12V automobile bulb or two should do.

    Does the transformer have any taps on the primary by any chance?

  3. #3

    Default

    No taps on the primaries. Drop to 19.9 with 2 12v bulb load on 8v line.

    -Matt

  4. #4
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,076

    Default

    Quote Originally Posted by hexsane View Post
    No taps on the primaries. Drop to 19.9 with 2 12v bulb load on 8v line.

    -Matt
    Definitely a little on the high side (s/b ~16V) and there isn't going to be much current drawn to pull them down; on the other hand the power dissipated in the regulators won't be very high (unless you're running a FH HD off the +20V).

    But you already know that; I'd be more concerned about the 8V level under low load conditions.

    Does it look like the original power xfmr?
    Any clues to why the traces burned?

  5. #5

    Default

    There won't be any drives running directly from this PSU so that won't be a problem.

    Yes they appear to be the original power transformers.

    8V line didn't flutter with 2 bulbs.

    7912 is toast on the Delta CPU / Serial card. (Dead short) everything else appears to be okay. I've disconnected the 7912 (I don't have a spare :/ ) and will pull the line drivers just in case.

    Plans are to put it back together and power it up tomorrow.

    -Matt

  6. #6
    Join Date
    Dec 2005
    Location
    Toronto ON Canada
    Posts
    7,076

    Default

    TransformerS? More than one? 8V is really ~8V ?

  7. #7

    Default

    2 transformers: #1 30v with tap for 15v #2 12v with tap for 6v

    There is a CRT in the case and +15vDC is going out to it. I haven't confirmed but on the backplane there is an LM340 so I'm assuming its for regulating the voltage to the monitor. Large filter caps and diode bridges (again assuming) would be for the 16v and 8v power.

    This is where pictures would be helpful.

    -Matt

  8. #8

    Default

    Can you put a scope on the outputs and check for ac ripple ?

    I'd also check the bridge rectifier or diode(s) and see if one
    of them is shorted or open.

    Whats your AC voltage at the wall outlet ? Older circuit's assumed 110vac
    but now a days, AC can vary from 117 - 127vac.

    On my late 70's early 80's arcade games, they used similar power supplies
    for the monitors. If you didn't re-strap the primary to match, component
    failure was very common.

    You could also bring it up with a variac and see whats going on.

  9. #9

    Default

    I snapped one of the transformer power connectors off the backplane so had to wait for a Jameco order to arrive (also picked up a 7912 while I was at it). New molex pins in the connector now.

    No AC ripple out. Very clean actually. No other taps on the transformers so I'm putting it back together and checking each board. Hopefully I'll get a page up with some pictures so y'all can see what I've latched my hands on to.

    May have scored a Byt-8 locally too. Going to go check on it tomorrow.

    -Matt

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •