Image Map Image Map
Page 6 of 6 FirstFirst ... 23456
Results 51 to 54 of 54

Thread: AT2XT keyboard converter

  1. #51


    I am having an odd bug/issue with my AT2XT.
    I am using Sergey's Micro8088 and the AT2XT that is part of the design.
    Most everything seems to be working correctly except...

    Shift + arrow keys.
    If I use the numpad, shift+arrow keys work as expected in and other text editors to highlight text.
    If I use the inverted T arrow keys, shift+arrow key acts as if shift is not being held and the cursor moves with no highlighting.

    I am setup to convert my CF card to a virtual disk image and back, all of that works reliably. So using the exact same drive image & utilities, shift + inverted T arrows works as expected in VirtualBox, so I'm left pointing fingers at the AT2XT.

    Is this a known issue, is this something I missed in configuration?

    Thank you.

  2. #52


    I found references to this problem online. The only suggestion was to upgrade from 0.94 to 0.1d. I've tried that with no change to the shift + inverted T arrow keys behavior.

    I may be expecting behavior that can't happen or otherwise misunderstand AT2XT, as I have a key scanning program which shows some odd behaviour of the shift key pressing itself when using the inverted T arrow keys, so I'm guessing the AT2XT is translating the arrow keys into num pad arrow presses depending if Numlock is on or not.
    Last edited by TheDrip; October 24th, 2020 at 03:26 PM.

  3. #53


    Quote Originally Posted by modem7 View Post
    Member schnurzel came up with some alternative firmware for the converter's PIC chip. It maybe the answer. Available at [here].

    You will need a device that can program the firmware into the 12F629 PIC chip. Alternatively, some of the people/companies at [here] could supply a programmed 12F629 for you.
    The alternate firmware above worked great with my Tandy 1000 SL/E.

    Just wanted to let everyone to know - try that firmware if you have a Tandy 1000 SL/TL/RL/RLX system.

  4. #54


    Quote Originally Posted by Chuck(G) View Post
    You want to check the "User program" and "Configuration" boxes. Leave the rest alone, particularly OSCCAL, which is set at the factory.
    I checked those two boxes and it worked great. Thanks!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts