Image Map Image Map
Results 1 to 1 of 1

Thread: LS-120 drive troubleshooting

  1. #1

    Default LS-120 drive troubleshooting

    I'm sorry if this thread is in the wrong place but I'm not sure where to put it.

    I purchased an Imation Superdisk drive (SD-USB-M version) recently and I'm having issues with it.
    It works fine when inserting a standard HD floppy disk, my current Macbook Pro (2015) mounts the floppy fine.

    But when inserting a Superdisk I get a seek, seek, seek and nothing happens.

    I read online that OSX doesn't recognize the SD-USB-M version drives so I bought a G4 to test. But it
    still doesn't work.

    Today, I opened it up. The head it typically locked in the park position (near where the hub of a floppy disk
    would be located after insertion). Once a floppy is inserted, the head unlocks and then moves to the
    furthest track from the hub while making seek noises. That's all good. However, after inserting a Superdisk
    into the drive, the head does not move and it makes seek noises constantly. The head is not locked but it
    doesn't move away from the centre hub. Whenever it begins seeking, and I move the head myself (manually),
    it stops scanning and makes no further noises. After moving the head myself and it makes no further noises,
    when I hit the eject button, the head moves back to the park position and ejects the disk as normal.

    So I don't know why the head behaves differently between a standard floppy disk and a superdisk.
    But it gives me reason to believe that there may be a fault with the drive itself. Has anyone got any idea
    what may be wrong with my drive?

    Thanks.
    P.s. I have 6 superdisks and the drive treats all 6 disks in the same manner.
    Last edited by Den2016; December 17th, 2017 at 09:24 AM. Reason: Add a comment

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •