Image Map Image Map
Page 51 of 51 FirstFirst ... 414748495051
Results 501 to 503 of 503

Thread: XTIDE Universal BIOS v2.0.0 beta testing thread

  1. #501

    Default

    Good news everyone!

    Malc kindly tested and benchmarked the new transfer mode on his 5160 with an 8088 CPU and it works just fine and is approximately 10% faster than the XTIDE rev 1 device type/transfer mode so I have committed the new code to the repository. In other words, r601 is out.

    Binaries available here.

    (I would still very much like to see benchmarks from the target machines).
    Looking for a cache card for the "ICL ErgoPRO C4/66d V"

  2. #502
    Join Date
    Aug 2006
    Location
    Chicagoland, Illinois, USA
    Posts
    5,598
    Blog Entries
    1

    Default

    Quote Originally Posted by pearce_jj View Post
    I've wondered for some time why databases from the time didn't write to disk partitions directly, it would have been a lot faster with such tiny cpu and ram. Or use FAT12 at least.
    Compatibility. Some devices were only addressable via DOS (ie. no int 13h interface). Also, in some cases, programmer naivety; in other cases, code was ported over from CPM for a set fee (or time limit on the contract).

    Quote Originally Posted by Krille View Post
    Malc kindly tested and benchmarked the new transfer mode on his 5160 with an 8088 CPU and it works just fine and is approximately 10% faster than the XTIDE rev 1 device type/transfer mode so I have committed the new code to the repository. In other words, r601 is out.
    Nice. I'm still planning on testing on 8086 and NEC V30 to measure any gains (unless someone else beats me to it).
    Offering a bounty for:
    - The software "Overhead Express" (doesn't have to be original, can be a copy)
    - A working Sanyo MBC-775, Olivetti M24, or Logabax 1600
    - Documentation and original disks for: Panasonic Sr. Partner, Zenith Z-160 series
    - Music Construction Set, IBM Music Feature edition (has red sticker on front stating IBM Music Feature)

  3. #503

    Default

    wow and the auto build script is still working

    http://www.xtideuniversalbios.org/binaries/r601/

    Nice work Krille.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •