Image Map Image Map
Page 1 of 4 1234 LastLast
Results 1 to 10 of 35

Thread: 486 to 386 problem

  1. Question 486 to 386 problem

    I have a FX-3000 Rev: 1.0 motherboard with a i486SX-25 CPU installed and no cache memory (Iíll list more details below). Iím trying to downgrade it to a AM386DX-40 CPU. The problem is that the computer detected it as a 16 MHz processor instead of a 40 MHz. I checked all the jumper settings and BIOS and canít find why its running at a low clock speed.

    Can anyone suggest anything about this problem?

    4 MB
    BIOS type: 40-0100-001131-00101111-121291-UMCAUTO-F
    Diagram/Jumpers settings: http://www.peteweb.com/ftp/user-submitted/us3486.zip

  2. #2
    Join Date
    May 2006
    Location
    Melbourne, Australia
    Posts
    6,129

    Default

    It is possible that when the manufacturer states, "Supports 80386DX,80487SX/80486SX/DX/DX2 at 25/33/40/50/66MHz', they don't mean all of those CPUS at all those speeds, just particular combinations. I think that's unlikely.

    Could be one of those motherboards where setting certain RAM speeds limits available CPU clock speeds (and vice-versa).

  3. #3
    Join Date
    Jun 2003
    Location
    Bellevue, Colorado
    Posts
    2,437
    Blog Entries
    1

    Default

    iirc, not many of those machines of that era detected much of anything, and you have to set it bios. Can you get to the bios? If you can, look for a setting that you can change. Also, I didn't even know that there was a 40mhz 80386. Look at the actual chip and see what it says. It might say 16mhz.

    Nathan
    The ancients knew *more* than us...
    http://www.legendarytimes.com/forum/index.php They're baaaack!

    Come and see http://www.gamegavel.com for all your gaming needs! We have Zero-ohm resistors!

  4. #4

    Default

    I've got some Karlnet wireless Brouters that are based on a 40mHz AMD 386.

    -Jason
    My Site (under construction!) | My Apple Lisa 2/10

  5. #5
    Join Date
    Apr 2003
    Location
    Saginaw, MI, USA 48601
    Posts
    8,763
    Blog Entries
    9

    Default

    Modem7 may be on the right track with the memory thing. Check the settings and try some tweaking. Also, are you using a 387 on the board too? Be sure it is the same speed as the 386. Some boards support asynchronous operation, and some do not. On a board that supports only synchronous, it might kick the CPU speed back to match the NPU.
    On my '386 board is a jumper to select between 33MHz & 40, but it's always been flakey when run at 40, so I just keep it set back to 33, although both chips are rated for 40.

    --T
    Teach your children how to think, not what, and hold 'em close, not tight.
    _____________________________________________

    Please visit the Vintage-Computer Wiki. Contributers welcome.

  6. #6
    Join Date
    Jun 2003
    Location
    Bellevue, Colorado
    Posts
    2,437
    Blog Entries
    1

    Default

    Quote Originally Posted by compu_85
    I've got some Karlnet wireless Brouters that are based on a 40mHz AMD 386.

    -Jason
    Ah, I stand corrected. I looked in my little box o' processors and found a 40mhz 386. I guess I said that cause I never had one of those actually inside of one of my machines. It's in the box, though.
    The ancients knew *more* than us...
    http://www.legendarytimes.com/forum/index.php They're baaaack!

    Come and see http://www.gamegavel.com for all your gaming needs! We have Zero-ohm resistors!

  7. #7

    Default

    I should have spotted that earlier. Intel only went to 33MHz on their 386 class processors. AMD had a 40Mhz.

    My workhorse vintage system for programming has one of these with a 128K L2 cache and it is quite competitive with low-end 486s except for the lack of floating point.

  8. #8

    Default

    Quote Originally Posted by NathanAllan
    iirc, not many of those machines of that era detected much of anything, and you have to set it bios. Can you get to the bios? If you can, look for a setting that you can change. Also, I didn't even know that there was a 40mhz 80386. Look at the actual chip and see what it says. It might say 16mhz.

    Nathan
    It won't have a bios/cmos setup, it will have only the jumpers which you have to set the correct bus speed by.
    Last edited by Jorg; June 30th, 2006 at 06:56 AM.

  9. Default

    I donít have a coprocessor installed. This computer does have a BIOS. The information in the zip folder shows that there are no jumper settings to change the clock speed. As for the BIOS, there are no settings to change the clock speed either. I tried changing the memory speed but that had no effect.

    CPU type: A80386DX/DXL-40

  10. #10

    Default

    There is probably an undocumented jumper for selecing the speed for a 386 CPU. Are there any on the motherboard that don't appear in the gif image, or that are not documented in the text file?

    I found a few "similar" motherbords where J4 would select a 20MHz clock or 16MHz clock for the 386.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •