Image Map Image Map
Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Poorly Philips P2000C

  1. #1

    Default Poorly Philips P2000C

    Hi

    I just acquired a Philips P2000C. This is a luggable CP/M machine with a dinky 9" screen and twin Teac FD55 drives (DSDD 640k). However, it is not working. At boot up it shows a random pattern of graphics characters. I say random, but it is always the same pattern each time I boot, so not like a PET boot screen.

    The machine has a CPU board with a separate "terminal" board that is connected to the CPU board via a TTL level serial link, so the display looks like a dumb terminal to the computer.

    According to the technical manual, the machine waits until the terminal board sends two characters. Only then will it proceed to boot.

    So I'm thinking the terminal board is suspect. Does anyone have any clues on how to proceed?
    Last edited by JonB; March 29th, 2015 at 07:53 AM.

  2. #2

    Default

    Interesting. It is showing a more regular pattern now. If you look closely at the attached image, you can also see some tiny bars one pixel high and about 8 wide at irregular points on the display. These are not static; they flit around randomly, so I think it is trying to do something.

    image.jpg

    Other than the little bars, the image is rock steady, does not appear to be rolling.
    Last edited by JonB; March 29th, 2015 at 07:54 AM.

  3. #3

    Default

    Update: The terminal board is definitely not working. By connecting its serial port to a PC via USB serial interface, I can see the boot prompt (after sending a couple of characters). The PC port is connected via a small line driver board (TTL to RS-232 voltages via a MAX232) like this:

    Code:
    P2000C  RS-232
    Serial
    conn
    -----   ------
    1 TxD - RxD
    2 RxD - TxD
    3 CTS 
    4 RTS
    5 NC
    6 GND - GnD
    CTS/RTS are not connected. Serial parameters in Hyperterm are 19200 baud, 8 bits, 1 stop bit, no handshake. Power up the P2000C and hit a few keys and I can see:-


    Code:
    IPL-1.1
    
    SYSTEM DISK?
    ..so it looks like the CPU card is OK. Inserting a disk gives activity, but the drive just buzzes, stops, and then the SYSTEM DISK? prompt comes up again. None of the disks I have will boot; whether that is because they are all zapped or the machine is not working I cannot tell right now. I suspect the former.
    Last edited by JonB; March 29th, 2015 at 07:55 AM.

  4. #4

    Default

    (Duplicated post, deleted)
    Last edited by JonB; March 29th, 2015 at 07:16 AM.

  5. #5

    Default

    Thought maybe drive 1 was defective so tried swapping the drives but it's still doing it. So now I have connected a pair of external drives, 3.5", and disconnected the internal ones. I should now be able to get a boot disk going from a downloaded image..

    Update: OK, HxC floppy emulator is connected. I have tried images from here:

    http://electrickery.xs4all.nl/comp/p2000c/floppyImages/

    ..but none of them will boot. I get the same buzz from HxC as I do from the drives, then back to the "SYSTEM DISK?" prompt. (To transfer to HxC I am converting them to .hfe format using the HxC PC software load / export function, and the images are all recognised as 80 track DS.)
    Last edited by JonB; March 29th, 2015 at 07:17 AM.

  6. #6

    Default

    For reference the serial circuit is shown here. Highlighted are the pins for the internal connection to the terminal board.

    P2000C Serial.jpg

  7. #7

    Default

    I'm running out of ideas...

    At the "SYSTEM DISK?" prompt you can enter the debugger by pressing ESC.

    There are various commands you can execute, including some to read / write disk tracks.

    They are shown in section 2.2 of the technical service manual.

    When reading a track from a 5.25" floppy I am getting:

    40 01 00 00 00 01 01

    It is supposed to be the uPD765 floppy controller's RESULT byte or OK if successful, but I am not sure what I'm seeing here. 40 may be the result byte but I don't know how to interpret it. I looked at the datasheet for the controller and it mentions the main register and four others, but only gives the meaning of the four registers. I am not sure if one of these is the "RESULT" byte, or if it is the status register.

    When attempting to read from the HxC I get the same result starting with 40.
    When attempting to write to the floppy, I also get 40 01 00 00 00 01 01.
    When attempting to write to a write protected floppy, I get 44 02 00 00 00 01 01. I think the second byte may be register 1 as bit 1 (as in "02") means "Write protected".


    I do not know how to interpret these results, can anyone suggest a way?
    Last edited by JonB; March 29th, 2015 at 07:57 AM. Reason: Just realised floppy was inserted upside down... so retested and altered results

  8. #8

    Default

    Main status register..

    uPD765 FDD main status register.JPG

    Doesn't look like any of those are describing error conditions (and the datasheet says it is readable anytime, whereas the other registers are result sets that should only be read after an operation completes).

  9. #9

    Default

    Just testing with a longer seek.

    Command "DR 179" means disk read from Floppy 1 Side 1 track 79. This gives a longer buzz (the head is moving further) and a different result of:-

    Code:
    40 01 00 4F 00 01 01
    It is trying to tell me something, but what?

    In case anyone fancies a go, the service manual is here: http://electrickery.xs4all.nl/comp/p...viceManual.pdf and the debugger program is described on p.335 of the PDF.

    Edit 2: Tested using a different track. If I ask it to read a track, say 60, byte 4 of the return value is showing the track number in hex. Works with other tracks too. When attempting to read from Drive 1 I get byte 1 as "41" instead of "40" for drive 0. And asking it to read side 2 of drive gives "45", so I conclude that the lower nibble of byte 1 is the drive side parameter of the command, and byte 4 is the track.
    Last edited by JonB; March 30th, 2015 at 04:04 AM. Reason: Add link to service manual

  10. #10

    Default

    Could it be that you have a RAM problem? The screen gives garbage and the machine does not boot. The IPL (assumed to be working from ROM) and serial port work. The video screen is visible and stable, so the MC6845 is initialized. The FDC765 responds properly.

    Is there a RAM test in the IPL ROM? Having the service manual on my site does not make me an expert on the P2000C. In this case I did not even scan it myself, just copied the files .

    The machine appears to read the boot track and then stops. Apparantly the boot track did not land in RAM, or is not readable.

    Fred Jan

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •