Image Map Image Map
Results 1 to 4 of 4

Thread: Booting a Geneve 9640

  1. #1

    Default Booting a Geneve 9640

    I'm having some problems trying to boot my Geneve+genmod(but with no memex card ) from my PHP1240. As it only (for now) supports DSDS disks, I've tried to fit a MDOS boot disk into 180K, I've follow these steps:

    - The PHP1240 has been tested with my TI-99/4A and it seems to work fine, reading flawlessly all the disks (3.5" type) I've write in my PC with TI99-PC.
    - As it doesn't have the 64K SRAM upgrade, I'm stuck with old MDOS versions. I've found 2.11 and 2.21 (the last one compatible).
    - None of them come in disk image format, both are .ARK files; so I've extracted the files first using TIDir and building a pair of 180K disk images with TIImageTool.
    - The Geneve BIOS (with genmod) 1.00, after showing "LOADING MDOS" tries to boot from disk and drive led lights up; but it displays a message telling me that the disk can't be read. Looks like it's really trying to read it as swapping the boot disk with another TI-99 one, changes the message to something like "no boot file found".

    - Am I missing anything while creating the boot disk?. Both images have the "SYSTEM/SYS" file that I believe it's the only required to boot.
    - Do I need to upgrade the SRAM to 64K?. If so, how can I reach pin 48 of the gate array?, may I solder the cable in the same pin in the genmod board (see red arrow in the pic below)?.


    A little update:

    I've been able to boot MESS with my SSDD 2.21 disk image. It has been a bit "messy" indeed; as I don't want a memex card, I've configured MESS without memex and used a "No GenMod" BIOS 1.00, the Geneve boots MDOS with TIFDC controller + 32K SRAM. So, the disk image at least seems to be good.
    Given the above result, I've burnt an EPROM with the NoGenMod 1.00 BIOS and tried it in my Geneve. Leaving GenMod "TI mode" switch on (leaving it off gives "BAD CPU RAM FOUND") the drive is accesed; but again with no luck, "CAN NOT READ FROM FLOPPY DISK" it's displayed.
    Last edited by jltursan; April 12th, 2015 at 02:58 AM. Reason: Update info

  2. #2

    Default

    Doh!, problem solved!

    I was creating the wrong format boot disk. After creating a real DSSD one, the Geneve boots 2.21 flawlessly


    Now I need to figure out how to upgrade SRAM with the genmod attached over the gate array. It must be a common setup (genmod+64K SRAM); so, I'm sure it has been done before...

  3. #3

    Default

    Do you have the MEMEX memory card to go with your GENMOD? Those came in 512K versions (no GENMOD required) or 2MB versions which required the GENMOD to recognize all memory past the first 512K. I have one of the 2M cards, but I still have to take the time to install my GENMOD hardware to get the rest of the card recognized. . .
    Enter My Mind At Your Own Risk!

  4. #4

    Default

    No, I don't have the MEMEX memory card , the GenMod in my Geneve is basically useless right now...

    The problem I see with the GenMod is, how to solder the extra wire the 64KB SRAM mod needs if the pin 48 is covered by the little GenMod PCB?, the pin is already exposed through the PCB; but I'm not sure if I can use it without interfere with the original GenMod GALs.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •