Image Map Image Map
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Sharp PC-7000 floppy drive problems

  1. #1

    Default Sharp PC-7000 floppy drive problems

    Hi,

    I have a Sharp PC-7000 whose B: drive is not working correctly. Some disks read just fine, while with others it will act like they have bad sectors. When you try to write to the disk it usually fails, again acting like the disk has bad sectors. When you format a disk, it always formats only one side, the side on head 0.

    The computer was like this when I originally got it, and after I cleaned the heads (Q-Tip and 91% isopropyl alcohol) the drive worked just fine. Then when I once put in a disk that turned out to be rotten, it screwed up the drive, but it was fine after I cleaned it again. The drive worked perfectly for two weeks, and then randomly failed the same way again. Since then I've cleaned the drive five times, and it won't come out of it.

    Any ideas? What side of the disk would head 1 be on? Note that this is a portable machine, and the two drives are one proprietary module with a single connection to the motherboard.

    Thanks!

  2. #2
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    33,689
    Blog Entries
    18

    Default

    That's the Sharp with the Epson drive, isn't it? There's a chance that you messed up the head supports and that both heads no long contact the media.

    For reference, the side that the label goes on is head 1; the reverse side is head 0.

  3. #3

    Default

    The drives in this unit are made by Canon. If both heads were no longer contacting the media, wouldn't the drive not work at all? After formatting a disk as single-sided, it works perfectly as such, so only head 1 is not working.

    Interesting that head 1 is the label side. On these drives, one of the heads are epoxied (or whatever) in place and the other is on springs and moves around a bit. For the B: drive, I expected the moveable head to be at fault, but that turns out to be head 0, so it's the one that's working.

  4. #4

    Default

    Using the correct tools never hurts. In the long run you may discover that if you had used a cleaning disk to clean the heads instead of that HAMMER, uh, Q-Tip, this problem might never have occurred. Of course I'm only guessing here but in 25 years of routinely cleaning floppy drives with cleaning disks and never anything else I've never had anything but 100% success.
    PM me if you're looking for 3" or 5" floppy disks. EMail For everything else, Take Another Step

  5. #5

    Default

    I've heard as many people suggest manual cleaning over cleaning disks as I have heard the other way around, so I just do what has always worked for me. Mockery does not aid the problem at hand.

  6. #6

    Default

    I'm still dealing with this problem with this computer - if anyone has any ideas regarding what to try to fix this, it would be much appreciated. Sarcastic jabs regarding head cleaning methods not necessary.

  7. #7

    Default

    From what I understand the correct procedure for manual cleaning is to use lint-free q-tips. Well at least for video heads. Have you checked if there are any tiny fibers on the heads. My theory being, that the drive works for a while, until lint gets in the way of the head. It may push the head away from the disk. For the bottom head, gravity works in your favor.

    Alternatively, you may be pushing the top head into alignment, when you clean it, and over time, the disk pulls it out. There should be a screw that aligns the head, if it is loose the head will have play in it.

    Edit: by loose, i mean ever so slightly, just enough for the disk to slowly pull it sideways.

  8. #8
    Join Date
    Jan 2013
    Location
    Marietta, GA
    Posts
    3,374

    Default

    If it won't format a disk, then it probably isn't alignment. That would just keep it from reading other disks.

    Cleaning disks are very handy for quick periodic cleaning, but sometimes heads can get so fouled they need a good scrubbing with a q-tip. The "correct" way is whichever one works

    Although I have a suspicion it may be the head 1 assembly or head damage. I have a couple of Mitsubishi drives that behave like that - if I press down a little on head 1 while it is operating, it will work. But there is nothing obvious wrong with the assembly and it seems to be putting the correct amount of pressure on the head.

  9. #9

    Default

    Okay, so I'm now severely questioning my head cleaning method, because I've just had the exact same thing happen to a drive on another computer. I was testing a disk that turned out to be rotten, and shed a bunch of material onto the heads, making the drive unusable. I cleaned the heads, and now the drive won't read a lot of disks, and the drive thinks any disk I try to format in it is single-sided, and formats only on the head 0 side. On this drive, head 1 is indeed the one that moves around on a spring-like assembly.

    So despite being gentle, now I'm wondering if I actually am screwing up head 1 on all my drives with Q-tips. I've done an uncountable number of 3.5" drives with this method over the years, with 100% success, but now I've messed up two of the total of five 5.25" drives across my computers.


    EDIT: I've just discovered something. I noticed that when a disk is in the drive (the other drive, not the Sharp's), head 1 floats maybe a millimeter above the disk surface. I decided to go out on a limb, and lightly press down on the head 1 assembly while attempting to use the drive. And by god, it works perfectly when I do that. So it looks like my cleaning procedure has bent either the head itself or the assembly slightly upward, such that it sits too high during use. So I wonder if this is the same case for the Sharp.
    Last edited by TheMaritimeMan; September 30th, 2016 at 06:11 PM.

  10. #10
    Join Date
    Jan 2013
    Location
    Marietta, GA
    Posts
    3,374

    Default

    Well, if it happened right after a disk shed a bunch of junk, then it may still be that there is gunk that your q-tips aren't getting. I recall one time when that happened to me, and I wound up using some flattened paper towels with isopropyl alcohol, moved them around with the heads "closed" - and that visibly pulled out a pile of brown gunk that a q-tip failed to get. I don't know if a cleaning disk would have worked just as well, I didn't have one for that drive at that time. Not sure why the q-tip failed that time (perhaps the angle of the heads?), as that usually works.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •