Image Map Image Map
Page 6 of 6 FirstFirst ... 23456
Results 51 to 58 of 58

Thread: What are typical issues for Toshiba T1000LE's?

  1. #51

    Default

    Yeah. I'm sorry I couldn't be of any help. Good luck with your PowerBook!
    Looking for: Tandy TRS-80 Model 100/101/102, Macintosh LC III/Performa 450, working Zenith Z-171 floppy drives

  2. #52

    Default

    Has anyone ever figured out what’s up with these? I just got one of these, recapped it, and it’s still just giving me the blinking “DC-in” light. This is the THIRD vintage Toshiba laptop I have bought that hasn’t worked. Why is the power supply circuitry in these so bad? Does anyone know of a fix? I’m really beginning to loathe the Toshibas.

    Their gas plasma portables (like the T3100e) are much better than their battery-powered laptops, it seems.

    It’s really sad, because this is one of the coolest XT-class laptops I have seen. Has a removable hard drive, high-res CGA display, a great keyboard, really everything you could ask for.
    Compaq - “It simply works better”

  3. #53

    Default

    Well, I found where someone fixed theirs with similar symptoms to mine by replacing a particular mosfet, so I have ordered a replacement and we’ll see what happens...
    Compaq - “It simply works better”

  4. #54

    Default

    Well, that didn’t fix it, and I tried some other things that didn’t help either. No more early Toshiba Laptops for me until someone figures out what’s up with them. I’ll stick with the gas plasma portables for Toshibas, which are much more reliable.
    Compaq - “It simply works better”

  5. #55

    Default

    I have 2 T1000LE's and a T1200XE that all had these symptoms.
    The T1200XE was fixed relatively simply by replacing all electrolytics and works perfectly fine to this day. The T1000LE's are a bit of a headscratcher.

    I replaced all capacitors in the first one I got but it still didn't work. After replacing the Q502 MOSFET, which was clearly gone, the machine worked fine for a while.
    After some time it stopped working in fast mode (9.54MHz), crashing as soon as it got through the BIOS POST, but worked fine in slow mode (4.77MHz).
    After again some time it stopped working all together with the same "blinking DC IN LED" problem, I have not gotten back to this machine.

    The second one worked like a charm after replacing all capacitors but soon after stopped working. Again, same symptoms.
    I opened it up again yesterday to find Q502 burnt on this one too.

    I think I have one of the required 2SJ182 MOSFETS in stock but I'll order a few of them so I can test.
    At this time I have not found exactly what that MOSFET is for but it seems to be an inegral part of the power supply as the computer does not work without it.
    It does some high-frequency switching of pretty high (for a 12V system) voltages, more on that in a later post.
    It also seems that these MOSFETS tend to blow up when a capacitor is shorted or leaking. Though I replaced all of the through-hole ones the quality of some could be questionable.

    I'm determined to find out what is up with these machines and their power supplies, I really like them.
    I had one years back that had the exact same symptoms that I eventually threw out so it seems it is not uncommon for them to fail in this way.

  6. #56

    Default

    If you find it out, please post here. I would love to fix one of these. Then I would actually have something good to say about them for a change.
    Compaq - “It simply works better”

  7. #57

    Default

    I acquired a third machine last week and replaced all the electrolytics on it with high-end Panasonic and Würth capacitors. I also cleaned the board with soapy water and IPA and reflowed some components.
    This machine now works flawlessly which allowed me to take some measurements, see attached images.
    Could you try to see if your machine matches these?
    I also started reverse-engineering the PCB as schematics are more descriptive but that will take time on this (at least) 4-layer PCB.

    I also posted about this on my blog where you can see the high-res pictures and the oscilloscope traces (TP1-6): https://thomwijtenburg.nl/2020/05/27...e-t1000le-psu/

    Caps-and-FETs-Annotated-768x1024.jpg
    Jumpers-annotated-768x1024.jpg

  8. #58

    Default

    I've managed to fix mine and I think it's permanent this time. It has been running fine for a couple of days now.

    It turns out there were some traces running to and under IC501 that got severly damaged which prevented the PSU from stabilizing.
    I also suspect that some of the caps I used in that machine were the root cause for it not running in fast mode and failing to boot altogether after a while.
    Also I imaginge that this caused Q502 to blow as there was a lot of ripple and ringing on that transistor caused by out of spec caps.

    On this particular machine (I call it machine #1) the voltages on the pins in my previous post were way below what they should be.
    Around 4V on the 5V power rail and only 10V and -12V on the 12V and -22V lines respectively.

    After replacing all the cheap Chinese caps with Würth and Panasonic-brand low-ESR ones and fixing the broken traces the machine runs perfectly fine, even in fast mode. No overheating components either.

    My advice would be to check that your board has no damanged traces and replace the caps with quality brand (Panasonic, Würth, Nichicon and the likes) low-ESR 110°C ones.
    Also check that no electrolyte has gotten underneath SMD components and has eaten away at traces of vias.

    If you want to I can cross-check any voltages or signals on one of my machines but I think the root of the problem is cheap caps that can't handle the load of being in a switch-mode powersupply causing brownouts and noise in the PSU.

    More detailed pictures can be found on my blog

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •