Image Map Image Map
Results 1 to 3 of 3

Thread: Xt-ide on ibm eduquest finally cracked

  1. #1

    Cool Xt-ide on ibm eduquest finally cracked!

    My friends, I have finally solved the problem with XT-IDE cards not working with IBM Eduquest computers and am happily booting it from my 8Gb cf card and playing all my old dos favorites.
    I found someone who had an Eduquest 50 for sale for cheap and of course the first thing i did was remove the 80Mb hard drive and install my XT-IDE and CF into it.. NOPE! I quickly found that no matter what i did, the computer would simply refuse to see and boot from the XT-IDE card.. WHY GOD WHY??? After searching the internet and finding others simply unable to get it to work i studied it a bit more... Then finally it hit me..


    The IBM Eduquest line of computers simply WILL NOT accept any other boot room as a primary because it ALREADY has dos built-in on a rom in U39 on the PCB. seen here http://www.walshcomptech.com/ps2/eqm40.htm

    In bios setup you can select between boot order consisting of Floppy, Fixed Disk, network, and boot rom. The first thing i tried was to remove the rom in U39 and then see if it would try booting from the XT-IDE and NOPE. It still expects to see the rom THERE and will look no where else.. Looking at that dos rom in U39 i realized it had the same pinout as the boot rom on the XT-IDE card and figured "What the hell, lets see what happens" and removed the dos rom from U39 and installed the XT-IDE rom into U39, booted to bios settings, and set the boot order to Floppy, Dos rom, Network, Fixed disk, and then saved and rebooted.

    Now at this point, I dont even have the XT-IDE card installed, i'm just trying it for the hell of it with the XT-IDE bios installed into U39 on the Eduquest motherboard..
    It goes through the memory count, a 221 error quickly flashes on the screen, then the next screen i see is the XT-IDE BOOT PROCESS and it is looking for a device at 300h... (Gratuitous happy dance at this point)

    I quickly turned the Eduquest back off and installed the now "ROM-LESS" XT-IDE card back in and connect my CF card to it and turn the computer back on and it boots and then reads from the CF card as if the rom was still on the XT-IDE card and boots to the dos prompt..
    Next i installed my Soundblaster AWE64 ISA card with 32Mb wavetable addon and started playing doom on it.. I can post some pics if yall wanna see and plan on making a Youtube Video showing it working with how to steps very shortly.

    I really thought i was going to have to throw in the towel on this one.. damn im happy right now =) Next upgrade will be an Overdrive processor in the 487 socket to give the 486 SX/33 something to look up to lol


    This should surely help breathe new life into The Eduquest Line of IBM's!
    Last edited by custm42435; September 29th, 2016 at 05:59 AM.

  2. #2
    Join Date
    Feb 2006
    Location
    Jacksonville, Florida
    Posts
    1,324

    Default

    Good work and thanks!
    I'll have to try it out!

  3. #3
    Join Date
    Mar 2010
    Location
    Florida, USA
    Posts
    1,964

    Default

    Thanks for posting about this! I have an eduquest forty-five, and while the HD works fine, I'd like to expand out the hard drive at some point - this info is now filed away!
    ---
    Currently seeking:
    * Roland MPU-401/AT (with daughter card header)
    * Magitronic K-156 Keyboard (5pin DIN w/ XT-AT switch)
    I also collect PC and C64 Sierra On-Line software!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •