Image Map Image Map
Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Model II Boot ROM Analysis

  1. #11

    Default

    For those who want to take a crack at it, I've found 2 versions of z80ctl in the directions to use a model 2000 keyboard on a 6000. One is for using the keyboard (z80ctl) and one I think is used with the unreleased 4 port serial cards (I have 4 of them).

    Here they are.
    Attached Files Attached Files

  2. #12

    Default

    Pete

    Bit of thread archeology.

    Given my Model 16A issued with DREM occurs when the HDC tried to boot a hard disk image but works when using diagnostic software booted from a floppy you indicate that the ROM is switched out.

    Therefore could my CRC error on first read issue be ROM version issues where the type 4 board boot isn’t supported by the ROM image ?

  3. #13

    Default

    Can you pull the CPU card out of your 16 and see if there is a label on the ROM? Some are labeled with a number that contains the checksum.

    I run C9AC (9733) in my M16A and and it is likely the latest official BootROM.

    If you have an eprom writer the binary for that ROM is here: https://github.com/pski/trs-xenix/tr...troms/pskiroms I use 28c16 (cat28c16a) eeproms in my machines without issue.

  4. #14

    Default

    If you run MEMII (option 7) from the menu on this diagnostics disk and select the Shadow Rom Checksum option it will identify what bootrom is in your machine.

  5. #15

    Default

    Ran the test, ROM reports back a checksum of F42A

    Pete, I note this isn't on you're list of ROM's so when i pull it, i'll grab a copy and send it over.

    I've no 2716's in stock at the moment, just 2732's and 27128's, so i'll have to order some, and thanks for the note that you're using 28c16's fine.

    Steve

  6. #16

    Default

    Quote Originally Posted by Tarkie101 View Post
    I've no 2716's in stock at the moment, just 2732's and 27128's...
    Hi Steve,

    You can usually get away doubling up your 2716 image and burning it into a 2732. The 2716 has vpp where the 2732 has address line A11, but it just means only one "half" of the 2732 will be accessed.

    Steve
    CP/M-86 Software Repository www.eolith.co.uk

  7. #17

    Default

    Ah good call, although I've ordered a couple from ebay.

    I'll see if i can fix the video chain issues on my model 1 while i wait The 74LS11's for that arrived yesteday.

  8. #18

    Default

    Quote Originally Posted by Tarkie101 View Post
    Ran the test, ROM reports back a checksum of F42A

    Steve
    That's definitely an issue for you, Steve. F42A only supports the older 8x300 controller found in the 8MB, 5MB and 12MB drives. See Model II Tech Bulletin II:33.

  9. #19

    Default

    Anecdotal but when I attempted to use my 16A with its stock boot rom (88E2) it acted like no HD interface was installed and presented the "INSERT DISK" message rather than a BOOT ERROR HC. After replacing the rom with C9AC (9733) it booted from HD without issue.

  10. #20

    Default

    Thanks both, encouraging.

    Given the DREM works when the shadow rom is paged out, and im in diagnostics, its certainly looking positive.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •