Image Map Image Map
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: CP/M Plus for Model II

  1. #1

    Default CP/M Plus for Model II

    I was able to rescue a close to pristine copy of CP/M Plus for the Model II today. This is one that I have been hunting for quite a while.

    You can find it here

    https://github.com/pski/model2archiv...CPM/CPM%20Plus

    It has a few customizations as far as I can tell:

    1. PROFILE.SUB set up for a dual disk
    2. ED.COM is missing
    3. Includes MBASIC.COM

    I'm sure there may be more issues, but from my non-CP/M expert perusal though it looks pretty clean. I invite the CP/M experts here to take a look and perhaps submit a cleaned up copy for the archive.

    I'm also not sure if there were other disks or utilities as part of the Model II CP/M Plus package. I have the Model 4 CP/M Plus set and it comes with 5 disks, including a Banked version.

    Anyone know more details?

  2. #2

    Default

    I think the original CP/M 3 documents from DRI are helpfull.


    http://www.cpm.z80.de/manuals/

    hc_1516.jpg

  3. #3

    Default

    Hi Pete

    CP/M Plus, hooray!

    I loaded the image onto the HxC emulator but it will not boot. It first comes up with "TRS-80 CP/M PLUS" in reverse text in the centre of the screen, then I see "Loading CP/M Plus ....." followed by "`? OVL", then "LINKING". A short while later there is an error displayed at the bottom of the screen: "READ ERROR: DRIVE A,TRACK=1B,HEAD=01,SECTOR=11: STATUS=10". It offers retry (any key) or cancel (break key or ^C) but selecting either has no effect, other than to make the screen flash and the error is displayed again.

    This is on a Model II with 64k RAM only, so if this version is for a banked system we are stuck. What is the memory specification of your Model II?

    I am wondering about the "LINKING" message. Doesn't seem like a standard CP/M boot message. Maybe there is an automatic submit job occurring that is failing. Can you confirm it is working on your machine, please? If so, there may be a problem with the image file in the archive, because Hans01 emailed me to say his copy won't boot either (although he didn't describe the symptoms).

    Cheers
    JonB

    [edit: Yours must be booting because you have included screen shots in the archive folder. Hmmm... bad news for me...]
    Last edited by JonB; November 6th, 2016 at 10:59 PM.

  4. #4
    Join Date
    Feb 2014
    Location
    Netherlands
    Posts
    431

    Default

    @Pete, JonB

    Yes, I have tried to run CP/M PLUS.

    I have first run it with the HxC emulator. To be sure I wrote a real 8" disk too.
    In both cases I got exact the same errors mentioned by JonB.

    I have try to run the image on MAME64 with the same results.

    If you take a look at this picture: model2archive / Software / CPM / CPM Plus / CPMPLUS-DirectoryListing.JPG
    There are two strange entries in the directory .PRN and .HEX. Is there something wrong with this image ?

    Does anyone has better results ?
    Last edited by Hans01; November 6th, 2016 at 11:32 PM. Reason: Add some extra info.

  5. #5

    Default

    Strange. I'm getting that error now too in Mame. But, I ran it multiple times in Mame a few days ago and even wrote a disk and ran it on my MII and it worked just fine. Something got messed up in between. Let me investigate and get back to you.

  6. #6

    Default

    Quote Originally Posted by Hans01 View Post
    If you take a look at this picture: model2archive / Software / CPM / CPM Plus / CPMPLUS-DirectoryListing.JPG
    There are two strange entries in the directory .PRN and .HEX. Is there something wrong with this image ?
    There may be something wrong with the image that is causing these odd filenames (.prn and .hex aren't necessarily corrupted files. Try 'pip test.prn=pip.com' followed by 'ren .prn=test.prn' and see what happens... funny thing is the built in commands like ERA accept a filename such as '.prn' but pip doesn't).

    However, because the system Pete has photographed is already booted and contains the two odd files, I conclude that they are not the cause of our inability to boot.

    Cheers
    JonB

  7. #7

    Default

    The .prn and .hex fiels are made by MAC, the CP/M 3 macro assembler. Someone did run mac, maybe for test purpose.

    MAC, the CP/M 3 macro assembler, reads assembly language statements from a file of type .ASM, assembles the statements, and produces three output files with the input filename and filetypes of .HEX, .PRN, and .SYM. Filename.HEX contains INTEL hexadecimal format object code. Filename.PRN contains an annotated source listing that you can print or examine at the console. Filename.SYM contains a sorted list of symbols defined in the program.



    Look here:

    http://rvbelzen.tripod.com/cpm/asuthelp.htm#mac

  8. #8

    Default

    Yes, it's not those files causing the issue as it ran fine for me just as you see.
    I'm thinking there was maybe an issue in copying somewhere.
    Will take a look tonight.

  9. #9

    Default

    I can understand why RS took their time with this release, and dropped it into an abyss after the copies were sold. By the time this and the Model 4 version were released, the CP/M Plus parade was over, and people returned to the relative comfort of 2.2. The banked versions of both the Model II and 4 versions are even more temperamental beasts.

    What Pete has imaged is someone's working copy of the unbanked version of CP/M Plus, as part of a disk set for booting CP/M-68k. I had hoped that Pete would be able to image the other disks in order to find out exactly how he managed this feat (CP/M-68k on CP/M Plus - it was a challenge on Pickle and Trout's own CP/M 2.2)

    From looking at the Boot track, I can see why it's not making anyone happy. The code in the BOOT sector does the usual (disable interrupts, switch the ROM out, select RAMbank 1, set up the CTRC [just register 10, set cursor to line 5, but don't display on screen], check the keyboard, swap the VIDRAM in, displays 'TRS-80 CP/M PLUS'). From there they get a little DMA Reset happy - Reset the DMA, select and restore Drive 0 to Track 0; Reset the DMA, check to see if we're at TRK0, then Step In to Track 1; Reset the DMA, Set the sector (1 in this case); Reset the DMA, and LOAD the DMA up to funnel 8192 bytes of track 1 to Memory, then enable the DMA before telling the FDC to read the Sectors!

    I'm fairly sure this method was not best practice, and if the timing between the FDC and DMA was even slightly out of spec would cause the load to fail, as it has on the HxC, Mame and my emulator. When I tried the image twice with Mame, it filled memory from 0900 to 28FF with different data. A variation of this is most likely what's causing the BDOS error, too. I haven't looked at the BIOS yet.

    Pete, JonB and Hans01, had your Model IIs been powered up for long when you put the disk in and booted? I'm thinking that as the FDC and DMA heat up, the datarate slightly changes, enough for the DMA to drop the first couple of bytes, or there is an overrun in the FDC and it just emits garbage. Also, are you running with the RevC FDC cards?

    Aaron

  10. #10

    Default

    Ok, I'm not crazy. I just tested the physical floppy I created from the IMD in my Model II and then I tested the IMD in my 6000 with an HxC and they both booted fine. Both of them were booted cold. I let the 6000 warm up for a bit and it continued to boot CP/M Plus just fine from the HxC.

    See the 2 videos here: https://www.dropbox.com/sh/shc9nmiq4...ZKdvMn7oa?dl=0

    However, I can't get it to work in Mame where I get the same error we've been seeing.

    Screen Shot 2016-11-07 at 10.36.31 PM.jpg

    I did notice a one-byte difference, other than the header, between the original IMD and the one I reverse-created from my HxC image tonight. However, the original IMD booted fine on on my 6000 as did the one on the HxC. And both failed to boot in Mame. I have included the HxC reverse-created IMD in the dropbox folder above for your reference as well as the HxC file.

    Screen Shot 2016-11-07 at 10.31.07 PM.jpg

    EDIT: Aaron, my MII has the later improved FDC.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •