Image Map Image Map
Results 1 to 2 of 2

Thread: Attempting to resurrect an Epson PX-8 Geneva

  1. #1
    Join Date
    Apr 2011
    Location
    San Francisco, CA
    Posts
    500

    Default Attempting to resurrect an Epson PX-8 Geneva

    Hi all,

    I recently found an Epson PX-8 at an estate sale, and I'm attempting to nurse it back to health. No success so far, but wondering if anyone may have some ideas.
    Here's what I've done so far:
    The unit did not have its original power supply, so using a bench power supply and connector I made the appropriate connections (center conductor GND, shield +6V) and plugged in. After about an hour I checked on the battery pack, and saw that it had in fact charged up to the nominal 4.8v. At this point I tried turning on the PX-8, and it beeped but the screen did not turn on. Tried later a couple of times, and once there was no beep but the three red LEDs (CAPS, NUM, INS) started blinking once a second or so. Another time the beep happened again, but again the screen did not turn on.
    I then unplugged the charger, removed the battery pack, and attempted connecting the bench power supply at the battery connector at the battery's 4.8vdc. I got the same result - sometimes there would be a beep, and sometimes the 3 blinking LEDs.

    After this, I opened the case and had a look at the motherboard. I saw the soldered-in nicad on the board, and did notice some corrosion on the positive terminal. Board in general was very clean though and did not notice leakage from any of the caps.
    My first guess is bad capacitors, or possibly bad RAM. Any ideas of where to start with this one? Thanks!
    - Mike

  2. #2
    Join Date
    Jan 2007
    Location
    Pacific Northwest, USA
    Posts
    32,464
    Blog Entries
    18

    Default

    I'd start with cleaning up around the NiCd--could be that some traces on the PCB have been compromised.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •